aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2010-08-17 07:18:15 +0800
committeracm <acm@FreeBSD.org>2010-08-17 07:18:15 +0800
commit2aa2bf91b309755e0e79205f53ee7a4f52cab0a6 (patch)
tree83c07138baa5fe5594b49eef2b00f71966a49f20 /editors
parent20f60b4e3dfe5bece631f8f23905e9f937648c91 (diff)
downloadfreebsd-ports-gnome-2aa2bf91b309755e0e79205f53ee7a4f52cab0a6.tar.gz
freebsd-ports-gnome-2aa2bf91b309755e0e79205f53ee7a4f52cab0a6.tar.zst
freebsd-ports-gnome-2aa2bf91b309755e0e79205f53ee7a4f52cab0a6.zip
- Add tools like a new target. It could be useful for compile some apps like
net-p2p/transmisson-remote-gui because it uses somes tools from lazarus tools directory Reported by: QAT
Diffstat (limited to 'editors')
-rw-r--r--editors/lazarus/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 76bcc5744f9c..b4ea4b993e70 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -73,6 +73,8 @@ post-patch:
do-build:
@cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${GMAKE} LCL_PLATFORM=${LCL_PLATFORM}
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} tools LCL_PLATFORM=${LCL_PLATFORM}
post-build:
@cd ${WRKSRC} && \
@@ -119,7 +121,8 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/${DIRE}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/${DIRE}/{}" \;
.endfor
- @${CHMOD} +x ${DATADIR}/tools/svn2revisioninc
+ @${CHMOD} +x ${DATADIR}/tools/svn2revisioninc ${DATADIR}/tools/lazres ${DATADIR}/tools/lrstolfm \
+ ${DATADIR}/tools/updatepofiles
.for FILE in lazarus startlazarus lazbuild
${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${DATADIR}