aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-02-16 06:03:07 +0800
committerobrien <obrien@FreeBSD.org>2004-02-16 06:03:07 +0800
commit3842a7df91776b6b192471fa779e9af311896d43 (patch)
tree7d87da87353a7251bb861db646fd7f836f727d66 /editors
parent141c8c574170bce4bd03562da47a747ab6e08bdb (diff)
downloadfreebsd-ports-gnome-3842a7df91776b6b192471fa779e9af311896d43.tar.gz
freebsd-ports-gnome-3842a7df91776b6b192471fa779e9af311896d43.tar.zst
freebsd-ports-gnome-3842a7df91776b6b192471fa779e9af311896d43.zip
Port was broken if you WITH_GTK=1. The USE_GTK needs to be modified to
occur before the .include <bsd.port.pre.mk>. Submitted by: kris
Diffstat (limited to 'editors')
-rw-r--r--editors/vim5/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index f2a51c4a7010..feb369b43cd5 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -38,18 +38,6 @@ MAN1= vim.1 vimtutor.1 xxd.1
MLINKS= vim.1 rvim.1 vim.1 rview.1 ectags.1 etags.1
MLINKS+= vim.1 gvim.1 vim.1 gview.1 vim.1 rgvim.1 vim.1 rgview.1
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500800
-BROKEN= "Does not compile with perl 5.8"
-.endif
-
-# Determine if we need xpg4.
-# No xpg4 in libc below 400020 and 500005
-.if ${OSVERSION} < 400020 && ${OSVERSION} < 500005
-MAKE_ARGS+= LIBS=-lxpg4
-.endif
-
.if !defined(LITE)
MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
@@ -83,6 +71,18 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp"
.endif # LITE
+.include <bsd.port.pre.mk>
+
+# Determine if we need xpg4.
+# No xpg4 in libc below 400020 and 500005
+.if ${OSVERSION} < 400020 && ${OSVERSION} < 500005
+MAKE_ARGS+= LIBS=-lxpg4
+.endif
+
+.if ${PERL_LEVEL} >= 500800
+BROKEN= "Does not compile with perl 5.8"
+.endif
+
pre-build:
@(cd ${WRKSRC}; ${MAKE} distclean)