aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-11-26 18:59:57 +0800
committermaho <maho@FreeBSD.org>2007-11-26 18:59:57 +0800
commit46291313e8e80e4f2888defdb042cbdcd27ccd5a (patch)
treefcca052636f8cc7a89634124e9037fc7b005c7f7 /editors
parent71a686a3636f164d07a9dfecdbfe290ba494730e (diff)
downloadfreebsd-ports-gnome-46291313e8e80e4f2888defdb042cbdcd27ccd5a.tar.gz
freebsd-ports-gnome-46291313e8e80e4f2888defdb042cbdcd27ccd5a.tar.zst
freebsd-ports-gnome-46291313e8e80e4f2888defdb042cbdcd27ccd5a.zip
Fix build on FBSD 6 and 7.
Approved by: portmgr (linimon)
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice.org-1.0/Makefile30
-rw-r--r--editors/openoffice.org-1.0/files/moz-patch175
-rw-r--r--editors/openoffice.org-1.0/files/patch-berkeleydb+db-3.2.9.patch33
-rw-r--r--editors/openoffice.org-1.0/files/patch-config_office+configure.in29
-rw-r--r--editors/openoffice.org-1.0/files/patch-stlport+STLport-4.5.patch41
5 files changed, 257 insertions, 51 deletions
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 26d423f010d8..4f7fb50a5f87 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -49,8 +49,6 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
-BROKEN= fails to install; consider upgrading to editors/openoffice.org-2
-
LANG_EXT?= 01
LANG_CONFIGURE_ARG?= ENUS
L10NHELP?= helpcontent_01_unix.tgz
@@ -91,16 +89,20 @@ PKGNAMESUFFIX?= -${LANG_SUFFIX}
.endif
# This port might build with gcc 2.95.2+
-BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
-# FIXME (correctly add ccache before gcc and g++)
+USE_GCC= 3.2
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
-CC= ccache gcc32
-CXX= ccache g++32
+CCACHE_PREFIX= ccache
+OOOCC= ${CCACHE_PREFIX} ${CC}
+OOOCXX= ${CCACHE_PREFIX} ${CXX}
.else
-CC= gcc32
-CXX= g++32
+OOOCC= ${CC}
+OOOCXX= ${CXX}
.endif
+CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
imake:${X_IMAKE_PORT} \
@@ -114,8 +116,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/config_office
TCSH?= /bin/tcsh
PKGMESSAGE= ${WRKDIR}/pkg-message
-MAKE_ENV+= DISPLAY="localhost:1001"
-CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
+CONFIGURE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" \
--with-os-version=${OSVERSION}
@@ -175,6 +176,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g' \
-e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
${WRKSRC}/product/settings/settings.mk
+pre-configure:
+#Workaround for moz project, it uses gcc directly.
+ @${LN} -sf `which ${CC}` ${WRKSRC}/solenv/bin/gcc
+ @${LN} -sf `which ${CC}` ${WRKSRC}/solenv/bin/cc
+ @${LN} -sf `which ${CXX}` ${WRKSRC}/solenv/bin/g++
+ @${LN} -sf `which ${CXX}` ${WRKSRC}/solenv/bin/c++
+
do-build:
@cd ${WRKSRC} ; ./bootstrap
@cd ${WRKSRC}/moz ; ${SETENV} "BUILD_MOZAB=TRUE" ${TCSH} -c 'source ../FreeBSDEnv.Set ; build.pl ; dmake zip' ; ${CP} unxfbsd.pro/zipped/FREEBSD*.zip ../moz/zipped
@@ -197,7 +205,7 @@ do-install:
.endif
@${X11BASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
@sleep 5
- @${SETENV} "LC_ALL=C" "LANG=C" ${TCSH} -c "cd ${WRKSRC}/instsetoo/*.pro/${LANG_EXT}/normal ; ./install --prefix=${PREFIX}"
+ @${SETENV} "LC_ALL=C" "LANG=C" DISPLAY="localhost:1001" ${TCSH} -c "cd ${WRKSRC}/instsetoo/*.pro/${LANG_EXT}/normal ; ./install --prefix=${PREFIX}"
@-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
@${RM} -f ${WRKDIR}/.Xvfb.pid
#XXX temporary hack (contains space in dir name)
diff --git a/editors/openoffice.org-1.0/files/moz-patch b/editors/openoffice.org-1.0/files/moz-patch
index 659ccc0feb02..1a8d55946a1e 100644
--- a/editors/openoffice.org-1.0/files/moz-patch
+++ b/editors/openoffice.org-1.0/files/moz-patch
@@ -66,15 +66,33 @@ GNUCOPY is not supported by 1.0 series
+ #endif
+
+ /*
---- moz/mozilla-source-1.0.patch~ Sun Sep 10 09:28:29 2006
-+++ moz/mozilla-source-1.0.patch Sun Sep 10 12:01:05 2006
-@@ -4516,3 +4516,49 @@
+
+--- moz/mozilla-source-1.0.patch.orig 2007-11-17 16:45:06.000000000 +0900
++++ moz/mozilla-source-1.0.patch 2007-11-17 17:00:23.000000000 +0900
+@@ -4516,3 +4516,217 @@
#endif
/*
+*** misc/mozilla/configure Tue May 28 04:29:00 2002
+--- misc/build/mozilla/configure Sun Sep 10 11:56:33 2006
+***************
++*** 4565,4571 ****
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo aout` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++--- 4565,4571 ----
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++***************
+*** 6589,6594 ****
+--- 6589,6596 ----
+ case $target in
@@ -88,6 +106,23 @@ GNUCOPY is not supported by 1.0 series
+*** misc/mozilla/configure.in Tue May 28 04:29:12 2002
+--- misc/build/mozilla/configure.in Sun Sep 10 11:56:18 2006
+***************
++*** 787,793 ****
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo aout` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++--- 787,793 ----
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++***************
+*** 1606,1611 ****
+--- 1606,1613 ----
+ case $target in
@@ -98,6 +133,140 @@ GNUCOPY is not supported by 1.0 series
+ *)
+ AC_CHECK_LIB(c_r, gethostbyname_r)
+ ;;
++*** misc/mozilla/directory/c-sdk/config/FreeBSD.mk Wed Apr 10 11:31:55 2002
++--- misc/build/mozilla/directory/c-sdk/config/FreeBSD.mk Thu May 3 07:55:57 2007
++***************
++*** 66,72 ****
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++--- 66,72 ----
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++*** misc/mozilla/directory/c-sdk/configure Wed Apr 10 11:31:53 2002
++--- misc/build/mozilla/directory/c-sdk/configure Thu May 3 07:58:33 2007
++***************
++*** 3410,3416 ****
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 3410,3416 ----
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++*** misc/mozilla/directory/c-sdk/configure.in Wed Apr 10 11:31:54 2002
++--- misc/build/mozilla/directory/c-sdk/configure.in Thu May 3 07:58:48 2007
++***************
++*** 900,906 ****
++ AC_DEFINE(FREEBSD)
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 900,906 ----
++ AC_DEFINE(FREEBSD)
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++*** misc/mozilla/nsprpub/configure Tue Sep 14 17:14:38 2004
++--- misc/build/mozilla/nsprpub/configure Wed Apr 4 20:56:33 2007
++***************
++*** 3407,3413 ****
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 3407,3413 ----
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++*** misc/mozilla/nsprpub/configure.in Tue Sep 14 17:14:38 2004
++--- misc/build/mozilla/nsprpub/configure.in Wed Apr 4 20:56:40 2007
++***************
++*** 922,928 ****
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ AC_DEFINE(HAVE_SOCKLEN_T)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 922,928 ----
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ AC_DEFINE(HAVE_SOCKLEN_T)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++
++*** misc/mozilla/security/coreconf/FreeBSD.mk Wed Mar 26 20:17:25 2003
++--- misc/build/mozilla/security/coreconf/FreeBSD.mk Wed Apr 4 20:56:48 2007
++***************
++*** 63,69 ****
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++--- 63,69 ----
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++*** misc/mozilla/nsprpub/config/FreeBSD.mk Wed Apr 10 12:16:03 2002
++--- misc/build/mozilla/nsprpub/config/FreeBSD.mk Thu May 3 08:07:27 2007
++***************
++*** 66,72 ****
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++--- 66,72 ----
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
+*** misc/mozilla/nsprpub/pr/src/misc/prnetdb.c Wed Apr 10 12:17:35 2002
+--- misc/build/mozilla/nsprpub/pr/src/misc/prnetdb.c Sun Sep 10 11:55:27 2006
+***************
diff --git a/editors/openoffice.org-1.0/files/patch-berkeleydb+db-3.2.9.patch b/editors/openoffice.org-1.0/files/patch-berkeleydb+db-3.2.9.patch
index 174bd03fac25..ba42c524d6a5 100644
--- a/editors/openoffice.org-1.0/files/patch-berkeleydb+db-3.2.9.patch
+++ b/editors/openoffice.org-1.0/files/patch-berkeleydb+db-3.2.9.patch
@@ -1,6 +1,6 @@
--- berkeleydb/db-3.2.9.patch.orig Sun Jan 19 14:58:19 2003
+++ berkeleydb/db-3.2.9.patch Sun Jan 19 15:00:02 2003
-@@ -62,54 +62,57 @@
+@@ -62,54 +62,66 @@
solaris*) JINCSUBDIRS="solaris";;
linux*) JINCSUBDIRS="linux genunix";;
+ irix*) JINCSUBDIRS="irix";;
@@ -74,6 +74,15 @@
+ solaris* | sysv5*)
+ if $LD -v 2>&1 | egrep 'BFD 2\.8' > /dev/null; then
+ ld_shlibs=no
++@@ -1891,7 +1902,7 @@
++ ;;
++
++ freebsd*)
++- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+++ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case "$version_type" in
++ freebsd-elf*)
+@@ -1955,7 +1966,7 @@
+ version_type=irix
+ need_lib_prefix=no
@@ -83,14 +92,10 @@
+ library_names_spec='${libname}${release}.so.$versuffix ${libname}${release}.so.$major ${libname}${release}.so $libname.so'
+ case "$host_os" in
+ irix5*)
-+@@ -2019,6 +2030,20 @@
-+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major ${libname}${release}.so ${libname}.so'
-+ soname_spec='${libname}${release}.so$major'
-+ dynamic_linker='NetBSD ld.elf_so'
-++ fi
-++ shlibpath_var=LD_LIBRARY_PATH
-++ ;;
-++
++@@ -2023,6 +2034,20 @@
++ shlibpath_var=LD_LIBRARY_PATH
++ ;;
++
++freebsd*)
++ version_type=sunos
++ if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
@@ -101,6 +106,10 @@
++ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major ${libname}${release}.so ${libname}.so'
++ soname_spec='${libname}${release}.so$major'
++ dynamic_linker='FreeBSD ld.elf_so'
-+ fi
-+ shlibpath_var=LD_LIBRARY_PATH
-+ ;;
+++ fi
+++ shlibpath_var=LD_LIBRARY_PATH
+++ ;;
+++
++ openbsd*)
++ version_type=sunos
++ if test "$with_gnu_ld" = yes; then
diff --git a/editors/openoffice.org-1.0/files/patch-config_office+configure.in b/editors/openoffice.org-1.0/files/patch-config_office+configure.in
index e0af7351d24e..4b6e10a17e04 100644
--- a/editors/openoffice.org-1.0/files/patch-config_office+configure.in
+++ b/editors/openoffice.org-1.0/files/patch-config_office+configure.in
@@ -4,48 +4,29 @@ RCS file: /cvs/tools/config_office/configure.in,v
retrieving revision 1.41.2.18
diff -u -r1.41.2.18 configure.in
--- config_office/configure.in 12 Mar 2003 11:38:41 -0000 1.41.2.18
-+++ config_office/configure.in 10 Jul 2005 03:38:11 -0000
-@@ -383,10 +383,7 @@
++++ config_office/configure.in 23 Nov 2007 06:17:03 -0000
+@@ -383,9 +383,6 @@
if test "$COMPATH" != "NO_GCC"; then
AC_MSG_RESULT([checked (gcc $_gcc_version)])
fi
-
-dnl Set the include paths
- _gcc_include_path=`$CC -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
--fi
-+fi
+ fi
dnl ===================================================================
- dnl Test the solaris compiler version
-@@ -545,14 +542,27 @@
+@@ -545,10 +542,12 @@
fi
dnl ===================================================================
-dnl Set the gxx include directories
+dnl Set the gcc/gxx include directories
dnl ===================================================================
-+if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
-+if test "$GXX" = "yes"; then
-+ if test "$_gcc_major" = "3" ; then
-+ _gccincname1="g++-v3"
-+ else
-+ _gccincname1="g++-3" #not checked
-+ fi
-+ _gcc_include_path=".."
-+ _gxx_include_path="$_gcc_include_path/$_gccincname1"
-+fi
-+else
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+ _gcc_include_path=`$CC -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
+ _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - \
+ | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
dnl This is the original code...
--dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
-+dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
-+fi
+ dnl _gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
fi
--
-
- dnl ===================================================================
- dnl Extra checking for the SUN OS compiler
diff --git a/editors/openoffice.org-1.0/files/patch-stlport+STLport-4.5.patch b/editors/openoffice.org-1.0/files/patch-stlport+STLport-4.5.patch
index eb8ca5822940..230fbf3c7067 100644
--- a/editors/openoffice.org-1.0/files/patch-stlport+STLport-4.5.patch
+++ b/editors/openoffice.org-1.0/files/patch-stlport+STLport-4.5.patch
@@ -1,6 +1,45 @@
--- stlport/STLport-4.5.patch.orig Mon Jan 14 18:33:17 2002
+++ stlport/STLport-4.5.patch Tue May 28 23:55:42 2002
-@@ -174,3 +174,110 @@
+@@ -65,7 +65,7 @@
+ !
+ *** misc/STLport-4.5/stlport/config/stl_gcc.h Tue Sep 4 13:10:16 2001
+ --- misc/build/STLport-4.5/stlport/config/stl_gcc.h Mon Nov 11 09:37:18 2002
+-*************** typedef unsigned int wint_t;
++***************
+ *** 226,233 ****
+
+ # if (__GNUC__ >= 3)
+@@ -74,12 +74,27 @@
+ ! # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++-v3/backward
+
+ # elif (__GNUC_MINOR__ < 8)
+-
+---- 226,235 ----
++
++--- 244,268 ----
+
+ # if (__GNUC__ >= 3)
+
+ ! /* properly determine the STLP_NATIVE_INCLUDE_PATH */
++! #ifdef i386
++! #undef i386
++! #define i386 i386
++! #endif
++!
++! #ifdef mips
++! #undef mips
++! #define mips mips
++! #endif
++!
++! #ifdef sgi
++! #undef sgi
++! #define sgi sgi
++! #endif
++!
+ ! # define _STLP_NATIVE_INCLUDE_PATH GXX_INCLUDE_PATH
+ ! # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH \
+ ! GXX_INCLUDE_PATH/backward
+@@ -104,3 +119,110 @@
class _STLP_CLASS_DECLSPEC __Named_exception : public _STLP_EXCEPTION_BASE {
public:
__Named_exception(const string& __str)