aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2017-11-19 17:13:43 +0800
committerAshish SHUKLA <ashish@FreeBSD.org>2017-11-19 17:13:43 +0800
commit4a3529f7c35a6049cf8ec94112d2650bfb5161b8 (patch)
tree486b0ddad96b43139b0fd447e6299798cd3f0469 /editors
parent81b931df493048d5e9fff3dfc760b1ec0b820867 (diff)
downloadfreebsd-ports-gnome-4a3529f7c35a6049cf8ec94112d2650bfb5161b8.tar.gz
freebsd-ports-gnome-4a3529f7c35a6049cf8ec94112d2650bfb5161b8.tar.zst
freebsd-ports-gnome-4a3529f7c35a6049cf8ec94112d2650bfb5161b8.zip
- Fix broken behaviour when port is compiled with IMAGEMAGICK option
and ImageMagick is built with OPENMP option PR: 223518 Submitted by: Kalten <kalten@gmx.at>
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index fbf605463483..57b477985a14 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -185,6 +185,17 @@ XWIDGETS_CONFIGURE_WITH=xwidgets
XWIDGETS_LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3
XWIDGETS_IMPLIES= GTK3
+.include <bsd.port.options.mk>
+
+# has graphics/ImageMagick been compiled with OPENMP?
+.if ${PORT_OPTIONS:MMAGICK} && ${:!${GREP} -sc " \-fopenmp " ${LOCALBASE}/libdata/pkgconfig/ImageMagick.pc || true!} == "1"
+_MAGICK_WITH_OPENMP= true
+.endif
+
+.ifdef _MAGICK_WITH_OPENMP
+USES+= compiler:openmp
+.endif
+
# With a desktop entry stage-qa will give a warning about requiring
# desktop-file-utils and portlint -C will give a warning about INSTALL_ICONS,
# but don't pull in those dependencies when X11 is off.