aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2018-04-05 12:52:36 +0800
committeracm <acm@FreeBSD.org>2018-04-05 12:52:36 +0800
commit5758d2c9bb03be37cd6217a9d0a650880afb1f97 (patch)
tree1407eca99be95ddb9e55faff3e70910850182df9 /editors
parentc45494b178c59af3fb4d9397c326bc43f4f1a3f5 (diff)
downloadfreebsd-ports-gnome-5758d2c9bb03be37cd6217a9d0a650880afb1f97.tar.gz
freebsd-ports-gnome-5758d2c9bb03be37cd6217a9d0a650880afb1f97.tar.zst
freebsd-ports-gnome-5758d2c9bb03be37cd6217a9d0a650880afb1f97.zip
- Migrate Mk/bsd.fpc.mk to Mk/Uses/fpc.mk
- Convert all fpc-based ports to USES=fpc PR: 227210 Reviewed by: portmgr Approved by: portmgr Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D14617
Diffstat (limited to 'editors')
-rw-r--r--editors/coedit/Makefile1
-rw-r--r--editors/fpc-ide/Makefile1
-rw-r--r--editors/lazarus/Makefile5
3 files changed, 5 insertions, 2 deletions
diff --git a/editors/coedit/Makefile b/editors/coedit/Makefile
index e6ca24a5b508..6a236c2d3a86 100644
--- a/editors/coedit/Makefile
+++ b/editors/coedit/Makefile
@@ -26,6 +26,7 @@ USE_GITHUB= yes
GH_ACCOUNT= BBasile
GH_PROJECT= Coedit
+USES= fpc
USE_FPC= cairo chm fcl-base fcl-db fcl-image fcl-json fcl-net fcl-registry \
fcl-stl fcl-web fcl-xml numlib openssl pasjpeg rtl-objpas \
regexpr rtl-extra x11
diff --git a/editors/fpc-ide/Makefile b/editors/fpc-ide/Makefile
index f1b13fa960b1..955044892271 100644
--- a/editors/fpc-ide/Makefile
+++ b/editors/fpc-ide/Makefile
@@ -6,6 +6,7 @@ PKGNAMESUFFIX= -ide
COMMENT= Free Pascal integrated IDE/compiler
+USES= fpc
USE_FPC= chm fv gdbint regexpr rtl-extra rtl-console fcl-xml
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 560abdc2b793..30a54a4fdafc 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -17,12 +17,13 @@ RUN_DEPENDS?= #
ONLY_FOR_ARCHS= i386 amd64
-USES= gmake
+USES= fpc gmake
USE_GNOME= #
USE_FPC?= cairo dblib fcl-base fcl-db fcl-fpcunit fcl-image fcl-json fcl-net \
fcl-registry fcl-res fcl-web fcl-xml gtk2 ibase iconvenc mysql \
numlib odbc openssl oracle pasjpeg postgres regexpr rtl-extra \
sqlite x11
+USE_XORG= x11
OPT?= "-Sgic "
MAKE_ENV= OPT=${OPT}
@@ -70,7 +71,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gdb:devel/gdb
.endif
.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME= gtk20 gdkpixbuf
+USE_GNOME= cairo gtk20 gdkpixbuf2
LCL_PLATFORM= gtk2
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-gtk2
RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-gtk2