aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-11 14:17:04 +0800
committerwill <will@FreeBSD.org>2002-01-11 14:17:04 +0800
commit5edfd4ef75e361115ce9d12b911ba357a816b0cf (patch)
treeefda22b51aaeafff725beac075dd2b198e154b85 /editors
parentb8330606cf2bc2e9a56f78cbd9128728df91a0d0 (diff)
downloadfreebsd-ports-gnome-5edfd4ef75e361115ce9d12b911ba357a816b0cf.tar.gz
freebsd-ports-gnome-5edfd4ef75e361115ce9d12b911ba357a816b0cf.tar.zst
freebsd-ports-gnome-5edfd4ef75e361115ce9d12b911ba357a816b0cf.zip
Bring in a few changes to the KDE ports infrastructure, and some fixes.
- Move all stuff specific to kde core ports to x11/kde2/Makefile.kde. + Default to compile optimized for speed, not debugging, in ports builds, not just packages. We don't really get that many backtraces or debugging information, and there's a better way to provide these things to people willing to spend some time working on KDE. It's at (as announced before): http://freebsd.kde.org/. - Remove teTeX dependency for kdegraphics2 upon request, and being unable to find any reason not to. Apparently, kdegraphics still compiles libkdvi and kdvi -- I guess dvips is merely a runtime dependency. Therefore to enable its use one just needs to add the teTeX package. Bump PORTREVISION to reflect dependency change. - Fix koffice port by removing PYTHON_VERSION, which is unnecessary. PR: 33650 (part of) Submitted by: John Merryweather Cooper <jmcoopr@johncoop.MSHOME.bmi.net> Reviewed by: kde-freebsd@lists.csociety.org (teTeX dep removal, and optimizing for speed, not debugging capability)
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile13
-rw-r--r--editors/koffice-kde3/Makefile13
-rw-r--r--editors/koffice-kde4/Makefile13
-rw-r--r--editors/koffice/Makefile13
4 files changed, 12 insertions, 40 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 69f321887c99..03fa731054c6 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -21,21 +21,14 @@ LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
-PYTHON_VERSION= python2.1
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+_NO_KDE_OBJPRELINK= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
post-patch:
@${PERL} -pi -e "s@Icon=killustrator@Icon=kontour@g" \
${WRKSRC}/templates/Illustration.desktop
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index 69f321887c99..03fa731054c6 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -21,21 +21,14 @@ LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
-PYTHON_VERSION= python2.1
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+_NO_KDE_OBJPRELINK= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
post-patch:
@${PERL} -pi -e "s@Icon=killustrator@Icon=kontour@g" \
${WRKSRC}/templates/Illustration.desktop
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index 69f321887c99..03fa731054c6 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -21,21 +21,14 @@ LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
-PYTHON_VERSION= python2.1
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+_NO_KDE_OBJPRELINK= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
post-patch:
@${PERL} -pi -e "s@Icon=killustrator@Icon=kontour@g" \
${WRKSRC}/templates/Illustration.desktop
diff --git a/editors/koffice/Makefile b/editors/koffice/Makefile
index 69f321887c99..03fa731054c6 100644
--- a/editors/koffice/Makefile
+++ b/editors/koffice/Makefile
@@ -21,21 +21,14 @@ LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
USE_KDELIBS_VER=2
USE_PYTHON= yes
-PYTHON_VERSION= python2.1
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
USE_GMAKE= yes
+_NO_KDE_OBJPRELINK= yes
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
post-patch:
@${PERL} -pi -e "s@Icon=killustrator@Icon=kontour@g" \
${WRKSRC}/templates/Illustration.desktop