aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-01-11 20:05:53 +0800
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-01-11 20:05:53 +0800
commit61c77121e75fcf3effcb0536a1d9ed23f356c050 (patch)
tree5f7a1f01adcac0b9bf6756b49c1c079f748f4fbe /editors
parentcc2ad03cb7d4aed45b531c8677975b3db740b023 (diff)
downloadfreebsd-ports-gnome-61c77121e75fcf3effcb0536a1d9ed23f356c050.tar.gz
freebsd-ports-gnome-61c77121e75fcf3effcb0536a1d9ed23f356c050.tar.zst
freebsd-ports-gnome-61c77121e75fcf3effcb0536a1d9ed23f356c050.zip
Update to 1.6.1.
Diffstat (limited to 'editors')
-rw-r--r--editors/imhex/Makefile2
-rw-r--r--editors/imhex/distinfo6
-rw-r--r--editors/imhex/files/patch-CMakeLists.txt15
-rw-r--r--editors/imhex/files/patch-source_views_view__hexeditor.cpp13
4 files changed, 4 insertions, 32 deletions
diff --git a/editors/imhex/Makefile b/editors/imhex/Makefile
index a5cd210b7538..0d0749ec1149 100644
--- a/editors/imhex/Makefile
+++ b/editors/imhex/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= imhex
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
CATEGORIES= editors
MAINTAINER= nobutaka@FreeBSD.org
diff --git a/editors/imhex/distinfo b/editors/imhex/distinfo
index 7983ffccf5c7..bb5df4533448 100644
--- a/editors/imhex/distinfo
+++ b/editors/imhex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1610164429
-SHA256 (WerWolv-ImHex-1.6.0-v1.6.0_GH0.tar.gz) = c096c01dc0a90b4691ddf3305763f0477bc79a96c0144cba865e6b7fa59f2043
-SIZE (WerWolv-ImHex-1.6.0-v1.6.0_GH0.tar.gz) = 952054
+TIMESTAMP = 1610362840
+SHA256 (WerWolv-ImHex-1.6.1-v1.6.1_GH0.tar.gz) = 03cfe4ea9971dec548f9519be31793952b96da4e9204328f3ea059742b86639d
+SIZE (WerWolv-ImHex-1.6.1-v1.6.1_GH0.tar.gz) = 962615
diff --git a/editors/imhex/files/patch-CMakeLists.txt b/editors/imhex/files/patch-CMakeLists.txt
deleted file mode 100644
index e4c25eceb461..000000000000
--- a/editors/imhex/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- CMakeLists.txt.orig 2021-01-08 19:12:16 UTC
-+++ CMakeLists.txt
-@@ -23,7 +23,11 @@ set(Python_FIND_FRAMEWORK NEVER)
-
- # Find packages
- find_package(PkgConfig REQUIRED)
--pkg_search_module(CRYPTO REQUIRED libcrypto)
-+if (CMAKE_SYSTEM_NAME MATCHES FreeBSD)
-+ find_library(CRYPTO crypto REQUIRED)
-+else()
-+ pkg_search_module(CRYPTO REQUIRED libcrypto)
-+endif()
- pkg_search_module(CAPSTONE REQUIRED capstone)
- find_package(OpenGL REQUIRED)
- find_package(nlohmann_json REQUIRED)
diff --git a/editors/imhex/files/patch-source_views_view__hexeditor.cpp b/editors/imhex/files/patch-source_views_view__hexeditor.cpp
deleted file mode 100644
index 4d4c8a4ddab1..000000000000
--- a/editors/imhex/files/patch-source_views_view__hexeditor.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- source/views/view_hexeditor.cpp.orig 2021-01-08 19:12:16 UTC
-+++ source/views/view_hexeditor.cpp
-@@ -13,6 +13,10 @@
- #undef __STRICT_ANSI__
- #include <cstdio>
-
-+#if defined(__FreeBSD__)
-+ #define ftello64 ftell
-+#endif
-+
- namespace hex {
-
- ViewHexEditor::ViewHexEditor(std::vector<lang::PatternData*> &patternData)