aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-04-13 18:55:08 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2018-04-13 18:55:08 +0800
commit6d61e55102a93efea7e5979bbf8039c5e96716b5 (patch)
tree26fc400f25734548f9bd4fac986068ae4f3e5ffa /editors
parentdd8d3f275f5dddf304ecf08ac125eb7a49f20cb6 (diff)
downloadfreebsd-ports-gnome-6d61e55102a93efea7e5979bbf8039c5e96716b5.tar.gz
freebsd-ports-gnome-6d61e55102a93efea7e5979bbf8039c5e96716b5.tar.zst
freebsd-ports-gnome-6d61e55102a93efea7e5979bbf8039c5e96716b5.zip
New port: editors/kakoune
Kakoune is a code editor that implements Vi's "keystrokes as a text editing language" model. As it's also a modal editor, it is somewhat similar to the Vim editor (after which Kakoune was originally inspired). Kakoune can operate in two modes, normal and insertion. In insertion mode, keys are directly inserted into the current buffer. In normal mode, keys are used to manipulate the current selection and to enter insertion mode. Kakoune has a strong focus on interactivity, most commands provide immediate and incremental results, while still being competitive (as in keystroke count) with Vim. Kakoune works on selections, which are oriented, inclusive range of characters, selections have an anchor and a cursor character. Most commands move both of them, except when extending selection where the anchor character stays fixed and the cursor one moves around. See https://vimeo.com/82711574 for a short demo video. WWW: https://github.com/mawww/kakoune
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/kakoune/Makefile33
-rw-r--r--editors/kakoune/distinfo3
-rw-r--r--editors/kakoune/pkg-descr22
-rw-r--r--editors/kakoune/pkg-plist116
5 files changed, 175 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index d3dc3f83ea91..0151a7886893 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -66,6 +66,7 @@
SUBDIR += jove
SUBDIR += jucipp
SUBDIR += jupp
+ SUBDIR += kakoune
SUBDIR += kate
SUBDIR += kate-kde4
SUBDIR += kate-plugin-pate-kde4
diff --git a/editors/kakoune/Makefile b/editors/kakoune/Makefile
new file mode 100644
index 000000000000..ce06b7caadae
--- /dev/null
+++ b/editors/kakoune/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= kakoune
+DISTVERSION= 2018.04.13
+CATEGORIES= editors
+MASTER_SITES= https://github.com/mawww/kakoune/releases/download/v${DISTVERSION}/
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Modal code editor with a focus on interactivity
+
+LICENSE= UNLICENSE
+LICENSE_FILE= ${WRKSRC}/../UNLICENSE
+
+BUILD_DEPENDS= a2x:textproc/asciidoc
+
+USES= compiler:c++14-lang gmake ncurses tar:bzip2
+
+DATADIR= ${PREFIX}/share/kak
+DOCSDIR= ${PREFIX}/share/doc/kak
+WRKSRC_SUBDIR= src
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} 's,/share/man/,/man/,' ${WRKSRC}/Makefile
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/kak
+
+do-test:
+ @cd ${WRKSRC}/../test && ${SETENV} LC_ALL=en_US.UTF-8 ./run
+
+.include <bsd.port.mk>
diff --git a/editors/kakoune/distinfo b/editors/kakoune/distinfo
new file mode 100644
index 000000000000..29080859a050
--- /dev/null
+++ b/editors/kakoune/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523616383
+SHA256 (kakoune-2018.04.13.tar.bz2) = cd8ccf8d833a7de8014b6d64f0c34105bc5996c3671275b00ced77996dd17fce
+SIZE (kakoune-2018.04.13.tar.bz2) = 404823
diff --git a/editors/kakoune/pkg-descr b/editors/kakoune/pkg-descr
new file mode 100644
index 000000000000..7aa5cb727754
--- /dev/null
+++ b/editors/kakoune/pkg-descr
@@ -0,0 +1,22 @@
+Kakoune is a code editor that implements Vi's "keystrokes as a text
+editing language" model. As it's also a modal editor, it is somewhat
+similar to the Vim editor (after which Kakoune was originally
+inspired).
+
+Kakoune can operate in two modes, normal and insertion. In insertion
+mode, keys are directly inserted into the current buffer. In normal
+mode, keys are used to manipulate the current selection and to enter
+insertion mode.
+
+Kakoune has a strong focus on interactivity, most commands provide
+immediate and incremental results, while still being competitive (as
+in keystroke count) with Vim.
+
+Kakoune works on selections, which are oriented, inclusive range of
+characters, selections have an anchor and a cursor character. Most
+commands move both of them, except when extending selection where the
+anchor character stays fixed and the cursor one moves around.
+
+See https://vimeo.com/82711574 for a short demo video.
+
+WWW: https://github.com/mawww/kakoune
diff --git a/editors/kakoune/pkg-plist b/editors/kakoune/pkg-plist
new file mode 100644
index 000000000000..d034b80ec311
--- /dev/null
+++ b/editors/kakoune/pkg-plist
@@ -0,0 +1,116 @@
+bin/kak
+man/man1/kak.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/README.asciidoc
+%%DATADIR%%/autoload
+%%DATADIR%%/colors/base16.kak
+%%DATADIR%%/colors/default.kak
+%%DATADIR%%/colors/desertex.kak
+%%DATADIR%%/colors/github.kak
+%%DATADIR%%/colors/gruvbox.kak
+%%DATADIR%%/colors/lucius.kak
+%%DATADIR%%/colors/reeder.kak
+%%DATADIR%%/colors/solarized-dark.kak
+%%DATADIR%%/colors/solarized-light.kak
+%%DATADIR%%/colors/tomorrow-night.kak
+%%DATADIR%%/colors/zenburn.kak
+%%DATADIR%%/doc/buffers.asciidoc
+%%DATADIR%%/doc/commands.asciidoc
+%%DATADIR%%/doc/execeval.asciidoc
+%%DATADIR%%/doc/expansions.asciidoc
+%%DATADIR%%/doc/faces.asciidoc
+%%DATADIR%%/doc/faq.asciidoc
+%%DATADIR%%/doc/highlighters.asciidoc
+%%DATADIR%%/doc/hooks.asciidoc
+%%DATADIR%%/doc/keys.asciidoc
+%%DATADIR%%/doc/mapping.asciidoc
+%%DATADIR%%/doc/modes.asciidoc
+%%DATADIR%%/doc/options.asciidoc
+%%DATADIR%%/doc/regex.asciidoc
+%%DATADIR%%/doc/registers.asciidoc
+%%DATADIR%%/doc/scopes.asciidoc
+%%DATADIR%%/kakrc
+%%DATADIR%%/rc/base/autowrap.kak
+%%DATADIR%%/rc/base/clojure.kak
+%%DATADIR%%/rc/base/css.kak
+%%DATADIR%%/rc/base/ctags.kak
+%%DATADIR%%/rc/base/d.kak
+%%DATADIR%%/rc/base/etc.kak
+%%DATADIR%%/rc/base/file.kak
+%%DATADIR%%/rc/base/fish.kak
+%%DATADIR%%/rc/base/gas.kak
+%%DATADIR%%/rc/base/git.kak
+%%DATADIR%%/rc/base/go.kak
+%%DATADIR%%/rc/base/haskell.kak
+%%DATADIR%%/rc/base/html.kak
+%%DATADIR%%/rc/base/ini.kak
+%%DATADIR%%/rc/base/java.kak
+%%DATADIR%%/rc/base/javascript.kak
+%%DATADIR%%/rc/base/json.kak
+%%DATADIR%%/rc/base/julia.kak
+%%DATADIR%%/rc/base/lint.kak
+%%DATADIR%%/rc/base/lisp.kak
+%%DATADIR%%/rc/base/lua.kak
+%%DATADIR%%/rc/base/mail.kak
+%%DATADIR%%/rc/base/markdown.kak
+%%DATADIR%%/rc/base/mercurial.kak
+%%DATADIR%%/rc/base/ocaml.kak
+%%DATADIR%%/rc/base/perl.kak
+%%DATADIR%%/rc/base/restructuredtext.kak
+%%DATADIR%%/rc/base/ruby.kak
+%%DATADIR%%/rc/base/rust.kak
+%%DATADIR%%/rc/base/scala.kak
+%%DATADIR%%/rc/base/screen.kak
+%%DATADIR%%/rc/base/spell.kak
+%%DATADIR%%/rc/base/sql.kak
+%%DATADIR%%/rc/base/swift.kak
+%%DATADIR%%/rc/base/tmux.kak
+%%DATADIR%%/rc/base/x11.kak
+%%DATADIR%%/rc/base/yaml.kak
+%%DATADIR%%/rc/core/asciidoc.kak
+%%DATADIR%%/rc/core/c-family.kak
+%%DATADIR%%/rc/core/comment.kak
+%%DATADIR%%/rc/core/diff.kak
+%%DATADIR%%/rc/core/doc.kak
+%%DATADIR%%/rc/core/formatter.kak
+%%DATADIR%%/rc/core/grep.kak
+%%DATADIR%%/rc/core/kakrc.kak
+%%DATADIR%%/rc/core/make.kak
+%%DATADIR%%/rc/core/makefile.kak
+%%DATADIR%%/rc/core/man.kak
+%%DATADIR%%/rc/core/python.kak
+%%DATADIR%%/rc/core/sh.kak
+%%DATADIR%%/rc/extra/arch-linux.kak
+%%DATADIR%%/rc/extra/autorestore.kak
+%%DATADIR%%/rc/extra/cabal.kak
+%%DATADIR%%/rc/extra/clang.kak
+%%DATADIR%%/rc/extra/coffee.kak
+%%DATADIR%%/rc/extra/cucumber.kak
+%%DATADIR%%/rc/extra/dockerfile.kak
+%%DATADIR%%/rc/extra/editorconfig.kak
+%%DATADIR%%/rc/extra/elixir.kak
+%%DATADIR%%/rc/extra/elm.kak
+%%DATADIR%%/rc/extra/exherbo.kak
+%%DATADIR%%/rc/extra/git-tools.kak
+%%DATADIR%%/rc/extra/go-tools.kak
+%%DATADIR%%/rc/extra/haml.kak
+%%DATADIR%%/rc/extra/hbs.kak
+%%DATADIR%%/rc/extra/iterm.kak
+%%DATADIR%%/rc/extra/jedi.kak
+%%DATADIR%%/rc/extra/just.kak
+%%DATADIR%%/rc/extra/kickstart.kak
+%%DATADIR%%/rc/extra/latex.kak
+%%DATADIR%%/rc/extra/modeline.kak
+%%DATADIR%%/rc/extra/moon.kak
+%%DATADIR%%/rc/extra/nim.kak
+%%DATADIR%%/rc/extra/php.kak
+%%DATADIR%%/rc/extra/pony.kak
+%%DATADIR%%/rc/extra/pug.kak
+%%DATADIR%%/rc/extra/racer.kak
+%%DATADIR%%/rc/extra/ragel.kak
+%%DATADIR%%/rc/extra/ranger.kak
+%%DATADIR%%/rc/extra/sass.kak
+%%DATADIR%%/rc/extra/scss.kak
+%%DATADIR%%/rc/extra/taskpaper.kak
+%%DATADIR%%/rc/extra/tmux-repl.kak
+%%DATADIR%%/rc/extra/tupfile.kak
+%%DATADIR%%/rc/extra/x11-repl.kak