aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-01 21:55:41 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-01 21:55:41 +0800
commit7127b3bd9b1a71eba75b3e0a770a01a423fd2017 (patch)
tree24861c722895a68db0b9802d8e85b1f4907a3967 /editors
parent275a88360f9408f3d9fed4335d1da6461c250730 (diff)
downloadfreebsd-ports-gnome-7127b3bd9b1a71eba75b3e0a770a01a423fd2017.tar.gz
freebsd-ports-gnome-7127b3bd9b1a71eba75b3e0a770a01a423fd2017.tar.zst
freebsd-ports-gnome-7127b3bd9b1a71eba75b3e0a770a01a423fd2017.zip
editors/e93: fix build on GCC architectures
Use C11 compiler: In file included from includes.h:54, from e93.c:17: varbind.h:14: error: redefinition of typedef 'VARIABLE_BINDING' defines.h:198: error: previous declaration of 'VARIABLE_BINDING' was here Approved by: mentors (implicit approval)
Diffstat (limited to 'editors')
-rw-r--r--editors/e93/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index 0f6f47fea8dd..718762a596f7 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tcl-based, programmer-oriented text editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
-USES= tar:tgz tcl xorg
+USES= compiler:c11 tar:tgz tcl xorg
USE_XORG= x11 xinerama xmu
MAKE_ENV= TCL_INCLUDEDIR=${TCL_INCLUDEDIR} TCL_VERSION=${TCL_SHLIB_VER}