aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-10-16 21:56:59 +0800
committerbland <bland@FreeBSD.org>2003-10-16 21:56:59 +0800
commit71514ebe2601a92db6b4c836af4aa15b06ddb842 (patch)
tree73c942122e965cfd025fdd2f36408c8b275bc1ec /editors
parent3e59b04d6b89b8f07b08319fd932c3c7905ce7e0 (diff)
downloadfreebsd-ports-gnome-71514ebe2601a92db6b4c836af4aa15b06ddb842.tar.gz
freebsd-ports-gnome-71514ebe2601a92db6b4c836af4aa15b06ddb842.tar.zst
freebsd-ports-gnome-71514ebe2601a92db6b4c836af4aa15b06ddb842.zip
Fix memory access after free().
This was a source of SIGBUS in print/printpreview on -CURRENT. Reported by: Jacek Wotka <cn@team-fatal.com>
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit2/Makefile1
-rw-r--r--editors/gedit2/files/patch-gedit::gedit-print.c32
2 files changed, 33 insertions, 0 deletions
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index 29665770ba14..c750af5f4347 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gedit2
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
diff --git a/editors/gedit2/files/patch-gedit::gedit-print.c b/editors/gedit2/files/patch-gedit::gedit-print.c
new file mode 100644
index 000000000000..cd4684269e9c
--- /dev/null
+++ b/editors/gedit2/files/patch-gedit::gedit-print.c
@@ -0,0 +1,32 @@
+--- gedit/gedit-print.c.orig Thu Oct 16 22:22:09 2003
++++ gedit/gedit-print.c Thu Oct 16 22:29:04 2003
+@@ -388,6 +388,8 @@
+
+ g_object_unref (gjob);
+
++ gtk_widget_destroy (pji->dialog);
++
+ if (pji->preview == PREVIEW)
+ gedit_print_job_info_destroy (pji, FALSE);
+ else
+@@ -395,8 +397,6 @@
+ g_signal_handlers_disconnect_by_func (pji->pjob, (GCallback) page_cb, pji);
+ g_signal_handlers_disconnect_by_func (pji->pjob, (GCallback) preview_finished_cb, pji);
+ }
+-
+- gtk_widget_destroy (pji->dialog);
+
+ gtk_widget_show (preview);
+ }
+@@ -412,9 +412,9 @@
+
+ g_object_unref (gjob);
+
+- gedit_print_job_info_destroy (pji, TRUE);
+-
+ gtk_widget_destroy (pji->dialog);
++
++ gedit_print_job_info_destroy (pji, TRUE);
+ }
+
+ void