aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-01-06 01:49:26 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-01-06 01:49:26 +0800
commit73503c67706bfee3c058f22f769ac0f11d3b2acf (patch)
tree2791500774ec4baa3f3f5421e21b2334d475dc43 /editors
parent8e2c19381feb34a3388a847cca622a8af5bc96de (diff)
downloadfreebsd-ports-gnome-73503c67706bfee3c058f22f769ac0f11d3b2acf.tar.gz
freebsd-ports-gnome-73503c67706bfee3c058f22f769ac0f11d3b2acf.tar.zst
freebsd-ports-gnome-73503c67706bfee3c058f22f769ac0f11d3b2acf.zip
Ensure vim uses ncursesw (the widechar version) everywhere
Reported by: cy
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 3021080b654c..45e1e63918ef 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vim
PORTVERSION= 8.2.2263
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -21,7 +22,7 @@ CONFLICTS_INSTALL?= vim-console vim-tiny
CONFIGURE_ARGS= --enable-gui=${GUI} \
--enable-multibyte \
- --with-tlib=ncurses
+ --with-tlib=ncursesw
MAKE_ARGS= STRIP="${STRIP_CMD}" \
VIMRCLOC=${ETCDIR} \
VIMRUNTIMEDIR=${PREFIX}/share/vim/${VIM_VER}