aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-31 23:39:55 +0800
committeradamw <adamw@FreeBSD.org>2014-08-31 23:39:55 +0800
commit817d569a8f4fcfe3359e2e376936d31f301789b3 (patch)
tree7d5b9cafb698793dd40fe9b6f2ca1cfb39f7754e /editors
parent0d056ad893edbe298c1746370cb329f4dc4433ea (diff)
downloadfreebsd-ports-gnome-817d569a8f4fcfe3359e2e376936d31f301789b3.tar.gz
freebsd-ports-gnome-817d569a8f4fcfe3359e2e376936d31f301789b3.tar.zst
freebsd-ports-gnome-817d569a8f4fcfe3359e2e376936d31f301789b3.zip
Unbreak by completing staging.
Diffstat (limited to 'editors')
-rw-r--r--editors/tamago/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index 04f24443a614..ab3ded92a0d2 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -41,23 +41,27 @@ PLIST_SUB+= HAS_JISX0213=""
PLIST_SUB+= HAS_JISX0213="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^lispdir/s|@lispdir@|${STAGEDIR}&|' \
+ -e 's|mkdir|${MKDIR}|' \
+ ${WRKSRC}/Makefile.in
+
pre-configure:
@${REINPLACE_CMD} -e 's|emacs/site-lisp|${EMACS_NAME}/${EMACS_VER}/site-lisp|g' \
${WRKSRC}/configure
post-build:
- cd ${WRKSRC}/helper && \
+ (cd ${WRKSRC}/helper && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
- ${_MAKE_JOBS} ${MAKE_ARGS} egg-helper
+ ${_MAKE_JOBS} ${MAKE_ARGS} egg-helper)
${INSTALL_DATA} ${WRKSRC}/debian/changelog ${WRKSRC}/changelog.Debian
${INSTALL_DATA} ${WRKSRC}/debian/README.Debian ${WRKSRC}
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/helper/egg-helper \
${STAGEDIR}${PREFIX}/bin/egg-helper
-.if ${PORT_OPTIONS:MDOCS}
+
${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.post.mk>