aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2008-07-21 19:28:30 +0800
committermaho <maho@FreeBSD.org>2008-07-21 19:28:30 +0800
commit893c207aa439f7df260a8c06873675791c1673a7 (patch)
tree26a11dcbc0e4db6a95eca429f98099f15b64f4b1 /editors
parentb46b2ddae53036658ae5d15ef7a2ec68d8062b03 (diff)
downloadfreebsd-ports-gnome-893c207aa439f7df260a8c06873675791c1673a7.tar.gz
freebsd-ports-gnome-893c207aa439f7df260a8c06873675791c1673a7.tar.zst
freebsd-ports-gnome-893c207aa439f7df260a8c06873675791c1673a7.zip
Fix build on FreeBSD 6 using stock gcc.
Reported by: pav Resource donated by: Nakamura Kazushi (partially)
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3/Makefile7
-rw-r--r--editors/openoffice.org-3-RC/Makefile7
-rw-r--r--editors/openoffice.org-3/Makefile7
3 files changed, 6 insertions, 15 deletions
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index ab810dc6d4d5..d8157084a0bf 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -106,11 +106,6 @@ PKGNAMESUFFIX= -${LANG_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-USE_GCC= 4.2
-#following part should sync with ports/Mk/bsd.gcc.mk
-.if (${OSVERSION} >= 700042)
-CONFIGURE_ARGS+= --with-system-stdlibs
-.endif
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
@@ -152,7 +147,9 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--enable-crashdump=yes \
--with-system-zlib \
+ --with-system-stdlibs \
--with-epm=internal
+
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index b9616a74a417..ef86b5ff4ddd 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -108,11 +108,6 @@ PKGNAMESUFFIX= -${LANG_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-USE_GCC= 4.2
-#following part should sync with ports/Mk/bsd.gcc.mk
-.if (${OSVERSION} >= 700042)
-CONFIGURE_ARGS+= --with-system-stdlibs
-.endif
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
@@ -154,7 +149,9 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--enable-crashdump=yes \
--with-system-zlib \
+ --with-system-stdlibs \
--with-epm=internal
+
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index ab810dc6d4d5..d8157084a0bf 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -106,11 +106,6 @@ PKGNAMESUFFIX= -${LANG_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-USE_GCC= 4.2
-#following part should sync with ports/Mk/bsd.gcc.mk
-.if (${OSVERSION} >= 700042)
-CONFIGURE_ARGS+= --with-system-stdlibs
-.endif
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
@@ -152,7 +147,9 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--enable-crashdump=yes \
--with-system-zlib \
+ --with-system-stdlibs \
--with-epm=internal
+
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost