aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-04-21 02:23:12 +0800
committerasami <asami@FreeBSD.org>1995-04-21 02:23:12 +0800
commit8df6dcd4d000b307270bd6da6aad9b712a6dd943 (patch)
tree4a236a05d5ec261687536997469c61e9f05cd9ad /editors
parent08d18cd2550510d93e96a0640d255acba1d354f4 (diff)
downloadfreebsd-ports-gnome-8df6dcd4d000b307270bd6da6aad9b712a6dd943.tar.gz
freebsd-ports-gnome-8df6dcd4d000b307270bd6da6aad9b712a6dd943.tar.zst
freebsd-ports-gnome-8df6dcd4d000b307270bd6da6aad9b712a6dd943.zip
Update of editors Makefiles!
Diffstat (limited to 'editors')
-rw-r--r--editors/mule-common/Makefile9
-rw-r--r--editors/mule/Makefile9
-rw-r--r--editors/uemacs/Makefile8
3 files changed, 6 insertions, 20 deletions
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index 0a02557c8d4a..c75bc8981a4d 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.14 1995/04/09 06:11:12 asami Exp $
+# $Id: Makefile,v 1.15 1995/04/10 08:06:03 jkh Exp $
#
DISTNAME= mule-2.2.2
@@ -34,12 +34,7 @@ CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
--wnn-includes=/usr/X11R6/include/wnn --terminal-face
STRIP=
-PREBUILD_COOKIE= ${.CURDIR}/work/.prebuild_done
-
-pre-build: ${PREBUILD_COOKIE}
-
-${PREBUILD_COOKIE}:
+pre-build:
find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
- @${TOUCH} ${TOUCH_FLAGS} ${PREBUILD_COOKIE}
.include <bsd.port.mk>
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index 0a02557c8d4a..c75bc8981a4d 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.14 1995/04/09 06:11:12 asami Exp $
+# $Id: Makefile,v 1.15 1995/04/10 08:06:03 jkh Exp $
#
DISTNAME= mule-2.2.2
@@ -34,12 +34,7 @@ CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
--wnn-includes=/usr/X11R6/include/wnn --terminal-face
STRIP=
-PREBUILD_COOKIE= ${.CURDIR}/work/.prebuild_done
-
-pre-build: ${PREBUILD_COOKIE}
-
-${PREBUILD_COOKIE}:
+pre-build:
find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
- @${TOUCH} ${TOUCH_FLAGS} ${PREBUILD_COOKIE}
.include <bsd.port.mk>
diff --git a/editors/uemacs/Makefile b/editors/uemacs/Makefile
index cf05fd63ab31..d10abe23cefe 100644
--- a/editors/uemacs/Makefile
+++ b/editors/uemacs/Makefile
@@ -3,7 +3,7 @@
# Date created: 16 Jan 1995
# Whom: thomas@ghpc8.ihf.rwth-aachen.de
#
-# $Id:$
+# $Id: Makefile,v 1.3 1995/04/09 06:11:13 asami Exp $
#
DISTNAME= uemacs
@@ -22,13 +22,9 @@ PATCH_STRIP= -p1
# Satoshi: it does now, so please update it when you see this.... :)
-pre-extract: exec_depends
- @echo "===> Extracting for ${DISTNAME}"
+do-extract:
@rm -rf ${WRKDIR}
@mkdir -p ${WRKDIR}
@unzip -Laq ${DISTDIR}/${DISTFILES} -d ${WRKDIR}
-extract: fetch pre-extract ${EXTRACT_COOKIE}
- @${TOUCH} ${TOUCH_FLAGS} ${EXTRACT_COOKIE}
-
.include <bsd.port.mk>