aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2018-12-15 19:55:13 +0800
committerdanilo <danilo@FreeBSD.org>2018-12-15 19:55:13 +0800
commit9ac04f3e6f405f4701383ef8b4daa3dd19e3e1c4 (patch)
tree3a92d2c34004d2288d607d5705ebc564603ff3c8 /editors
parentf2f04875b160ac7d7dd9ed24a6965e603bae9bc6 (diff)
downloadfreebsd-ports-gnome-9ac04f3e6f405f4701383ef8b4daa3dd19e3e1c4.tar.gz
freebsd-ports-gnome-9ac04f3e6f405f4701383ef8b4daa3dd19e3e1c4.tar.zst
freebsd-ports-gnome-9ac04f3e6f405f4701383ef8b4daa3dd19e3e1c4.zip
- Remove groff dependency. The tarball already has the HTML files
- Remove unecessary REINPLACE_CMD - Use post-install-{EXAMPLES,DOCS}-on to install the extra files while here: - Disable groff execution by the configure script PR: 234000 Submitted by: Daniel Eisele <daniel_eisele AT gmx.de>
Diffstat (limited to 'editors')
-rw-r--r--editors/nano/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 3316bdb49dbf..1f9661951661 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -25,8 +25,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS EXAMPLES NLS
OPTIONS_SUB= yes
-DOCS_USES= groff
-
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
@@ -34,17 +32,16 @@ INFO= nano
PORTSCOUT= limitw:1,even
-post-configure:
- ${REINPLACE_CMD} -e 's/update_revision//g' ${WRKSRC}/src/Makefile
-
-post-build:
- cd ${WRKSRC}/doc; ${REINPLACE_CMD} \
- -e 's:SYSCONFDIR:${PREFIX}/etc:g' \
- -e 's:EXAMPLESDIR:${EXAMPLESDIR}:g' \
- nano.1 rnano.1 nanorc.5 ${WRKSRC}/doc/${INFO:=.info}
+post-patch:
+ ${REINPLACE_CMD} -e 's/^groff.*/false/' ${WRKSRC}/configure
-post-install:
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/sample.nanorc ${STAGEDIR}${EXAMPLESDIR}
+post-install-DOCS-on:
+.for doc in nano.1.html rnano.1.html nanorc.5.html
+ ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
.include <bsd.port.mk>