aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-31 23:50:53 +0800
committermarino <marino@FreeBSD.org>2014-07-31 23:50:53 +0800
commit9dc760fa44ee4522ff7bff471d66d91e37a03174 (patch)
treef5c816692f4e73ed36e86967f1dfd7710cfbf2a2 /editors
parent3fb74f3d678f9773818f97de747adaa4a159a39d (diff)
downloadfreebsd-ports-gnome-9dc760fa44ee4522ff7bff471d66d91e37a03174.tar.gz
freebsd-ports-gnome-9dc760fa44ee4522ff7bff471d66d91e37a03174.tar.zst
freebsd-ports-gnome-9dc760fa44ee4522ff7bff471d66d91e37a03174.zip
editors/zoinks: Upgrade version 0.3.7 => 0.4.1 and stage
PR: 191818 Submitted by: Ports Fury
Diffstat (limited to 'editors')
-rw-r--r--editors/zoinks/Makefile39
-rw-r--r--editors/zoinks/distinfo4
-rw-r--r--editors/zoinks/files/patch-fw-TTextView.cpp11
-rw-r--r--editors/zoinks/files/patch-fw-TWindow.cpp15
-rw-r--r--editors/zoinks/pkg-descr12
-rw-r--r--editors/zoinks/pkg-plist1
6 files changed, 21 insertions, 61 deletions
diff --git a/editors/zoinks/Makefile b/editors/zoinks/Makefile
index 25b15062a86f..a5e617af3517 100644
--- a/editors/zoinks/Makefile
+++ b/editors/zoinks/Makefile
@@ -2,47 +2,32 @@
# $FreeBSD$
PORTNAME= zoinks
-PORTVERSION= 0.3.7
-PORTREVISION= 4
+PORTVERSION= 0.4.1
CATEGORIES= editors
MASTER_SITES= http://zoinks.mikelockwood.com/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 programmer's editor and development environment
-.if defined(WITH_IMLIB)
-USE_GNOME= imlib
-CONFIGURE_ARGS+= --enable-imlib
-.else
-CONFIGURE_ARGS+= --disable-imlib
-.endif
+LICENSE= GPLv2 # (or later)
USE_XORG= xpm
GNU_CONFIGURE= yes
-NO_STAGE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= IMLIB NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Zoinks can be built with optional support for calculating image sizes"
- @${ECHO_MSG} "and image thumbnail creation for HTML files."
- @${ECHO_MSG} "These features require the Gnome imlib library."
- @${ECHO_MSG} "Use WITH_IMLIB=yes to enable these features."
- @${ECHO_MSG} ""
+IMLIB_USE= GNOME=imlib
+IMLIB_CONFIGURE_ENABLE= imlib
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^MY_CXXFLAGS|#&|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name *.xpm | ${XARGS} ${REINPLACE_CMD} -e \
's|^"|(char *)"|g'
diff --git a/editors/zoinks/distinfo b/editors/zoinks/distinfo
index 988f1f7ed91a..a588a7fcf041 100644
--- a/editors/zoinks/distinfo
+++ b/editors/zoinks/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zoinks-0.3.7.tar.gz) = a13f852eb97b6679ef5d01dc72b4dd5c0ed28c7792e234babcfa486cceb8e944
-SIZE (zoinks-0.3.7.tar.gz) = 326876
+SHA256 (zoinks-0.4.1.tar.gz) = bd8b229904b2e0aeae4742cc9eda882cd47874c86dcf21df8b3d77c830d301cd
+SIZE (zoinks-0.4.1.tar.gz) = 322009
diff --git a/editors/zoinks/files/patch-fw-TTextView.cpp b/editors/zoinks/files/patch-fw-TTextView.cpp
deleted file mode 100644
index e690577b32ed..000000000000
--- a/editors/zoinks/files/patch-fw-TTextView.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- fw/TTextView.cpp.orig 2007-11-03 00:01:15.000000000 +0100
-+++ fw/TTextView.cpp 2007-11-03 00:01:40.000000000 +0100
-@@ -451,7 +451,7 @@
- {
- if (offset < fSelectionAnchor)
- {
-- selectionStart = selectionStart = fLayout->GetLineOffset(fLayout->OffsetToLine(offset));
-+ selectionStart = fLayout->GetLineOffset(fLayout->OffsetToLine(offset));
- selectionEnd = fSelectionAnchorEnd;
- }
- else if (offset > fSelectionAnchorEnd)
diff --git a/editors/zoinks/files/patch-fw-TWindow.cpp b/editors/zoinks/files/patch-fw-TWindow.cpp
index a4c07b37d533..4a3a4636012b 100644
--- a/editors/zoinks/files/patch-fw-TWindow.cpp
+++ b/editors/zoinks/files/patch-fw-TWindow.cpp
@@ -24,18 +24,3 @@
if (xic)
fInputContext = new TInputContext(xic);
-@@ -657,7 +657,14 @@
- {
- time = CurrentTime; // ignore time for now
-
-+#if 0
-+ Pietro Cerutti <gahr@gahr.ch>
-+ We may not be the active window
-+ anymore by this time
-+
- ASSERT(sPointerGrabWindow == this);
-+#endif
-+ if(sPointerGrabWindow != this) return;
-
- XUngrabPointer(sDisplay, time);
-
diff --git a/editors/zoinks/pkg-descr b/editors/zoinks/pkg-descr
index b67cb6389e98..4d9f75a61951 100644
--- a/editors/zoinks/pkg-descr
+++ b/editors/zoinks/pkg-descr
@@ -1,8 +1,8 @@
-Zoinks is a programmer's editor and development environment for
-Unix/X11 systems. The editor has features similar to Mac text
-editors like MPW and CodeWarrior. It also has some features for
-HTML authoring. Zoinks supports comparing/diffing files and
-directory hierarchies. It also supports inputting and editing
-multi-byte text (e.g. Japanese and other Asian languages).
+Zoinks is a programmer's editor and development environment for Unix/X11
+systems. The editor has features similar to Mac text editors like MPW
+and CodeWarrior. It also has some features for HTML authoring. Zoinks
+supports comparing/diffing files and directory hierarchies. It also
+supports inputting and editing multi-byte text (e.g. Japanese and other
+Asian languages).
WWW: http://zoinks.mikelockwood.com/
diff --git a/editors/zoinks/pkg-plist b/editors/zoinks/pkg-plist
index 07f2c04e3eff..055fe8ef758b 100644
--- a/editors/zoinks/pkg-plist
+++ b/editors/zoinks/pkg-plist
@@ -1,2 +1,3 @@
bin/zoinks
+%%NLS%%share/locale/es/LC_MESSAGES/zoinks.mo
%%NLS%%share/locale/ja/LC_MESSAGES/zoinks.mo