aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-08-18 17:43:32 +0800
committermbr <mbr@FreeBSD.org>2002-08-18 17:43:32 +0800
commit9e3b142cfcb45d0fab422686eef5260bf1655479 (patch)
tree9aca344ef1d29912347777613091bee9060e041c /editors
parent00bad625303b80e8dedd0e6a0293f76ba00b42fc (diff)
downloadfreebsd-ports-gnome-9e3b142cfcb45d0fab422686eef5260bf1655479.tar.gz
freebsd-ports-gnome-9e3b142cfcb45d0fab422686eef5260bf1655479.tar.zst
freebsd-ports-gnome-9e3b142cfcb45d0fab422686eef5260bf1655479.zip
Add CXX and CC flags to mozilla build too to workaround the
fact that USE_GCC=3.1 does not use the ports compiler. Submitted by: Vladimir Kushnir <vkushnir@alfacom.net>
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile4
-rw-r--r--editors/openoffice.org-1.0/Makefile4
-rw-r--r--editors/openoffice/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 284eaaa6ed7c..e54df00c22dd 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -331,7 +331,11 @@ mozilla:
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
.if defined(USE_GCC)
+.if ${USE_GCC} == 3.1
+ cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.endif
.else
cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
.endif
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 284eaaa6ed7c..e54df00c22dd 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -331,7 +331,11 @@ mozilla:
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
.if defined(USE_GCC)
+.if ${USE_GCC} == 3.1
+ cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.endif
.else
cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
.endif
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 284eaaa6ed7c..e54df00c22dd 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -331,7 +331,11 @@ mozilla:
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
.if defined(USE_GCC)
+.if ${USE_GCC} == 3.1
+ cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.endif
.else
cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
.endif