aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-10-02 00:31:17 +0800
committeralepulver <alepulver@FreeBSD.org>2007-10-02 00:31:17 +0800
commita130f4ae73ca6044e59d0fe1e7ea3c10b0873b6f (patch)
treee8f97c42f7c4602ba1a771b8518ae9c6c9228f54 /editors
parentfb67d3985386619b830a0d1684771163e95a628b (diff)
downloadfreebsd-ports-gnome-a130f4ae73ca6044e59d0fe1e7ea3c10b0873b6f.tar.gz
freebsd-ports-gnome-a130f4ae73ca6044e59d0fe1e7ea3c10b0873b6f.tar.zst
freebsd-ports-gnome-a130f4ae73ca6044e59d0fe1e7ea3c10b0873b6f.zip
- Take VIMRUNTIME value from editors/vim instead of hard coding it.
PR: ports/116726 Submitted by: alepulver (myself) Approved by: Janos Mohacsi <mohacsi@niif.hu> (maintainer)
Diffstat (limited to 'editors')
-rw-r--r--editors/cream/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/editors/cream/Makefile b/editors/cream/Makefile
index a1e4f0a729e1..23fe8f646bac 100644
--- a/editors/cream/Makefile
+++ b/editors/cream/Makefile
@@ -16,10 +16,12 @@ COMMENT= Gvim extension with many features
RUN_DEPENDS= ${LOCALBASE}/bin/gvim:${PORTSDIR}/editors/vim
NO_BUILD= yes
-# needs updating for each major vim update.
-VIMRUNTIME= ${PREFIX}/share/vim/vim71
PLIST_SUB= VIMRUNTIME="${VIMRUNTIME:S/${PREFIX}\///}"
+.include <bsd.port.pre.mk>
+
+VIMRUNTIME!= cd ${PORTSDIR}/editors/vim && ${MAKE} -V DATADIR
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cream ${PREFIX}/bin
${MKDIR} ${VIMRUNTIME}/cream
@@ -40,4 +42,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>