aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-08-14 20:55:12 +0800
committermbr <mbr@FreeBSD.org>2002-08-14 20:55:12 +0800
commitada05059b420333b962b35579edb623303915a59 (patch)
treea1e5f23f05f083b522852256accd3e8d903e3c0a /editors
parent6ce0b36d9496bbfd916a7dd945a0a0e0716adcce (diff)
downloadfreebsd-ports-gnome-ada05059b420333b962b35579edb623303915a59.tar.gz
freebsd-ports-gnome-ada05059b420333b962b35579edb623303915a59.tar.zst
freebsd-ports-gnome-ada05059b420333b962b35579edb623303915a59.zip
Add package-rename target to automate the OpenOffice.org mirror
package generation. Only useful for Ooo mirrors.
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile10
-rw-r--r--editors/openoffice.org-1.0/Makefile10
-rw-r--r--editors/openoffice/Makefile10
3 files changed, 30 insertions, 0 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 6f2571d0b5b0..d899929ae830 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -397,4 +397,14 @@ post-install:
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type d > ${WRKDIR}/dir.tmp
@${SORT} -r ${WRKDIR}/dir.tmp | ${XARGS} -n 1 ${ECHO_CMD} @dirrm >> ${TMPPLIST}
+package-rename:
+ @${ECHO_MSG} "===> Rename package for OO.org mirror upload";
+.if defined(LANG_SUFFIX)
+ @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${LANG_SUFFIX}-${PORTVERSION}_${PORTREVISION}.tbz2 \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}.tbz2
+.else
+ @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${PORTVERSION}_${PORTREVISION}.tbz2 \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz2
+.endif
+
.include <bsd.port.post.mk>
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 6f2571d0b5b0..d899929ae830 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -397,4 +397,14 @@ post-install:
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type d > ${WRKDIR}/dir.tmp
@${SORT} -r ${WRKDIR}/dir.tmp | ${XARGS} -n 1 ${ECHO_CMD} @dirrm >> ${TMPPLIST}
+package-rename:
+ @${ECHO_MSG} "===> Rename package for OO.org mirror upload";
+.if defined(LANG_SUFFIX)
+ @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${LANG_SUFFIX}-${PORTVERSION}_${PORTREVISION}.tbz2 \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}.tbz2
+.else
+ @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${PORTVERSION}_${PORTREVISION}.tbz2 \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz2
+.endif
+
.include <bsd.port.post.mk>
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 6f2571d0b5b0..d899929ae830 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -397,4 +397,14 @@ post-install:
@cd ${PREFIX} && ${FIND} -s ${INSTALLATION_BASEDIR} -type d > ${WRKDIR}/dir.tmp
@${SORT} -r ${WRKDIR}/dir.tmp | ${XARGS} -n 1 ${ECHO_CMD} @dirrm >> ${TMPPLIST}
+package-rename:
+ @${ECHO_MSG} "===> Rename package for OO.org mirror upload";
+.if defined(LANG_SUFFIX)
+ @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${LANG_SUFFIX}-${PORTVERSION}_${PORTREVISION}.tbz2 \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}.tbz2
+.else
+ @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${PORTVERSION}_${PORTREVISION}.tbz2 \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz2
+.endif
+
.include <bsd.port.post.mk>