aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2014-05-23 19:44:38 +0800
committerolgeni <olgeni@FreeBSD.org>2014-05-23 19:44:38 +0800
commitaee771d179c099e47679191814b8329560676790 (patch)
treee8a440f719954ef9222e0331ba2cca6156420946 /editors
parent6f0ca38615441b0933934976aba317fe59ec693f (diff)
downloadfreebsd-ports-gnome-aee771d179c099e47679191814b8329560676790.tar.gz
freebsd-ports-gnome-aee771d179c099e47679191814b8329560676790.tar.zst
freebsd-ports-gnome-aee771d179c099e47679191814b8329560676790.zip
Add staging support.
Diffstat (limited to 'editors')
-rw-r--r--editors/rox-edit/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/editors/rox-edit/Makefile b/editors/rox-edit/Makefile
index 482cedd7f872..dbbec2661533 100644
--- a/editors/rox-edit/Makefile
+++ b/editors/rox-edit/Makefile
@@ -13,10 +13,9 @@ COMMENT= Text editor for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
+USES= tar:bzip2
USE_PYTHON= yes
-USE_BZIP2= yes
-NO_STAGE= yes
post-extract:
@${FIND} ${WRKSRC} -name .cvsignore | ${XARGS} ${RM}
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -rf
@@ -31,8 +30,7 @@ pre-install:
@${FIND} ${WRKSRC} -name *.bak | ${XARGS} ${RM}
do-install:
- @${MKDIR} ${PREFIX}/apps
- @${CP} -r ${WRKSRC}/Edit ${PREFIX}/apps/
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/apps/Edit
+ @${MKDIR} ${STAGEDIR}${PREFIX}/apps
+ ${CP} -r ${WRKSRC}/Edit ${STAGEDIR}${PREFIX}/apps/
.include <bsd.port.mk>