aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /editors
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'editors')
-rw-r--r--editors/gwrite/Makefile3
-rw-r--r--editors/kile-kde4/Makefile2
-rw-r--r--editors/klat4/Makefile2
3 files changed, 3 insertions, 4 deletions
diff --git a/editors/gwrite/Makefile b/editors/gwrite/Makefile
index 592b719a977f..002e8a5e0acf 100644
--- a/editors/gwrite/Makefile
+++ b/editors/gwrite/Makefile
@@ -14,7 +14,6 @@ LICENSE= LGPL3 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}distutils-extra>=2.15:${PORTSDIR}/devel/py-distutils-extra \
- intltool-update:${PORTSDIR}/textproc/intltool \
${PYTHON_PKGNAMEPREFIX}jswebkit>=0:${PORTSDIR}/www/py-jswebkit \
${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:${PORTSDIR}/www/py-webkitgtk
RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
@@ -22,7 +21,7 @@ RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
${PYTHON_PKGNAMEPREFIX}jswebkit>=0:${PORTSDIR}/www/py-jswebkit \
${PYTHON_PKGNAMEPREFIX}webkitgtk>=0:${PORTSDIR}/www/py-webkitgtk
-USES= desktop-file-utils python
+USES= desktop-file-utils gettext-tools python
USE_GNOME= pygtk2
USE_PYTHON= distutils
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index caf6c996930e..87541c94b505 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -12,7 +12,7 @@ COMMENT= LaTeX source editor for KDE
RUN_DEPENDS= identify:${PORTSDIR}/graphics/ImageMagick
-USES= cmake shared-mime-info tar:bzip2
+USES= cmake gettext-tools shared-mime-info tar:bzip2
USE_QT4= qmake_build moc_build rcc_build uic_build
USE_KDE4= kdeprefix kdelibs automoc4 kate_run
USE_TEX= latex
diff --git a/editors/klat4/Makefile b/editors/klat4/Makefile
index ca7afcfb1cc0..27fdcf818519 100644
--- a/editors/klat4/Makefile
+++ b/editors/klat4/Makefile
@@ -12,7 +12,7 @@ COMMENT= LaTeX source editor for KDE4
LICENSE= GPLv2 # (or later)
-USES= cmake tar:bzip2
+USES= cmake gettext-tools tar:bzip2
USE_KDE4= automoc4 kate kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build