aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-07-30 11:57:23 +0800
committerKurt Jaeger <pi@FreeBSD.org>2014-07-30 11:57:23 +0800
commitb95d127471e2fd17cc8d189dbeec094e3ff556db (patch)
tree15807f23c2499ac331641e73da0725c3432fea04 /editors
parent626234f3eae064cb91ca281da3c79d84b69bf30c (diff)
downloadfreebsd-ports-gnome-b95d127471e2fd17cc8d189dbeec094e3ff556db.tar.gz
freebsd-ports-gnome-b95d127471e2fd17cc8d189dbeec094e3ff556db.tar.zst
freebsd-ports-gnome-b95d127471e2fd17cc8d189dbeec094e3ff556db.zip
security/libgcrypt: 1.5.3_3 -> 1.6.1
- Update to 1.6.1 - Remove some unneeded patches - Fix pkg-plist - report configure bug upstream https://bugs.g10code.com/gnupg/issue1668 - report API breakage downstream and find that MacPorts had the same issue https://rt.cpan.org/Ticket/Display.html?id=97201 - bump PORTREVISION for dependent ports (approx. 100 ports) - Thanks to exp-run by antoine@ to find ports that break - patch ports that would otherwise break security/shishi with PR 192164 is already committed [1] devel/ccrtp [2] editors/abiword [3] security/p5-Crypt-GCrypt PR: 191256, 192162 [1], 192163 [2], 192166 [3] Submitted by: Carlos Jacobo Puga Medina <cjpugmed@gmail.com> Approved by: maintainer timeout, antoine (exp-run), portmgr (implicit)
Diffstat (limited to 'editors')
-rw-r--r--editors/abiword/files/patch-tls_tunnel.cpp17
1 files changed, 17 insertions, 0 deletions
diff --git a/editors/abiword/files/patch-tls_tunnel.cpp b/editors/abiword/files/patch-tls_tunnel.cpp
new file mode 100644
index 000000000000..9447b8dd855c
--- /dev/null
+++ b/editors/abiword/files/patch-tls_tunnel.cpp
@@ -0,0 +1,17 @@
+--- plugins/collab/backends/service/xp/tls_tunnel.cpp-orig 2014-07-27 14:22:00.000000000 +0200
++++ plugins/collab/backends/service/xp/tls_tunnel.cpp 2014-07-27 14:22:46.000000000 +0200
+@@ -124,10 +124,14 @@
+ }
+
+ static struct gcry_thread_cbs gcry_threads_tunnel =
++#if GCRYPT_VERSION_NUMBER < 0x010600
+ { GCRY_THREAD_OPTION_USER, NULL,
+ gcry_tunnel_mutex_init, gcry_tunnel_mutex_destroy,
+ gcry_tunnel_mutex_lock, gcry_tunnel_mutex_unlock,
+ NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL };
++#else
++{ GCRY_THREAD_OPTION_USER };
++#endif
+
+ bool Proxy::tls_tunnel_init() {
+ if (gcry_control(GCRYCTL_SET_THREAD_CBS, &tls_tunnel::gcry_threads_tunnel) != 0)