aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-25 09:19:27 +0800
committerbapt <bapt@FreeBSD.org>2014-01-25 09:19:27 +0800
commitbb5a503fc52f59a52c9eb69e25355ca41b9853b1 (patch)
tree8839b09cbff80ca106285e5e47e4b5b723922b46 /editors
parent9c08f0cd81d19c7ce125a1190c67456fdabfd1c0 (diff)
downloadfreebsd-ports-gnome-bb5a503fc52f59a52c9eb69e25355ca41b9853b1.tar.gz
freebsd-ports-gnome-bb5a503fc52f59a52c9eb69e25355ca41b9853b1.tar.zst
freebsd-ports-gnome-bb5a503fc52f59a52c9eb69e25355ca41b9853b1.zip
Support stage
Diffstat (limited to 'editors')
-rw-r--r--editors/aewan/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/editors/aewan/Makefile b/editors/aewan/Makefile
index 0d69807f9eb8..44ca7db921bb 100644
--- a/editors/aewan/Makefile
+++ b/editors/aewan/Makefile
@@ -9,27 +9,26 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses-based program for the creation and editing of ASCII art
+OPTIONS_DEFINE= DOCS
+
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
-MAN1= aecat.1 aewan.1 aemakeflic.1
-MAN5= aewan.5
-PLIST_FILES= bin/aecat bin/aewan bin/aemakeflic
+PLIST_FILES= bin/aecat bin/aewan bin/aemakeflic \
+ man/man1/aecat.1.gz \
+ man/man1/aewan.1.gz \
+ man/man1/aemakeflic.1.gz \
+ man/man5/aewan.5.gz
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|OSTYPE == |OSTYPE = |g' ${WRKSRC}/configure
-.if !defined(NOPORTDOCS)
post-install:
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>