aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
committerbapt <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
commite6b8ed87b5e99e0ddfa7f575594f03f1992cf201 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /editors
parent729d5d5ddb37fd2035af319a95b99466360a2e7e (diff)
downloadfreebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.gz
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.tar.zst
freebsd-ports-gnome-e6b8ed87b5e99e0ddfa7f575594f03f1992cf201.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Diffstat (limited to 'editors')
-rw-r--r--editors/fxite/Makefile6
-rw-r--r--editors/wordgrinder/Makefile4
-rw-r--r--editors/yzis/Makefile4
3 files changed, 5 insertions, 9 deletions
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 47108f9f789d..af4e1024b0f1 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fxite
PORTVERSION= 0.92
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= gahr@FreeBSD.org
@@ -21,12 +22,11 @@ GH_ACCOUNT= yetanothergeek
GH_TAGNAME= FXITE-0_91
GH_COMMIT= c2ecac3
-USES= gmake pkgconfig
-USE_LUA= yes
+USES= gmake pkgconfig lua:51 desktop-file-utils
USE_AUTOTOOLS= aclocal autoconf automake
ACLOCAL_ARGS= --force -I m4
AUTOMAKE_ARGS= --gnu --add-missing --copy
-CXXFLAGS+= -fPIC
+CXXFLAGS+= -fPIC -Wno-invalid-source-encoding -Wno-format
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+=--with-system-lua \
--with-lua-pkg=lua-${LUA_VER}
diff --git a/editors/wordgrinder/Makefile b/editors/wordgrinder/Makefile
index 00e90d04130a..1857024cff3c 100644
--- a/editors/wordgrinder/Makefile
+++ b/editors/wordgrinder/Makefile
@@ -13,9 +13,7 @@ LICENSE= MIT
RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:${PORTSDIR}/devel/luafilesystem
-USE_LUA= 5.1+
-
-USE_BZIP2= yes
+USES= lua:51 tar:bzip2
MAN1= wordgrinder.1
diff --git a/editors/yzis/Makefile b/editors/yzis/Makefile
index 344775aa2598..cfb4032ac45b 100644
--- a/editors/yzis/Makefile
+++ b/editors/yzis/Makefile
@@ -15,10 +15,8 @@ COMMENT= Vi-like editor
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-USES= tar:bzip2 cmake gettext perl5
+USES= tar:bzip2 cmake gettext perl5 lua:51
USE_XORG= x11 xext ice
-USE_LUA= 5.1
-LUA_COMPS= lua
USE_QT4= qtestlib qmake_build rcc_build uic_build moc_build gui xml
CMAKE_ARGS+= -DLOCALBASE:STRING="${LOCALBASE}" \
-DLUA_INCDIR:STRING="${LUA_INCDIR}" \