aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2002-02-20 17:05:35 +0800
committerobrien <obrien@FreeBSD.org>2002-02-20 17:05:35 +0800
commiteeb12a7d199ecb4587abacd6836075af3f9cb52a (patch)
tree7d7ce360801d5109ff9296dfe215a32a946ae23c /editors
parent898cb4ccf7125d2fa570b6b65174f05f0b75afe2 (diff)
downloadfreebsd-ports-gnome-eeb12a7d199ecb4587abacd6836075af3f9cb52a.tar.gz
freebsd-ports-gnome-eeb12a7d199ecb4587abacd6836075af3f9cb52a.tar.zst
freebsd-ports-gnome-eeb12a7d199ecb4587abacd6836075af3f9cb52a.zip
Use Tcl 8.3 instead of 8.0.
Submitted by: Alan Eldridge <ports@geeksrus.net> PR: 35134
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 745d228c5669..276c031b79f3 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -9,7 +9,7 @@
PORTNAME?= vim
PATCHLEVEL= 223
PORTVERSION= 6.0.${PATCHLEVEL}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= editors
MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/unix/ \
ftp://ftp.nuxi.com/pub/vim/unix/ \
@@ -86,8 +86,8 @@ MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp"
.endif
.if defined(WITH_TCL)
-BUILD_DEPENDS= tclsh8.0:${PORTSDIR}/lang/tcl80
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
+BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
MAKE_ARGS+= CONF_OPT_TCL="--enable-tclinterp"
.endif
@@ -129,6 +129,7 @@ MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable
pre-build:
@(cd ${WRKSRC}; ${MAKE} distclean)
+ @${PERL} -pi -e 's,8\.2,8.3,' ${WRKSRC}/auto/configure
post-install:
[ -e ${PREFIX}/bin/gvim ] || (cd ${PREFIX}/bin ; ${LN} -sf vim gvim)