aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-03-18 02:53:19 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-03-18 02:53:19 +0800
commitf381a0a881a31a2a0435cc276083bb1950cd8a76 (patch)
tree812639bdc3733b454f022984e241fab5d226e825 /editors
parentf675d3d18bbf98bcc278bb268e32a643c52d6c12 (diff)
downloadfreebsd-ports-gnome-f381a0a881a31a2a0435cc276083bb1950cd8a76.tar.gz
freebsd-ports-gnome-f381a0a881a31a2a0435cc276083bb1950cd8a76.tar.zst
freebsd-ports-gnome-f381a0a881a31a2a0435cc276083bb1950cd8a76.zip
Update to 1.45.0
Submitted by: maintainer (via Github)
Diffstat (limited to 'editors')
-rw-r--r--editors/atom/Makefile7
-rw-r--r--editors/atom/distinfo14
-rw-r--r--editors/atom/files/atom/patch-node__modules_github_package.json6
-rw-r--r--editors/atom/files/atom/patch-node__modules_github_test_github-package.test.js6
4 files changed, 17 insertions, 16 deletions
diff --git a/editors/atom/Makefile b/editors/atom/Makefile
index 5016f3187f40..822a8f75269d 100644
--- a/editors/atom/Makefile
+++ b/editors/atom/Makefile
@@ -2,7 +2,7 @@
PORTNAME= atom
DISTVERSIONPREFIX= v
-DISTVERSION= 1.44.0
+DISTVERSION= 1.45.0
CATEGORIES= editors
MASTER_SITES= https://nodejs.org/dist/v${APM_NODE_VER}/:node \
https://github.com/tagattie/FreeBSD-Atom/releases/download/v1.42.0/:jasmine_tagged \
@@ -60,6 +60,7 @@ USES= desktop-file-utils gl gnome jpeg localbase:ldflags pkgconfig \
USE_GITHUB= yes
.include "${.CURDIR}/../../devel/electron4/Makefile.version"
+# See ${WRKSRC}/apm/node_modules/atom-package-manager/BUNDLED_NODE_VERSION for APM_NODE_VER
APM_NODE_VER= 10.2.1
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -228,7 +229,7 @@ make-apm-cache:
cd ${WRKDIR} && ${RM} -r .atom
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
ATOM_RESOURCE_PATH=${WRKSRC} \
- npm_config_target=${ELECTON_VER} \
+ npm_config_target=${ELECTRON_VER} \
npm_config_ignore_scripts=true \
${WRKSRC}/apm/node_modules/atom-package-manager/bin/apm install
cd ${WRKSRC}/node_modules && \
@@ -237,7 +238,7 @@ make-apm-cache:
${ECHO_CMD} "Installing modules for $${p}"; \
cd ${WRKSRC}/node_modules/$${p} && ${SETENV} ${MAKE_ENV} \
ATOM_RESOURCE_PATH=${WRKSRC} \
- npm_config_target=${ELECTON_VER} \
+ npm_config_target=${ELECTRON_VER} \
npm_config_ignore_scripts=true \
${WRKSRC}/apm/node_modules/atom-package-manager/bin/apm install; \
done
diff --git a/editors/atom/distinfo b/editors/atom/distinfo
index 89d0b3a98a59..1530bb710f44 100644
--- a/editors/atom/distinfo
+++ b/editors/atom/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1581749918
+TIMESTAMP = 1584423742
SHA256 (node-v10.2.1.tar.gz) = dcdba29f6b933969d6a8a36ea91cfd44bcb500a1e582a3273ac3d4d930e721e4
SIZE (node-v10.2.1.tar.gz) = 35757099
SHA256 (jasmine-tagged-1.1.4.tar.gz) = 8988597858ddf9e9ba3333a19d8651691c8384117bf2e362e8a5ba193ed47585
SIZE (jasmine-tagged-1.1.4.tar.gz) = 3071259
-SHA256 (atom-npm-cache-1.44.0.tar.gz) = 0dcab4ae60f05add0ffc0bddc45542fa9de58095e1e4c195b7fe6da07871fd3f
-SIZE (atom-npm-cache-1.44.0.tar.gz) = 42467992
-SHA256 (atom-apm-cache-1.44.0.tar.gz) = 4426bd88a55c9521d850eea01859dc6d2dff7f202115206c97c0ee342f9ec1bd
-SIZE (atom-apm-cache-1.44.0.tar.gz) = 115336084
-SHA256 (atom-atom-v1.44.0_GH0.tar.gz) = 8d79697b0c969f22ee8dc2c1d27c608036e92deaf63574f8cd1509ea506eded9
-SIZE (atom-atom-v1.44.0_GH0.tar.gz) = 11909698
+SHA256 (atom-npm-cache-1.45.0.tar.gz) = ebeb3e4df2e149a3935306ac826a045af6be6ded6b90aaca252278479da8f414
+SIZE (atom-npm-cache-1.45.0.tar.gz) = 42498756
+SHA256 (atom-apm-cache-1.45.0.tar.gz) = 7f3cb00b4fa1dd4e4ba5741bd890b93d3486cdba59e77991d3f4e190807bbc3a
+SIZE (atom-apm-cache-1.45.0.tar.gz) = 118410560
+SHA256 (atom-atom-v1.45.0_GH0.tar.gz) = 9d50468ef1c8e1027881f245d205f3ab8446dcf6c40726a3f562de035f46af52
+SIZE (atom-atom-v1.45.0_GH0.tar.gz) = 11909782
diff --git a/editors/atom/files/atom/patch-node__modules_github_package.json b/editors/atom/files/atom/patch-node__modules_github_package.json
index 904624e644a5..f3ed8e55d84f 100644
--- a/editors/atom/files/atom/patch-node__modules_github_package.json
+++ b/editors/atom/files/atom/patch-node__modules_github_package.json
@@ -1,10 +1,10 @@
---- node_modules/github/package.json.orig 2020-02-15 07:00:39 UTC
+--- node_modules/github/package.json.orig 2020-03-17 05:46:57 UTC
+++ node_modules/github/package.json
@@ -215,7 +215,6 @@
"dedent-js": "1.0.1",
"electron-devtools-installer": "2.2.4",
- "electron-link": "0.4.0",
+ "electron-link": "0.4.1",
- "electron-mksnapshot": "^4.2.0",
"enzyme": "3.10.0",
"enzyme-adapter-react-16": "1.7.1",
- "eslint": "6.7.0",
+ "eslint": "6.7.2",
diff --git a/editors/atom/files/atom/patch-node__modules_github_test_github-package.test.js b/editors/atom/files/atom/patch-node__modules_github_test_github-package.test.js
index 8a943c4c4e83..46597ff509b1 100644
--- a/editors/atom/files/atom/patch-node__modules_github_test_github-package.test.js
+++ b/editors/atom/files/atom/patch-node__modules_github_test_github-package.test.js
@@ -1,6 +1,6 @@
---- node_modules/github/test/github-package.test.js.orig 2019-12-11 02:42:35 UTC
+--- node_modules/github/test/github-package.test.js.orig 2020-02-05 20:24:36 UTC
+++ node_modules/github/test/github-package.test.js
-@@ -935,7 +935,7 @@ describe('GithubPackage', function() {
+@@ -1040,7 +1040,7 @@ describe('GithubPackage', function() {
describe('when a file change is made outside Atom in workspace 1', function() {
beforeEach(function() {
@@ -9,7 +9,7 @@
this.skip();
}
-@@ -953,7 +953,7 @@ describe('GithubPackage', function() {
+@@ -1058,7 +1058,7 @@ describe('GithubPackage', function() {
describe('when a file change is made outside Atom in workspace 2', function() {
beforeEach(function() {