aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-02-09 17:38:44 +0800
committersem <sem@FreeBSD.org>2005-02-09 17:38:44 +0800
commitf44b183830a4ec5f0d73d1b944bb48914b1910aa (patch)
tree000ba064f2346def9430ae5890b6ca8a7737dd09 /editors
parent700f140ec8aea2e1de6cd4183f1560e147bf547c (diff)
downloadfreebsd-ports-gnome-f44b183830a4ec5f0d73d1b944bb48914b1910aa.tar.gz
freebsd-ports-gnome-f44b183830a4ec5f0d73d1b944bb48914b1910aa.tar.zst
freebsd-ports-gnome-f44b183830a4ec5f0d73d1b944bb48914b1910aa.zip
- Update port to 21.4.17 "Jumbo Shrimp".
- Sync up Motif selection algorithm with xemacs21-mule port. - Remove GTK support for now, it was commented out and it does not work well. - General Makefile cleanup - Unbreak on sparc64 PR: ports/77291 Submitted by: Pawel Worach <pawel.worach(at)telia.com>
Diffstat (limited to 'editors')
-rw-r--r--editors/xemacs/Makefile111
-rw-r--r--editors/xemacs/distinfo4
-rw-r--r--editors/xemacs/files/patch-ai20
-rw-r--r--editors/xemacs/files/patch-ak17
4 files changed, 46 insertions, 106 deletions
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index 43a404070a79..106d20b2cd19 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -16,23 +16,13 @@ DIST_SUBDIR= xemacs
MAINTAINER?= ports@FreeBSD.org
COMMENT?= This port tracks the stable version of the XEmacs text editor
-NOT_FOR_ARCHS= sparc64
-
-RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
-.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- compface.1:${PORTSDIR}/mail/faces
-USE_XLIB= yes
-USE_XPM= yes
-.endif
-USE_BZIP2= yes
-
XEMACS_REL= 21.4
-XEMACS_VER= 21.4.16
+XEMACS_VER= 21.4.17
XEMACS_ARCH= ${CONFIGURE_TARGET}
+RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
+
+USE_BZIP2= yes
STRIP=
USE_AUTOCONF_VER=213
CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
@@ -44,7 +34,8 @@ CONFIGURE_ARGS?=--with-clash-detection \
--with-ldap=no \
--with-site-lisp \
--with-database=berkdb \
- ${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX} ${WITH_GTK}
+ ${WITH_SCROLLBARS} ${WITH_DIALOGS} ${WITH_WIDGETS} \
+ ${WITH_XFACE} ${WITH_OFFIX}
MAKE_ARGS= prefix=${PREFIX}
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
@@ -56,86 +47,72 @@ PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
# Undump and malloc do not behave on amd64 at the moment
.if ${ARCH} == amd64
-CONFIGURE_ARGS+=--with-system-malloc --pdump
+CONFIGURE_ARGS+= --with-system-malloc --pdump
.endif
-.if exists(${X11BASE}/lib/libXm.so)
+.if !defined(WITHOUT_X11)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ compface.1:${PORTSDIR}/mail/faces
+CONFIGURE_ARGS+= --with-png --with-jpeg --with-tiff
+USE_XLIB= yes
+USE_XPM= yes
+.if !defined(WITHOUT_MOTIF) && !defined(MOTIF_STATIC)
USE_MOTIF= yes
-HAVE_MOTIF= yes
-.endif
-
-pre-fetch:
-#.if !defined(WANT_GTK)
-# @${ECHO_MSG} "If you want to use GTK, please set the environment variable WANT_GTK "
-# @${ECHO_MSG} "and recompile."
-#.endif
-.if defined(HAVE_MOTIF)
-.if !defined(MOTIF_STATIC)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "If your MOTIF library is actually lesstif, you might occasionally"
- @${ECHO_MSG} "experience locked-up frames."
- @${ECHO_MSG} "In this case, set the environment variable MOTIF_STATIC and recompile, "
- @${ECHO_MSG} "which will force the use of athena widgets for dialogs."
+WITH_SCROLLBARS= --with-scrollbars=motif
+WITH_DIALOGS= --with-dialogs=motif
+WITH_WIDGETS= --with-widgets=motif
+.else
+WITH_SCROLLBARS= --with-scrollbars=athena
+WITH_DIALOGS= --with-dialogs=athena
+WITH_WIDGETS= --with-widgets=athena
+.if defined(WITH_XAW3D)
+LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+CONFIGURE_ARGS+= --with-athena=3d
.endif
-.if !defined(WITHOUT_X11)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Set the environment variable WITHOUT_X11 if you "
- @${ECHO_MSG} "do not want to use X11."
-CONFIG_ARGS+= --with-png=yes --with-tiff=yes
.endif
-.if defined(WITHOUT_X11)
+.else
CONFIGURE_ARGS+= --without-x11
.endif
-# hack to avoid shipping binaries linked with Motif
-.if defined(MOTIF_STATIC)
-WITH_DIALOGS= --with-dialogs=athena
+pre-patch:
+.if !defined(WITHOUT_X11)
+.if !defined(WITHOUT_MOTIF) && !defined(MOTIF_STATIC)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If your MOTIF library is lesstif you might occasionally"
+ @${ECHO_MSG} "experience locked-up frames."
+ @${ECHO_MSG} "In this case, set the environment variable WITHOUT_MOTIF"
+ @${ECHO_MSG} "and recompile, which will force the use of athena for"
+ @${ECHO_MSG} "scrollbars, dialogs and widgets."
.endif
-
-.if defined(WITH_XAW3D)
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Set the environment variable WITHOUT_X11 if you do not"
+ @${ECHO_MSG} "want to use X11."
.endif
-#.if defined(WANT_GTK)
-#USE_GNOME= gtk20
-#MAKE_ARGS+= X_LIBS="$(X_LIBS) -lXt"
-#WITH_GTK= --with-gtk=yes \
-# --with-xpm=no
-#USE_XPM= no
-#.endif
-
# Drop faces (libcompface) and offix (libDnd) if building package,
# autodetect otherwise
.if defined(PACKAGE_BUILDING)
WITH_XFACE?= --with-xface=no
WITH_OFFIX?= --with-offix=no
.endif
-.endif
-
-post-patch:
- @${RM} ${WRKSRC}/src/s/freebsd.h.orig
# fix .so references in a few man pages
pre-configure::
-.for file in etc/ctags.1 etc/gnuattach.1 etc/gnuclient.1 etc/gnudoit.1
- @${SED} -e 's/\.1/&.gz/' ${WRKSRC}/${file} > ${WRKDIR}/tmp_zot
- @${MV} ${WRKDIR}/tmp_zot ${WRKSRC}/${file}
+.for f in etc/ctags.1 etc/gnuattach.1 etc/gnuclient.1 etc/gnudoit.1
+ @${SED} -e 's/\.1/&.gz/' ${WRKSRC}/${f} > ${WRKDIR}/tmp_zot
+ @${MV} ${WRKDIR}/tmp_zot ${WRKSRC}/${f}
.endfor
post-install::
-.for file in b2m ctags ellcc etags gnuclient xemacs-${XEMACS_VER}
- ${STRIP_CMD} ${PREFIX}/bin/${file}
+.for f in b2m ctags ellcc etags gnuclient xemacs-${XEMACS_VER}
+ ${STRIP_CMD} ${PREFIX}/bin/${f}
.endfor
# For some reason install no longer makes ${PREFIX}/lib/xemacs/site-lisp.
# Do what PLIST does for pkg_add.
${MKDIR} ${PREFIX}/lib/xemacs/site-lisp
${CHMOD} 755 ${PREFIX}/lib/xemacs/site-lisp
${RM} -f ${PREFIX}/bin/send-pr
-#.if defined(WANT_GTK)
-# @${ECHO_MSG} "Please be aware that GTK support is buggy. Do not report bugs to"
-# @${ECHO_MSG} "the maintainer."
-# @${ECHO_MSG} "Please also be aware that the package's name was automagically changed"
-# @${ECHO_MSG} "to ${PORTNAME}${PKGNAMESUFFIX}-${XEMACS_VER}."
-#.endif
.include <bsd.port.post.mk>
diff --git a/editors/xemacs/distinfo b/editors/xemacs/distinfo
index cce3595ee40a..56bd8955c222 100644
--- a/editors/xemacs/distinfo
+++ b/editors/xemacs/distinfo
@@ -1,2 +1,2 @@
-MD5 (xemacs/xemacs-21.4.16.tar.bz2) = a3a5000db3ada076a117665ea473dab4
-SIZE (xemacs/xemacs-21.4.16.tar.bz2) = 9029850
+MD5 (xemacs/xemacs-21.4.17.tar.bz2) = a207e106138c085711160855d78b72a2
+SIZE (xemacs/xemacs-21.4.17.tar.bz2) = 8693211
diff --git a/editors/xemacs/files/patch-ai b/editors/xemacs/files/patch-ai
deleted file mode 100644
index c91881639c5e..000000000000
--- a/editors/xemacs/files/patch-ai
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib-src/fakemail.c.orig Tue Mar 23 22:09:58 1999
-+++ lib-src/fakemail.c Tue Mar 23 22:12:20 1999
-@@ -157,9 +157,17 @@
- extern char *malloc (), *realloc ();
- #endif
-
-+#if defined(__FreeBSD_version) && __FreeBSD_version >= 400000
-+#define CURRENT_USER
-+#endif
-+
- #ifdef CURRENT_USER
- extern struct passwd *getpwuid ();
-+#if defined(__FreeBSD_version) && __FreeBSD_version >= 400000
-+extern uid_t geteuid ();
-+#else
- extern unsigned short geteuid ();
-+#endif
- static struct passwd *my_entry;
- #define cuserid(s) \
- (my_entry = getpwuid (((int) geteuid ())), \
diff --git a/editors/xemacs/files/patch-ak b/editors/xemacs/files/patch-ak
deleted file mode 100644
index 1284f826cc7e..000000000000
--- a/editors/xemacs/files/patch-ak
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./src/unexelf.c~ Sun Aug 15 03:29:56 1999
-+++ ./src/unexelf.c Tue Nov 2 10:24:55 1999
-@@ -515,6 +515,14 @@
- # include <sys/exec_elf.h>
- #endif
-
-+#if defined(__FreeBSD__) && (defined(__alpha__) || defined(__amd64__))
-+# ifdef __STDC__
-+# define ElfW(type) Elf64_##type
-+# else
-+# define ElfW(type) Elf64_/**/type
-+# endif
-+#endif
-+
- #if __GNU_LIBRARY__ - 0 >= 6
- # include <link.h> /* get ElfW etc */
- #endif