aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 14:36:23 +0800
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 14:36:23 +0800
commitfda2e985daa21bcac7cf4e4882e560933d7ad5e8 (patch)
tree4ccb4a868e97ff347416395233e3825776b24951 /editors
parentd0cdca8bc326260560504ebb5d4b206942ca5125 (diff)
downloadfreebsd-ports-gnome-fda2e985daa21bcac7cf4e4882e560933d7ad5e8.tar.gz
freebsd-ports-gnome-fda2e985daa21bcac7cf4e4882e560933d7ad5e8.tar.zst
freebsd-ports-gnome-fda2e985daa21bcac7cf4e4882e560933d7ad5e8.zip
Implement USE_GTK, part 1.
Diffstat (limited to 'editors')
-rw-r--r--editors/AbiWord/Makefile4
-rw-r--r--editors/AbiWord2/Makefile4
-rw-r--r--editors/abiword-devel/Makefile4
-rw-r--r--editors/abiword/Makefile4
-rw-r--r--editors/gxedit/Makefile7
5 files changed, 10 insertions, 13 deletions
diff --git a/editors/AbiWord/Makefile b/editors/AbiWord/Makefile
index 87c38373cf6a..d1b4e57deefb 100644
--- a/editors/AbiWord/Makefile
+++ b/editors/AbiWord/Makefile
@@ -18,8 +18,7 @@ MAINTAINER= wolman@cs.washington.edu
# unzip is needed during the installation process
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- png.4:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
DIST_SUBDIR= AbiWord
@@ -27,6 +26,7 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abi-${PORTVERSION}/src
USE_XLIB= yes
USE_GMAKE= yes
+USE_GTK= yes
MAKE_ENV= prefix="${PREFIX}"
.include <bsd.port.pre.mk>
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index 87c38373cf6a..d1b4e57deefb 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -18,8 +18,7 @@ MAINTAINER= wolman@cs.washington.edu
# unzip is needed during the installation process
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- png.4:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
DIST_SUBDIR= AbiWord
@@ -27,6 +26,7 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abi-${PORTVERSION}/src
USE_XLIB= yes
USE_GMAKE= yes
+USE_GTK= yes
MAKE_ENV= prefix="${PREFIX}"
.include <bsd.port.pre.mk>
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 87c38373cf6a..d1b4e57deefb 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -18,8 +18,7 @@ MAINTAINER= wolman@cs.washington.edu
# unzip is needed during the installation process
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- png.4:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
DIST_SUBDIR= AbiWord
@@ -27,6 +26,7 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abi-${PORTVERSION}/src
USE_XLIB= yes
USE_GMAKE= yes
+USE_GTK= yes
MAKE_ENV= prefix="${PREFIX}"
.include <bsd.port.pre.mk>
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 87c38373cf6a..d1b4e57deefb 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -18,8 +18,7 @@ MAINTAINER= wolman@cs.washington.edu
# unzip is needed during the installation process
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- png.4:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
DIST_SUBDIR= AbiWord
@@ -27,6 +26,7 @@ DIST_SUBDIR= AbiWord
WRKSRC= ${WRKDIR}/abi-${PORTVERSION}/src
USE_XLIB= yes
USE_GMAKE= yes
+USE_GTK= yes
MAKE_ENV= prefix="${PREFIX}"
.include <bsd.port.pre.mk>
diff --git a/editors/gxedit/Makefile b/editors/gxedit/Makefile
index 07dd7bf37ee7..0e1a2cf80ece 100644
--- a/editors/gxedit/Makefile
+++ b/editors/gxedit/Makefile
@@ -14,12 +14,9 @@ DISTNAME= GXedit${PORTVERSION}
MAINTAINER= dom@myrddin.demon.co.uk
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
-MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+USE_GTK= yes
+
ALL_TARGET= gxedit
post-patch: