aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/bochs
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-01-31 17:39:47 +0800
committerriggs <riggs@FreeBSD.org>2015-01-31 17:39:47 +0800
commitde3653c1900df59750a69954c398c3481879d430 (patch)
tree2b65867f7d1d9c4cc794471e123aac820a3e446a /emulators/bochs
parentfac08492cc266b9ea8b8e0993b3b22218bf635c2 (diff)
downloadfreebsd-ports-gnome-de3653c1900df59750a69954c398c3481879d430.tar.gz
freebsd-ports-gnome-de3653c1900df59750a69954c398c3481879d430.tar.zst
freebsd-ports-gnome-de3653c1900df59750a69954c398c3481879d430.zip
- Update to upstream version 2.6.7
- New maintainer: Anton Törnqvist (antont@inbox.lv) PR: 197069 Submitted by: antont@inbox.lv (maintainer)
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile16
-rw-r--r--emulators/bochs/distinfo4
-rw-r--r--emulators/bochs/files/patch-Makefile.in23
-rw-r--r--emulators/bochs/pkg-plist8
4 files changed, 34 insertions, 17 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 2b413eeffcf2..682416b730c4 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -2,31 +2,29 @@
# $FreeBSD$
PORTNAME= bochs
-PORTVERSION= 2.6.6
-PORTREVISION= 1
+PORTVERSION= 2.6.7
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= antont@inbox.lv
COMMENT= IA-32 (x86) PC emulator that runs DOS, Win 95, and more
LICENSE= LGPL21
-USES= gmake libtool pkgconfig
+USES= gmake libtool:keepla pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_alsa_asoundlib_h=no
CONFIGURE_ARGS= --disable-docbook --disable-instrumentation
SUB_FILES= pkg-message
-CFLAGS+= -fno-exceptions -fomit-frame-pointer ${CPPFLAGS}
+CFLAGS+= -fno-exceptions -fomit-frame-pointer
CXXFLAGS+= -fno-rtti
-CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= A20_PIN ALIGN_CHECK ASSERT_CHECK AVX BUSMOUSE \
- CDROM CHAINING CLGD54XX CONF_MSRS CPP_SUFX \
+ CDROM CHAINING CLGD54XX CONF_MSRS \
DISASM DOCS \
E1000 ES1370 EVEX FPU \
GAMEPORT IDLE_HACK IODEBUG \
@@ -61,8 +59,6 @@ CLGD54XX_DESC= Enable Cirrus Logic GD54xx video card
CLGD54XX_CONFIGURE_ENABLE= clgd54xx
CONF_MSRS_DESC= Enable configurable MSR registers support
CONF_MSRS_CONFIGURE_ENABLE= configurable-msrs
-CPP_SUFX_DESC= Use .cpp as C++ suffix
-CPP_SUFX_CONFIGURE_ENABLE= cpp
DEBUG_DESCR= Enable Debugging, select this and one of DEBUGGER or GDB_STUB (or none)
DEBUGGER_DESC= Enable debugger support
DEBUGGER_CONFIGURE_ENABLE= debugger
@@ -263,7 +259,7 @@ post-build:
@${LN} -sf .bochsrc ${WRKSRC}/bochsrc-sample.txt
post-install:
-.for f in bochs bxcommit bximage bximage_old
+.for f in bochs bximage
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
.if ${PORT_OPTIONS:MPLUGINS}
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index 8b9ecec5917a..8a09142733fb 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bochs-2.6.6.tar.gz) = cef4f8cf0620b8a8a51bc45620403ea953a5bf165c19624ffa7ba48e82a0995a
-SIZE (bochs-2.6.6.tar.gz) = 5012543
+SHA256 (bochs-2.6.7.tar.gz) = a4354eeb699662da869b038e225160ec726b883f1b4f425a06cf56cbffbb8282
+SIZE (bochs-2.6.7.tar.gz) = 5045466
diff --git a/emulators/bochs/files/patch-Makefile.in b/emulators/bochs/files/patch-Makefile.in
new file mode 100644
index 000000000000..3bfe391e86db
--- /dev/null
+++ b/emulators/bochs/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+--- Makefile.in.orig 2015-01-28 14:00:56 UTC
++++ Makefile.in
+@@ -417,13 +417,13 @@ install_bin::
+
+ install_libtool_plugins::
+ for i in $(DESTDIR)$(plugdir); do mkdir -p $$i && test -d $$i && test -w $$i; done
+- list=`cd gui && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install gui/$$i $(DESTDIR)$(plugdir); done
+- list=`cd iodev && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install iodev/$$i $(DESTDIR)$(plugdir); done
+- list=`cd iodev/display && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install iodev/display/$$i $(DESTDIR)$(plugdir); done
+- list=`cd iodev/hdimage && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install iodev/hdimage/$$i $(DESTDIR)$(plugdir); done
+- list=`cd iodev/usb && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install iodev/usb/$$i $(DESTDIR)$(plugdir); done
+- list=`cd iodev/network && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install iodev/network/$$i $(DESTDIR)$(plugdir); done
+- list=`cd iodev/sound && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install iodev/sound/$$i $(DESTDIR)$(plugdir); done
++ list=`cd gui && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s gui/$$i $(DESTDIR)$(plugdir); done
++ list=`cd iodev && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s iodev/$$i $(DESTDIR)$(plugdir); done
++ list=`cd iodev/display && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s iodev/display/$$i $(DESTDIR)$(plugdir); done
++ list=`cd iodev/hdimage && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s iodev/hdimage/$$i $(DESTDIR)$(plugdir); done
++ list=`cd iodev/usb && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s iodev/usb/$$i $(DESTDIR)$(plugdir); done
++ list=`cd iodev/network && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s iodev/network/$$i $(DESTDIR)$(plugdir); done
++ list=`cd iodev/sound && echo *.la`; for i in $$list; do $(LIBTOOL) --mode=install install -s iodev/sound/$$i $(DESTDIR)$(plugdir); done
+ $(LIBTOOL) --finish $(DESTDIR)$(plugdir)
+
+ install_dll_plugins::
diff --git a/emulators/bochs/pkg-plist b/emulators/bochs/pkg-plist
index 7e18ba5a7f1a..068f001913eb 100644
--- a/emulators/bochs/pkg-plist
+++ b/emulators/bochs/pkg-plist
@@ -1,12 +1,8 @@
bin/bochs
-bin/bxcommit
bin/bximage
-bin/bximage_old
-man/man1/bochs.1.gz
man/man1/bochs-dlx.1.gz
-man/man1/bxcommit.1.gz
+man/man1/bochs.1.gz
man/man1/bximage.1.gz
-man/man1/bximage_old.1.gz
man/man5/bochsrc.5.gz
%%DATADIR%%/BIOS-bochs-latest
%%DATADIR%%/BIOS-bochs-legacy
@@ -21,6 +17,8 @@ man/man5/bochsrc.5.gz
%%DATADIR%%/bios.bin-1.7.5
%%DATADIR%%/keymaps/sdl-pc-de.map
%%DATADIR%%/keymaps/sdl-pc-us.map
+%%DATADIR%%/keymaps/sdl2-pc-de.map
+%%DATADIR%%/keymaps/sdl2-pc-us.map
%%DATADIR%%/keymaps/x11-pc-be.map
%%DATADIR%%/keymaps/x11-pc-da.map
%%DATADIR%%/keymaps/x11-pc-de.map