aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/catapult
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-02 18:42:08 +0800
committerPawel Pekala <pawel@FreeBSD.org>2012-11-02 18:42:08 +0800
commitfc88e2209d3172c41d7340d9b5337204e2fe39cc (patch)
tree01a9744f09e7d3ae1da23cfe003d5ac2eecebe2c /emulators/catapult
parent6ae40468e0ca98c582aad3f468f2c003a61a88cf (diff)
downloadfreebsd-ports-gnome-fc88e2209d3172c41d7340d9b5337204e2fe39cc.tar.gz
freebsd-ports-gnome-fc88e2209d3172c41d7340d9b5337204e2fe39cc.tar.zst
freebsd-ports-gnome-fc88e2209d3172c41d7340d9b5337204e2fe39cc.zip
- Update to version 0.9.1
- Convert to OptionsNG - Mark MAKE_JOBS_SAFE PR: ports/171993 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'emulators/catapult')
-rw-r--r--emulators/catapult/Makefile50
-rw-r--r--emulators/catapult/distinfo4
2 files changed, 35 insertions, 19 deletions
diff --git a/emulators/catapult/Makefile b/emulators/catapult/Makefile
index 8b3ba1a8856a..23bbb0434839 100644
--- a/emulators/catapult/Makefile
+++ b/emulators/catapult/Makefile
@@ -1,14 +1,8 @@
-# New ports collection makefile for: emulators/catapult
-# Date created: 14 November 2007
-# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
-#
-# $Carpetsmoker: ports/emulators/catapult/Makefile,v 1.2 2008/07/21 12:54:29 carpetsmoker Exp $
+# Created by: Martin Tournoij <carpetsmoker@xs4all.nl>
# $FreeBSD$
-#
PORTNAME= catapult
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= emulators
MASTER_SITES= SF/openmsx/openmsx/${PORTVERSION}
DISTNAME= openmsx-${PORTNAME}-${PORTVERSION}
@@ -19,12 +13,30 @@ COMMENT= GUI for openMSX
LICENSE= GPLv2
BUILD_DEPENDS= openmsx:${PORTSDIR}/emulators/openmsx
+LIB_DEPENDS= mspack:${PORTSDIR}/archivers/libmspack \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ jbig:${PORTSDIR}/graphics/jbigkit \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png15:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= openmsx:${PORTSDIR}/emulators/openmsx
-USE_GNOME= libxml2
+OPTIONS_DEFINE= DEBUG DOCS
+
+USE_GNOME= gdkpixbuf2 glib20 gtk20 libxml2
USE_WX= 2.6+
USE_PYTHON_BUILD=yes
USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp \
+ xext xfixes xi xinerama xrandr xrender xxf86vm
MAKEFILE= GNUmakefile
MAKE_ARGS= INSTALL_BASE="${PREFIX}" \
INSTALL_SHARE_DIR="${DATADIR}" \
@@ -32,15 +44,18 @@ MAKE_ARGS= INSTALL_BASE="${PREFIX}" \
CATAPULT_OPENMSX_BINARY="${LOCALBASE}/bin/openmsx" \
CATAPULT_OPENMSX_SHARE="${LOCALBASE}/share/openmsx" \
SYMLINK_FOR_BINARY="false"
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.options.mk>
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+MAKE_ARGS+= INSTALL_DOC_DIR="${DOCSDIR}"
+.else
# Use dummy target rather than rewriting makefile
MAKE_ARGS+= INSTALL_DOC_DIR="${WRKSRC}/dummy"
-.else
-MAKE_ARGS+= INSTALL_DOC_DIR="${DOCSDIR}"
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CFLAGS+= -DDEBUG
CATAPULT_STRIP= false
.else
@@ -51,10 +66,11 @@ CATAPULT_STRIP= true
post-patch:
@${REINPLACE_CMD} 's|INSTALL_BASE|INSTALL_SHARE_DIR|' \
${WRKSRC}/build/info2code.mk
-.for FILE in build/main.mk build/probe.mk
- @${REINPLACE_CMD} 's|@$$(CXX)|$$(CXX)| ; \
- s|wx-config|${WX_CONFIG}|g' ${WRKSRC}/${FILE}
-.endfor
+ @${REINPLACE_CMD} '/--no-strict-aliasing/s|^CXXFLAGS|#CXXFLAGS| ; \
+ /--cxx/s|^CXX|#CXX| ; \
+ s|@$$(CXX)|$$(CXX)|' ${WRKSRC}/build/main.mk
+ @${REINPLACE_CMD} 's|wx-config --|${WX_CONFIG:T} --|g' \
+ ${WRKSRC}/build/probe.mk
@${ECHO_CMD} > ${WRKSRC}/build/flavour-portbld.mk
@${ECHO_CMD} 'CXXFLAGS+=${CXXFLAGS}' \
>> ${WRKSRC}/build/flavour-portbld.mk
diff --git a/emulators/catapult/distinfo b/emulators/catapult/distinfo
index b911ed65db6e..d5f6d416fb8b 100644
--- a/emulators/catapult/distinfo
+++ b/emulators/catapult/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openmsx-catapult-0.8.2.tar.gz) = 9168b0c88d4d2a3b76691fd4b995f464de8365ec882f0ea3948a833ea783dddd
-SIZE (openmsx-catapult-0.8.2.tar.gz) = 1284311
+SHA256 (openmsx-catapult-0.9.1.tar.gz) = 856e46c6246e941f397d963b43bae44a942772c6b9a98a90f28f6286812ad9f5
+SIZE (openmsx-catapult-0.9.1.tar.gz) = 1284353