aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/cingb
diff options
context:
space:
mode:
authornakai <nakai@FreeBSD.org>2001-04-22 08:31:45 +0800
committernakai <nakai@FreeBSD.org>2001-04-22 08:31:45 +0800
commit4905953d875ea2f2e6cd0c80f2f1bd2ee11928a9 (patch)
tree702267b0afa2a2506a67ffe454227144848a6a01 /emulators/cingb
parentc31ca843cbbec7d84dced94715c08ba32724a3ab (diff)
downloadfreebsd-ports-gnome-4905953d875ea2f2e6cd0c80f2f1bd2ee11928a9.tar.gz
freebsd-ports-gnome-4905953d875ea2f2e6cd0c80f2f1bd2ee11928a9.tar.zst
freebsd-ports-gnome-4905953d875ea2f2e6cd0c80f2f1bd2ee11928a9.zip
Initial import.
Another GameBoy(tm) emulator.
Diffstat (limited to 'emulators/cingb')
-rw-r--r--emulators/cingb/Makefile25
-rw-r--r--emulators/cingb/distinfo1
-rw-r--r--emulators/cingb/files/patch-aa17
-rw-r--r--emulators/cingb/pkg-comment1
-rw-r--r--emulators/cingb/pkg-descr3
-rw-r--r--emulators/cingb/pkg-plist1
6 files changed, 48 insertions, 0 deletions
diff --git a/emulators/cingb/Makefile b/emulators/cingb/Makefile
new file mode 100644
index 000000000000..0441d408908a
--- /dev/null
+++ b/emulators/cingb/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cingb
+# Date created: 16 April 2001
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cingb
+PORTVERSION= 0.22A
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nakai@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/cingb
+
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+ALL_TARGET= standard
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cingb ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/emulators/cingb/distinfo b/emulators/cingb/distinfo
new file mode 100644
index 000000000000..73b67c924f07
--- /dev/null
+++ b/emulators/cingb/distinfo
@@ -0,0 +1 @@
+MD5 (cingb-0.22A.tar.gz) = 9e29a3f91370855914c6f4732ec84b73
diff --git a/emulators/cingb/files/patch-aa b/emulators/cingb/files/patch-aa
new file mode 100644
index 000000000000..cd90885ac677
--- /dev/null
+++ b/emulators/cingb/files/patch-aa
@@ -0,0 +1,17 @@
+--- Makefile.templ.orig Thu Apr 19 21:04:46 2001
++++ Makefile.templ Thu Apr 19 21:05:37 2001
+@@ -16,7 +16,7 @@
+
+ # unix dependent
+
+-INCPATH = -I/usr/include/glide
++INCPATH = -I/usr/X11R6/include -I/usr/local/include
+ LIBPATH = -L/usr/X11R6/lib
+
+ LIBS = -lX11 %%%libext%%% %%%libsocket%%% %%%libnsl%%%
+@@ -91,4 +91,4 @@
+
+ arplay.c: globals.h arplay.h
+
+-main.c: globals.h z80.h gameboy.h
++main.c: globals.h z80.h gameboy.h
diff --git a/emulators/cingb/pkg-comment b/emulators/cingb/pkg-comment
new file mode 100644
index 000000000000..9c1e1c670f2d
--- /dev/null
+++ b/emulators/cingb/pkg-comment
@@ -0,0 +1 @@
+yet another Nintendo GameBoy(tm) emulator
diff --git a/emulators/cingb/pkg-descr b/emulators/cingb/pkg-descr
new file mode 100644
index 000000000000..336b9b9109a8
--- /dev/null
+++ b/emulators/cingb/pkg-descr
@@ -0,0 +1,3 @@
+yet another Nintendo GameBoy(tm) emulator
+
+WWW: http://cingb.sourceforge.net/
diff --git a/emulators/cingb/pkg-plist b/emulators/cingb/pkg-plist
new file mode 100644
index 000000000000..40a4ccefa777
--- /dev/null
+++ b/emulators/cingb/pkg-plist
@@ -0,0 +1 @@
+bin/cingb