aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/generator
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-09-04 20:55:45 +0800
committersem <sem@FreeBSD.org>2005-09-04 20:55:45 +0800
commit5706a4a9d7ed507a3631fc3df34fff3d2f2bdcd1 (patch)
tree17a89ed3a4372a5f90b4ae73d5b672fc7c7e7d84 /emulators/generator
parent20b292bcb7aabbd824222b024962160a4b005e67 (diff)
downloadfreebsd-ports-gnome-5706a4a9d7ed507a3631fc3df34fff3d2f2bdcd1.tar.gz
freebsd-ports-gnome-5706a4a9d7ed507a3631fc3df34fff3d2f2bdcd1.tar.zst
freebsd-ports-gnome-5706a4a9d7ed507a3631fc3df34fff3d2f2bdcd1.zip
- Makefile clean up: remove old gcc version checking.
PR: ports/84926 Submitted by: maintainer
Diffstat (limited to 'emulators/generator')
-rw-r--r--emulators/generator/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index e08a97958506..eda9ff18e97c 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -53,28 +53,15 @@ post-patch:
.endif
.endif
-# Generator needs GCC 2.95.x or GCC >= 3.4.2 to work properly.
# Generator does not automatically determine the GCC version.
-.if ${OSVERSION} < 400012
-# GCC < 2.95 is in the base system.
-USE_GCC= 2.95
-.endif
-
-.if ${OSVERSION} >= 500035 && ${OSVERSION} < 502126
-# GCC > 2.95 (3.X) && GCC < 3.4.2 is in the base system.
-USE_GCC= 3.4
-.endif
-
-.if ${OSVERSION} < 500035
+.if defined(WITH_OPTIMIZED_CFLAGS)
+. if ${OSVERSION} < 500035
CONFIGURE_ARGS+= --with-gcc=2
-.endif
-
-.if ${OSVERSION} >= 500035
+. elif ${OSVERSION} >= 500035
CONFIGURE_ARGS+= --with-gcc=3
-.endif
-
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+. endif
+.else
CONFIGURE_ARGS+= --without-gcc
.endif