aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/higan/files
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-05-05 22:21:55 +0800
committerrakuco <rakuco@FreeBSD.org>2013-05-05 22:21:55 +0800
commit597de047895a550b81de822312e1d4487bc65533 (patch)
tree29d401d4857fa81f1a3e74bc494a0ab18a045a20 /emulators/higan/files
parentd6528972651418efbb7f13287ea55323f2f78a9b (diff)
downloadfreebsd-ports-gnome-597de047895a550b81de822312e1d4487bc65533.tar.gz
freebsd-ports-gnome-597de047895a550b81de822312e1d4487bc65533.tar.zst
freebsd-ports-gnome-597de047895a550b81de822312e1d4487bc65533.zip
- Install missing files.
- Add DEBUG option. - Fix missing @dirrmtry entry in pkg-plist for share/pixmaps. - Patch loading so ${PREFIX}/share can be used for higan's BIOS files and shaders. PR: ports/178309 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Diffstat (limited to 'emulators/higan/files')
-rw-r--r--emulators/higan/files/patch-target-ethos-AddSharePath30
1 files changed, 30 insertions, 0 deletions
diff --git a/emulators/higan/files/patch-target-ethos-AddSharePath b/emulators/higan/files/patch-target-ethos-AddSharePath
new file mode 100644
index 000000000000..286474b9c734
--- /dev/null
+++ b/emulators/higan/files/patch-target-ethos-AddSharePath
@@ -0,0 +1,30 @@
+--- higan/target-ethos/ethos.hpp.orig 2012-11-04 00:39:15.000000000 -0400
++++ higan/target-ethos/ethos.hpp 2013-04-30 23:07:49.000000000 -0400
+@@ -41,6 +41,7 @@
+ unsigned depth;
+
+ string basepath;
++ string sharepath;
+ string userpath;
+
+ string normalFont;
+--- higan/target-ethos/ethos.cpp.orig 2013-01-12 17:01:26.000000000 -0500
++++ higan/target-ethos/ethos.cpp 2013-04-30 23:10:23.000000000 -0400
+@@ -18,6 +18,9 @@
+ string path = {basepath, filename};
+ if(file::exists(path)) return path;
+ if(directory::exists(path)) return path;
++ path = {sharepath, filename};
++ if(file::exists(path)) return path;
++ if(directory::exists(path)) return path;
+ return {userpath, filename};
+ }
+
+@@ -44,6 +47,7 @@
+ autopause = false;
+
+ basepath = dir(realpath(argv[0]));
++ sharepath = {parentdir(basepath), "share/higan/"};
+ userpath = {nall::configpath(), "higan/"};
+ directory::create(userpath);
+