aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/i386-wine-devel/Makefile
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2020-04-28 04:00:07 +0800
committerLorenzo Salvadore <salvadore@FreeBSD.org>2020-04-28 04:00:07 +0800
commit43ce40675e52df9bafb7ed9dc447cde2ff3b7f67 (patch)
tree061c49faa4843cae10c2c396fe87bc7b8491a536 /emulators/i386-wine-devel/Makefile
parentf1522ac8760137ffe128dda9bf731f4b3d78d4f8 (diff)
downloadfreebsd-ports-gnome-43ce40675e52df9bafb7ed9dc447cde2ff3b7f67.tar.gz
freebsd-ports-gnome-43ce40675e52df9bafb7ed9dc447cde2ff3b7f67.tar.zst
freebsd-ports-gnome-43ce40675e52df9bafb7ed9dc447cde2ff3b7f67.zip
emulators/i386-wine-devel: Style improvements
- Reorder variables. - Remove tools for updating pkg-plist: they were broken by precedent commits and based on the python 2 script files/mergeplist.py, but python 2 is now EOL. - Move port-update target from Makefile.amd64 to Makefile and rename it distinfo-update as it does not update pkg-plist anymore. - Remove EXTRACT_SUFX and use properly USES=tar:txz instead. - Remove references to removed wine staging ports in CONFLICTS_INSTALL. Approved by: tcberner (co-mentor) Differential Revision: https://reviews.freebsd.org/D24550
Diffstat (limited to 'emulators/i386-wine-devel/Makefile')
-rw-r--r--emulators/i386-wine-devel/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/emulators/i386-wine-devel/Makefile b/emulators/i386-wine-devel/Makefile
index e59f8e4045d1..7230496ce221 100644
--- a/emulators/i386-wine-devel/Makefile
+++ b/emulators/i386-wine-devel/Makefile
@@ -18,4 +18,20 @@ COMMENT= 32-bit Microsoft Windows compatibility environment for 64-bit FreeBSD
ONLY_FOR_ARCHS= i386 amd64
+CONFLICTS_INSTALL= wine-[0-9]* wine-devel-[0-9]* i386-wine-[0-9]*
+
+PKGINSTALL= ${.CURDIR}/files/pkg-install
+PKGDEINSTALL= ${PKGINSTALL}
+
+distinfo-update:
+ ${RM} ${.CURDIR}/distinfo ${.CURDIR}/distinfo~
+.for osrel in 11 12 13
+ ${MAKE} fetch OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
+ ${MAKE} makesum OSREL=${osrel} OSVERSION=${osrel}99999 _OSRELEASE=${osrel}
+ ${CAT} ${.CURDIR}/distinfo >> ${.CURDIR}/distinfo~
+ ${RM} ${.CURDIR}/distinfo
+.endfor
+ ${SED} -e '2,$${' -e '/^TIMESTAMP/d' -e '}' distinfo~ > ${.CURDIR}/distinfo
+ ${RM} ${.CURDIR}/distinfo~
+
.include <bsd.port.mk>