aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/i386-wine-devel
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2014-08-09 18:17:23 +0800
committerdbn <dbn@FreeBSD.org>2014-08-09 18:17:23 +0800
commit4e2ef12e0b14d9430d663d72b464558263c2a0d3 (patch)
treea2bc04445dca2ef87a6545a9ad08d79df93c30bd /emulators/i386-wine-devel
parent1e44c7230fe39f0eab1756f51eb0f3995875cc3b (diff)
downloadfreebsd-ports-gnome-4e2ef12e0b14d9430d663d72b464558263c2a0d3.tar.gz
freebsd-ports-gnome-4e2ef12e0b14d9430d663d72b464558263c2a0d3.tar.zst
freebsd-ports-gnome-4e2ef12e0b14d9430d663d72b464558263c2a0d3.zip
Various improvements for emulators/i386-wine-devel.
* Add support for a forthcoming i386-wine-compholio port [1] * Fix binbounce for RPATH issues [1] A port revision bump is not possible due to the complexities for the wine ports. The impact is minimised by timing these updates closely with the underlying updates of wine-devel. Requested by: [1] Kris Moore <kris@pcbsd.org> Reported by: [2] Nils Beyer <nbe@renzel.net>
Diffstat (limited to 'emulators/i386-wine-devel')
-rw-r--r--emulators/i386-wine-devel/Makefile.i3869
-rw-r--r--emulators/i386-wine-devel/Makefile.inc8
-rw-r--r--emulators/i386-wine-devel/files/binbounce3
-rw-r--r--emulators/i386-wine-devel/files/nvidia.sh4
4 files changed, 16 insertions, 8 deletions
diff --git a/emulators/i386-wine-devel/Makefile.i386 b/emulators/i386-wine-devel/Makefile.i386
index cf9e56361c9d..63e82f2eaa24 100644
--- a/emulators/i386-wine-devel/Makefile.i386
+++ b/emulators/i386-wine-devel/Makefile.i386
@@ -7,8 +7,9 @@ MAINTAINER= dbn@FreeBSD.org
COMMENT= 32bit Microsoft Windows compatibility environment for 64bit FreeBSD
# Use the wine port to do most of the heavy lifting
-MASTERDIR= ${.CURDIR}/../wine-devel
-PKGINSTALL= ${.CURDIR}/files/pkg-install
+SLAVEDIR?= ${.CURDIR}
+MASTERDIR= ${SLAVEDIR}/../wine-devel
+PKGINSTALL= ${SLAVEDIR}/files/pkg-install
PKGDEINSTALL= ${PKGINSTALL}
RUN_DEPENDS= dri>0:${PORTSDIR}/graphics/dri
@@ -27,7 +28,7 @@ USE_LDCONFIG32= ${WINELIBDIR} ${WINELIBDIR}/wine
# under FreeBSD/amd64
post-install-script:
# Install bounce script to access the 32bit executables
- ${INSTALL_SCRIPT} ${.CURDIR}/files/binbounce ${STAGEDIR}${PREFIX}/bin/wine
+ ${INSTALL_SCRIPT} ${SLAVEDIR}/files/binbounce ${STAGEDIR}${PREFIX}/bin/wine
for i in `grep ^bin ${TMPPLIST} | xargs -n1 basename` ; do \
[ "$${i}" = "wine" ] || ${LN} -f ${STAGEDIR}${PREFIX}/bin/wine ${STAGEDIR}${PREFIX}/bin/$${i} ; \
echo bin32/$${i} >> ${TMPPLIST} ; \
@@ -72,7 +73,7 @@ post-install-script:
fi
echo '@dirrm bin32' >> ${TMPPLIST}
# Install nvidia patching script
- ${INSTALL_SCRIPT} ${.CURDIR}/files/nvidia.sh ${STAGEDIR}${DATADIR}/patch-nvidia.sh
+ ${INSTALL_SCRIPT} ${SLAVEDIR}/files/nvidia.sh ${STAGEDIR}${DATADIR}/patch-nvidia.sh
echo ${DATADIR:S|$(PREFIX)/||}/patch-nvidia.sh >> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index b9df239f3338..045e73bb4f19 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -73,11 +73,13 @@ ${PLIST}: fetch
port-update:
${RM} -f ${.CURDIR}/distinfo ${.CURDIR}/distinfo~ ${.CURDIR}/pkg-plist.*
.for osrel in 8 9 10 11
- ${MAKE} fetch OSREL=${osrel}
- ${MAKE} makesum OSREL=${osrel}
+.for suffix in -devel -compholio
+ ${MAKE} fetch OSREL=${osrel} PKGNAMESUFFIX=${suffix}
+ ${MAKE} makesum OSREL=${osrel} PKGNAMESUFFIX=${suffix}
${CAT} ${.CURDIR}/distinfo >> ${.CURDIR}/distinfo~
${RM} ${.CURDIR}/distinfo
- ${MAKE} pkg-plist.${osrel} PLIST=pkg-plist.${osrel} OSREL=${osrel}
+ [ "${suffix}" != "-devel" ] || ${MAKE} pkg-plist.${osrel} PLIST=pkg-plist.${osrel} OSREL=${osrel}
+.endfor
.endfor
${MV} ${.CURDIR}/distinfo~ ${.CURDIR}/distinfo
python ${FILESDIR}/mergeplist.py ${.CURDIR}/pkg-plist.* > ${PLIST}
diff --git a/emulators/i386-wine-devel/files/binbounce b/emulators/i386-wine-devel/files/binbounce
index ed7564cf4885..34ca7c05d06b 100644
--- a/emulators/i386-wine-devel/files/binbounce
+++ b/emulators/i386-wine-devel/files/binbounce
@@ -11,10 +11,13 @@ then
if [ `uname -p` = i386 ]
then
export LD_LIBRARY_PATH="$LOCALBASE/lib32":"$LOCALBASE/lib32/wine":"$LD_LIBRARY_PATH"
+ export LD_LIBRARY_PATH_RPATH="$LOCALBASE/lib32":"$LOCALBASE/lib32/wine":"$LD_LIBRARY_PATH_RPATH"
else
export LD_32_LIBRARY_PATH="$LOCALBASE/lib32":"$LOCALBASE/lib32/wine":"$LD_32_LIBRARY_PATH":/usr/lib32
+ export LD_32_LIBRARY_PATH_RPATH="$LOCALBASE/lib32":"$LOCALBASE/lib32/wine":"$LD_32_LIBRARY_PATH_RPATH":/usr/lib32
fi
export PATH="$LOCALBASE/bin32":"$PATH"
+ export __BINBOUNCE_BOOTSTRAP="1"
fi
exec "$LOCALBASE/bin32/$BINNAME" "$@"
diff --git a/emulators/i386-wine-devel/files/nvidia.sh b/emulators/i386-wine-devel/files/nvidia.sh
index 0f5c572f735f..94a06b9aefea 100644
--- a/emulators/i386-wine-devel/files/nvidia.sh
+++ b/emulators/i386-wine-devel/files/nvidia.sh
@@ -63,6 +63,8 @@
# - add deinstall option
# Version 1.12 - 2013/11/03
# - add detection for i386-wine-devel
+# Version 1.13 - 2014/08/05
+# - add detection for i386-wine-compholio
set -e
@@ -147,7 +149,7 @@ echo "===> Patching i386-wine to work with x11/nvidia-driver:"
if [ -z "${WINE}" ]
then
- WINE=`version i386-wine; version i386-wine-devel`
+ WINE=`version i386-wine; version i386-wine-devel; version i386-wine-compholio`
fi
[ -n "$WINE" ] \
|| terminate 255 "Unable to detect i386-wine, please install first"