aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/ia64sim
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2003-10-07 17:09:32 +0800
committerroam <roam@FreeBSD.org>2003-10-07 17:09:32 +0800
commit8ab57225b5100c10ddbc3278d4a8137a0f801602 (patch)
treed22439de90fae64290e96ec183ea29c857f25325 /emulators/ia64sim
parent7bd8706e5c6fea710b94e6814ad78a7694f7792f (diff)
downloadfreebsd-ports-gnome-8ab57225b5100c10ddbc3278d4a8137a0f801602.tar.gz
freebsd-ports-gnome-8ab57225b5100c10ddbc3278d4a8137a0f801602.tar.zst
freebsd-ports-gnome-8ab57225b5100c10ddbc3278d4a8137a0f801602.zip
Mark broken by the most recent GCC import in -CURRENT.
While I'm here, clean this up a bit: use DISTNAME and RM instead of DISTFILES and 'rm'. PR: 57612 Submitted by: Mark Linimon <linimon@lonesome.com>
Diffstat (limited to 'emulators/ia64sim')
-rw-r--r--emulators/ia64sim/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 9fc5fea35bce..e5647ed939f6 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -12,20 +12,27 @@ CATEGORIES= emulators
MASTER_SITES= http://www.pacificsites.com/~ccrayne/ \
http://www.glue.umd.edu/~jasonp/ \
http://www.boo.net/~jasonp/
-DISTFILES= ${PORTNAME}${EXTRACT_SUFX}
+DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= IA64 simulator (Intel(R) Architecture 64)
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501103
+BROKEN= "does not build with latest gcc"
+.endif
+
EXTRACT_BEFORE_ARGS= -qLa
WRKSRC= ${WRKDIR}/home/chuck/ia64simcc
-USE_ZIP= yes
USE_GMAKE= yes
MAKEFILE= makefile.unx
pre-build:
- rm -f ${WRKSRC}/obj/*.o
- rm -f ${WRKSRC}/ia64sim
+ ${RM} -f ${WRKSRC}/obj/*.o
+ ${RM} -f ${WRKSRC}/ia64sim
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ia64sim ${PREFIX}/bin
@@ -34,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/ia64user.txt ${WRKSRC}/readme ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>