aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux-geepee32
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-02-14 04:55:35 +0800
committerlinimon <linimon@FreeBSD.org>2004-02-14 04:55:35 +0800
commit732e7101b47ca3de33e7e9698f221e80878089ec (patch)
tree52382404ca8f6a7363627a3290b983a8e21c86c4 /emulators/linux-geepee32
parent879fb5af88e93a0bf9591e6337821840499793fc (diff)
downloadfreebsd-ports-gnome-732e7101b47ca3de33e7e9698f221e80878089ec.tar.gz
freebsd-ports-gnome-732e7101b47ca3de33e7e9698f221e80878089ec.tar.zst
freebsd-ports-gnome-732e7101b47ca3de33e7e9698f221e80878089ec.zip
Fix up problems with install.
PR: ports/62501 Submitted by: arundel@gmx.net (maintainer)
Diffstat (limited to 'emulators/linux-geepee32')
-rw-r--r--emulators/linux-geepee32/Makefile20
-rw-r--r--emulators/linux-geepee32/scripts/geepee32.sh5
2 files changed, 13 insertions, 12 deletions
diff --git a/emulators/linux-geepee32/Makefile b/emulators/linux-geepee32/Makefile
index 80553ddc0ac3..6dad67264c89 100644
--- a/emulators/linux-geepee32/Makefile
+++ b/emulators/linux-geepee32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= geepee32
PORTVERSION= 30
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= http://users.skynet.be/firefly/gp32/project/geepee32/
PKGNAMEPREFIX= linux-
@@ -21,23 +22,18 @@ USE_LINUX= yes
USE_XLIB= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
+NO_BUILD= yes
-TARGET_DIR= ${PREFIX}/geepee32
-
-STRIP=
-PROG_FILES= ${WRKDIR}/geepee32
-DATA_FILES= ${FILESDIR}/geepee32.sh
-
-do-build:
+TARGET_DIR= ${PREFIX}/${PORTNAME}
do-install:
- ${INSTALL} -d -m 777 ${TARGET_DIR} && \
- ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR} && \
- ${INSTALL_SCRIPT} ${DATA_FILES} ${TARGET_DIR}
+ ${INSTALL} -d -m 777 ${TARGET_DIR}
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${TARGET_DIR}
+ ${INSTALL_SCRIPT} ${SCRIPTDIR}/${PORTNAME}.sh ${TARGET_DIR}
post-install:
- ${TOUCH} ${TARGET_DIR}/iic.bin && \
- ${LN} -s ${TARGET_DIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ @${TOUCH} ${TARGET_DIR}/iic.bin
+ @${LN} -s ${TARGET_DIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
@${ECHO_MSG} ""
@${ECHO_MSG} "Please don't mail us with requests for ROM dump."
@${ECHO_MSG} ""
diff --git a/emulators/linux-geepee32/scripts/geepee32.sh b/emulators/linux-geepee32/scripts/geepee32.sh
new file mode 100644
index 000000000000..ae5bbf6caa4f
--- /dev/null
+++ b/emulators/linux-geepee32/scripts/geepee32.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# Wrap geepee32 binary
+./geepee32 $*
+exit $?