aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux_base-8
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-01-20 23:40:43 +0800
committernetchild <netchild@FreeBSD.org>2005-01-20 23:40:43 +0800
commit74d450a5468f965ba1bf575a962a7ae8dc4197d1 (patch)
tree4792fe7a277a529455663938ffe5908e504fe7a8 /emulators/linux_base-8
parentb26b992b2a2fba96418979152a3edbcb6d348c9d (diff)
downloadfreebsd-ports-gnome-74d450a5468f965ba1bf575a962a7ae8dc4197d1.tar.gz
freebsd-ports-gnome-74d450a5468f965ba1bf575a962a7ae8dc4197d1.tar.zst
freebsd-ports-gnome-74d450a5468f965ba1bf575a962a7ae8dc4197d1.zip
Minimal changes to let users update the linux base and the linux X11 bits
in any order: - add the X11 lib path to ld.so.conf in the linux base port - (re)generate the ld.so.cache file in the linux base port too - don't change the ld.so.conf in the linux X11 port At deinstall time the linux base port may still complain about a changed ld.so.cache file. A clean way to solve this would be to use ("@unexec" and "@exec") in the plist. Since the plist is autogenerated this would need some little magic in the plist generation or we have to switch to a static plist. Delay the decission about how to handle this until we know when/how to update to a more recent linux base port.
Diffstat (limited to 'emulators/linux_base-8')
-rw-r--r--emulators/linux_base-8/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 9929f41b49b7..f5b2db6a8f64 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -8,7 +8,7 @@
PORTNAME= linux_base-8
PORTVERSION= 8.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX} \
${MASTER_SITE_REDHAT_LINUX:S/$/:new/} \
@@ -134,6 +134,10 @@ pre-install:
${INSTALL} ${COPY} -m 644 ${FILESDIR}/yp.conf ${WRKSRC}/etc
${TOUCH} ${WRKSRC}/etc/mtab
#
+# Create a good ld.so.conf
+#
+ ${ECHO_CMD} -e '/lib\n/usr/lib\n/usr/X11R6/lib' > ${WRKSRC}/etc/ld.so.conf
+#
# Finish
#
@for D in ${REMOVE_DIRS}; do \
@@ -154,6 +158,7 @@ pre-install:
do-install:
cd ${WRKSRC} && ${FIND} * | ${CPIO} -dmp ${PREFIX}
${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
+ ${PREFIX}/sbin/ldconfig
post-install:
@${ECHO} ''