aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux_base-f10
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2006-07-11 06:48:01 +0800
committerbsam <bsam@FreeBSD.org>2006-07-11 06:48:01 +0800
commit5baec65ee22e94adfa7899f893b3863ccd58b88b (patch)
treeb4fecdb33e33328ad1cd2e325275fac8ede87609 /emulators/linux_base-f10
parent8714b4823fa638d34fb5710ec8d8f38ff5c58b8b (diff)
downloadfreebsd-ports-gnome-5baec65ee22e94adfa7899f893b3863ccd58b88b.tar.gz
freebsd-ports-gnome-5baec65ee22e94adfa7899f893b3863ccd58b88b.tar.zst
freebsd-ports-gnome-5baec65ee22e94adfa7899f893b3863ccd58b88b.zip
Fix using "portupgrade -s" with this port:
o chmod u+w ${WRKSRC}/usr/bin/*db4* (before brandelf) o reverse permittions after branding. PR: ports/100039 Submitted by: Stefan Sperling <freebsd-gnats@stsp.in-berlin.de> Approved by: netchild (mentor, implicit)
Diffstat (limited to 'emulators/linux_base-f10')
-rw-r--r--emulators/linux_base-f10/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/linux_base-f10/Makefile b/emulators/linux_base-f10/Makefile
index 0727b80f92ad..89de6b55fdac 100644
--- a/emulators/linux_base-f10/Makefile
+++ b/emulators/linux_base-f10/Makefile
@@ -172,11 +172,17 @@ do-build:
#
@${MV} ${WRKSRC}/etc/nsswitch.conf ${WRKSRC}/etc/nsswitch.conf.dist
+# Fix usr/bin/*db4* permissions to allow "portupgrade -s"
+ @${CHMOD} u+w ${WRKSRC}/usr/bin/*db4*
+
@${FIND} ${WRKSRC}/bin ${WRKSRC}/sbin/ ${WRKSRC}/usr/bin \
${WRKSRC}/usr/sbin -type f -print0 | ${XARGS} -0 ${FILE} \
| ${GREP} ELF | ${CUT} -d : -f 1 \
| ${XARGS} ${BRANDELF} -t Linux
+# Restore the status quo for usr/bin/*db4* files
+ @${CHMOD} u-w ${WRKSRC}/usr/bin/*db4*
+
do-install:
#
# Handle the loading of the linux loadable kernel module if required.