aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/osf1_base
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-02-06 03:13:39 +0800
committerobrien <obrien@FreeBSD.org>2000-02-06 03:13:39 +0800
commit4815e49e8622bc84f78fdf1ce95badbdd214b5da (patch)
tree3b6b2577eabb07c38ee1a4aacdb1aa3e60263b45 /emulators/osf1_base
parent68690e87561ad0e44e724ff5b32cc348a9bf7124 (diff)
downloadfreebsd-ports-gnome-4815e49e8622bc84f78fdf1ce95badbdd214b5da.tar.gz
freebsd-ports-gnome-4815e49e8622bc84f78fdf1ce95badbdd214b5da.tar.zst
freebsd-ports-gnome-4815e49e8622bc84f78fdf1ce95badbdd214b5da.zip
This contains a minimal selection of shared libraries from a Compaq Tru64 5.0
installation. These libraries and support files, in conjunction with the osf1 module, form the basis of the osf1 compatibility environment.
Diffstat (limited to 'emulators/osf1_base')
-rw-r--r--emulators/osf1_base/Makefile51
-rw-r--r--emulators/osf1_base/distinfo1
-rw-r--r--emulators/osf1_base/pkg-comment1
-rw-r--r--emulators/osf1_base/pkg-descr7
-rw-r--r--emulators/osf1_base/pkg-plist25
5 files changed, 85 insertions, 0 deletions
diff --git a/emulators/osf1_base/Makefile b/emulators/osf1_base/Makefile
new file mode 100644
index 000000000000..11772bafe890
--- /dev/null
+++ b/emulators/osf1_base/Makefile
@@ -0,0 +1,51 @@
+# ex:ts=8
+# Ports collection makefile for: osf1_base
+# Version required: 5.0
+# Date created: Mon Feb 03, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+DISTNAME= netscape-4.7-1.alpha
+PKGNAME= osf1_base-5.0
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.digital.com/private/netscape/
+EXTRACT_SUFX= .rpm
+
+MAINTAINER= obrien@FreeBSD.org
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/misc/rpm2cpio
+
+ONLY_FOR_ARCHS= alpha
+RESTRICTED= Not allowed to redistribute on our FTP site or CDROMs
+
+PREFIX= /usr/compat/osf1
+EXTRACT_CMD= rpm2cpio
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= |cpio -idumv
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+NO_MTREE= yes
+
+do-install:
+ @if [ -z "`kldstat -v | ${GREP} -E 'osf1_ecoff'`" ]; then \
+ ${ECHO} 'OSF/1 (Digital Unix / Tru64) mode is not enabled.\
+ Loading OSF/1 kernel module...' | fmt; \
+ osf1 || { \
+ ${ECHO} 'The OSF/1 kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man osf1" for details.' | fmt; \
+ ${FALSE}; \
+ };\
+ fi
+ @${MKDIR} ${PREFIX}/usr/lib
+ @${LN} -sf ${X11BASE}/lib/X11 ${PREFIX}/usr/lib
+ @${TAR} --exclude usr/local/* -xpzf \
+ ${WRKSRC}/usr/local/netscape/netscape-all-4.7.tar.gz \
+ -C ${PREFIX}
+ @${RM} ${PREFIX}/usr/bin/netscape
+ @${RMDIR} ${PREFIX}/usr/bin
+
+.include <bsd.port.mk>
diff --git a/emulators/osf1_base/distinfo b/emulators/osf1_base/distinfo
new file mode 100644
index 000000000000..16348e8d6dd8
--- /dev/null
+++ b/emulators/osf1_base/distinfo
@@ -0,0 +1 @@
+MD5 (netscape-4.7-1.alpha.rpm) = 7026e37b820c78480414b6694331a5dc
diff --git a/emulators/osf1_base/pkg-comment b/emulators/osf1_base/pkg-comment
new file mode 100644
index 000000000000..f1a1ba1586cc
--- /dev/null
+++ b/emulators/osf1_base/pkg-comment
@@ -0,0 +1 @@
+The base set of libraries needed in OSF/1 (Tru64) mode
diff --git a/emulators/osf1_base/pkg-descr b/emulators/osf1_base/pkg-descr
new file mode 100644
index 000000000000..953f0418484c
--- /dev/null
+++ b/emulators/osf1_base/pkg-descr
@@ -0,0 +1,7 @@
+The osf1_base port contains a minimal selection of shared libraries from a
+Compaq Tru64 5.0 installation. These libraries and support files, in
+conjunction with the osf1 module, form the basis of the osf1 compatibility
+environment.
+
+-- David
+obrien@FreeBSD.org
diff --git a/emulators/osf1_base/pkg-plist b/emulators/osf1_base/pkg-plist
new file mode 100644
index 000000000000..2455c4aee5f1
--- /dev/null
+++ b/emulators/osf1_base/pkg-plist
@@ -0,0 +1,25 @@
+@comment $FreeBSD$
+usr/shlib/libXm.so
+usr/shlib/libXmu.so
+usr/shlib/libXt.so
+usr/shlib/libX11.so
+usr/shlib/libXext.so
+usr/shlib/libdnet_stub.so
+usr/shlib/libm.so
+usr/shlib/libots.so
+usr/shlib/libc.so
+usr/shlib/libcxx.so
+usr/shlib/libexc.so
+usr/shlib/libSM.so
+usr/shlib/libICE.so
+usr/shlib/LICENSE
+etc/svc.conf
+etc/sia/OSFC2_matrix.conf
+etc/sia/bsd_matrix.conf
+etc/sia/siainitgood
+sbin/loader
+@dirrm sbin
+@dirrm etc/sia
+@dirrm etc
+@dirrm usr/shlib
+@dirrm usr