aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/ppsspp
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-10-01 17:15:53 +0800
committerjbeich <jbeich@FreeBSD.org>2017-10-01 17:15:53 +0800
commit7f2e8f9bdcb917266b37807813ceca2f7a726ee4 (patch)
tree2a06469da5ab5b366a83ed82d3326444023f9621 /emulators/ppsspp
parent771ca684c3a7c238793015e8baf535684d08940d (diff)
downloadfreebsd-ports-gnome-7f2e8f9bdcb917266b37807813ceca2f7a726ee4.tar.gz
freebsd-ports-gnome-7f2e8f9bdcb917266b37807813ceca2f7a726ee4.tar.zst
freebsd-ports-gnome-7f2e8f9bdcb917266b37807813ceca2f7a726ee4.zip
emulators/ppsspp-devel: revive and update to 1.4.2.463
Changes: https://github.com/hrydgard/ppsspp/compare/v1.4.2...11f8bcc8a
Diffstat (limited to 'emulators/ppsspp')
-rw-r--r--emulators/ppsspp/Makefile5
-rw-r--r--emulators/ppsspp/distinfo2
-rw-r--r--emulators/ppsspp/files/patch-Common_MemoryUtil.cpp31
3 files changed, 7 insertions, 31 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index a521b6262a21..9102811c9f34 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -10,6 +10,11 @@ MASTER_SITES= https://bazaar.launchpad.net/~sergio-br2/${PORTNAME}/debian-sdl/do
DISTFILES= ${PORTNAME}.1:manpage
EXTRACT_ONLY= ${DISTFILES:N*\:manpage:C/:.*//}
+.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX:N*-devel}
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= e33acdc5e922.patch:-p1
+.endif
+
MAINTAINER= jbeich@FreeBSD.org
COMMENT= PSP emulator in C++ with dynarec JIT for x86, ARM, MIPS
diff --git a/emulators/ppsspp/distinfo b/emulators/ppsspp/distinfo
index a57fad2a0925..52c7938dacbc 100644
--- a/emulators/ppsspp/distinfo
+++ b/emulators/ppsspp/distinfo
@@ -13,3 +13,5 @@ SHA256 (Kingcom-armips-v0.9-26-g770365d_GH0.tar.gz) = e6c52967082658082544f83875
SIZE (Kingcom-armips-v0.9-26-g770365d_GH0.tar.gz) = 163606
SHA256 (Kingcom-tinyformat-Release-2.0.1-7-gb7f5a22_GH0.tar.gz) = d86b5b4592047254c5118d0639e51d00869b3adc2f2c5419fdf29381ca42011e
SIZE (Kingcom-tinyformat-Release-2.0.1-7-gb7f5a22_GH0.tar.gz) = 22286
+SHA256 (e33acdc5e922.patch) = 26db4fe256c3947193b379ea7d17b0aae59e4339ae3822b53ef40fd6dca07004
+SIZE (e33acdc5e922.patch) = 1819
diff --git a/emulators/ppsspp/files/patch-Common_MemoryUtil.cpp b/emulators/ppsspp/files/patch-Common_MemoryUtil.cpp
deleted file mode 100644
index 8bb037d020fe..000000000000
--- a/emulators/ppsspp/files/patch-Common_MemoryUtil.cpp
+++ /dev/null
@@ -1,31 +0,0 @@
-https://github.com/hrydgard/ppsspp/pull/9857
-
---- Common/MemoryUtil.cpp.orig 2017-05-27 09:58:05 UTC
-+++ Common/MemoryUtil.cpp
-@@ -154,7 +154,7 @@ void *AllocateExecutableMemory(size_t size) {
- }
- #else
- static char *map_hint = 0;
--#if defined(_M_X64)
-+#if defined(_M_X64) && !defined(MAP_32BIT)
- // Try to request one that is close to our memory location if we're in high memory.
- // We use a dummy global variable to give us a good location to start from.
- if (!map_hint) {
-@@ -176,7 +176,7 @@ void *AllocateExecutableMemory(size_t size) {
- void* ptr = mmap(map_hint, size, prot,
- MAP_ANON | MAP_PRIVATE
- #if defined(_M_X64) && defined(MAP_32BIT)
-- | ((uintptr_t) map_hint == 0 ? MAP_32BIT : 0)
-+ | MAP_32BIT
- #endif
- , -1, 0);
-
-@@ -193,7 +193,7 @@ void *AllocateExecutableMemory(size_t size) {
- ERROR_LOG(MEMMAP, "Failed to allocate executable memory (%d)", (int)size);
- PanicAlert("Failed to allocate executable memory\n%s", GetLastErrorMsg());
- }
--#if defined(_M_X64) && !defined(_WIN32)
-+#if defined(_M_X64) && !defined(MAP_32BIT) && !defined(_WIN32)
- else if ((uintptr_t)map_hint <= 0xFFFFFFFF) {
- // Round up if we're below 32-bit mark, probably allocating sequentially.
- map_hint += round_page(size);