aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-26 23:11:36 +0800
committerpav <pav@FreeBSD.org>2006-03-26 23:11:36 +0800
commit08eb40ad996a356f43b8abf6bb3f866d3553d5dc (patch)
tree0f065cbed658329ffe1d10d800c0f7c80bae0337 /emulators/qemu-devel/Makefile
parent2bdfafa1d7a81d76fb87c3a9f87af78accf87595 (diff)
downloadfreebsd-ports-gnome-08eb40ad996a356f43b8abf6bb3f866d3553d5dc.tar.gz
freebsd-ports-gnome-08eb40ad996a356f43b8abf6bb3f866d3553d5dc.tar.zst
freebsd-ports-gnome-08eb40ad996a356f43b8abf6bb3f866d3553d5dc.zip
- Lonnie sent me updates to 2 of his usb fixes,
- and posted another usb bugfix affecting FreeBSD guests - (optionally) seperate out the two WITH_HACKS patches after I learned the cirrus patch can cause problems with xp guests too PR: ports/94949 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer)
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 28c88772c7a0..f0ef5169731f 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.8.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
@@ -16,8 +16,11 @@ MASTER_SITES= http://www.qemu.org/:release \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
http://people.freebsd.org/~maho/qemu/:misc
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
-.if defined (WITH_HACKS)
-DISTFILES+= qemu_dma_patch.tar.gz:idedma patch3_cirrus:misc
+.if defined (WITH_HACKS_IDEDMA) || defined (WITH_HACKS)
+DISTFILES+= qemu_dma_patch.tar.gz:idedma
+.endif
+.if defined (WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
+DISTFILES+= patch3_cirrus:misc
.endif
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -61,13 +64,16 @@ pre-everything::
@${ECHO_MSG} "Notice: you can build qemu with the (alpha!) kqemu accelerator kernel module"
@${ECHO_MSG} "by defining WITH_KQEMU."
.endif
-.if !defined(WITH_HACKS)
+.if !defined(WITH_HACKS_IDEDMA) && !defined(WITH_HACKS_CIRRUS) && !defined(WITH_HACKS)
@${ECHO_MSG} "You can build qemu with some hacks (esp. for speedup)"
- @${ECHO_MSG} "by defining WITH_HACKS."
- @${ECHO_MSG} "1. IDE Bus-master DMA Support by John Coiner"
+ @${ECHO_MSG} "by defining WITH_HACKS, or specifically:"
+ @${ECHO_MSG} "1. WITH_HACKS_IDEDMA: IDE Bus-master DMA Support by John Coiner"
@${ECHO_MSG} "http://people.brandeis.edu/~jcoiner/qemu_idedma/qemu_dma_patch.html"
- @${ECHO_MSG} "2. higher speed on large display (cirrus_vga) by Juergen Pfennig"
+ @${ECHO_MSG} "2. WITH_HACKS_CIRRUS: higher speed on large display (cirrus_vga)"
+ @${ECHO_MSG} "by Juergen Pfennig"
@${ECHO_MSG} "http://lists.gnu.org/archive/html/qemu-devel/2006-01/msg00208.html"
+ @${ECHO_MSG} "Note: this second patch is known to cause mouse problems with some(?)"
+ @${ECHO_MSG} "versions of XP, and also minor redraw bugs with some Linux guests."
.endif
.if !defined(WITH_SAMBA) && !exists(${LOCALBASE}/sbin/smbd)
@${ECHO_MSG} "Notice: if you need qemu's -smb option (smb-export local dir to guest)"
@@ -86,8 +92,10 @@ pre-patch:
done
post-patch:
-.if defined(WITH_HACKS)
+.if defined(WITH_HACKS_IDEDMA) || defined (WITH_HACKS)
@cd ${WRKDIR} ; ${TAR} xfz ${DISTDIR}/${DIST_SUBDIR}/qemu_dma_patch.tar.gz ; ${CP} new_qemu_dma_patch/bios.bin ${WRKSRC}/pc-bios; cd ${WRKSRC}; ${PATCH} --quiet -p1 < ../new_qemu_dma_patch/qemu-piix4-udma.patch
+.endif
+.if defined(WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
@cd ${WRKSRC} ; ${PATCH} --quiet < ${DISTDIR}/${DIST_SUBDIR}/patch3_cirrus
.endif