aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-10-24 03:06:58 +0800
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-10-24 03:06:58 +0800
commit65c5948417d6f5aa9e0d47b4962b0a94f5fc3c34 (patch)
tree7ce3c7566a207222c74c5e8115a279c0ad8f4234 /emulators/qemu-devel/Makefile
parent93076cc5d64a3e78a526b7666903a7263b1d302b (diff)
downloadfreebsd-ports-gnome-65c5948417d6f5aa9e0d47b4962b0a94f5fc3c34.tar.gz
freebsd-ports-gnome-65c5948417d6f5aa9e0d47b4962b0a94f5fc3c34.tar.zst
freebsd-ports-gnome-65c5948417d6f5aa9e0d47b4962b0a94f5fc3c34.zip
emulators/qemu-devel: Update version 5.1.0.20200909=>5.1.0.20201010
- Fix plist when DOCS disabled [1] PR: 250456 [1] Reported by: lwhsu [1]
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 4d94d10a2cad..0c4e38e6a9ae 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-DISTVERSION= 5.1.0.20200909
+DISTVERSION= 5.1.0.20201019
CATEGORIES= emulators
PKGNAMESUFFIX= -devel
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -15,23 +15,25 @@ LICENSE= GPLv2
ONLY_FOR_ARCHS= amd64 powerpc powerpc64
IGNORE_FreeBSD_11= Unable to produce Position Independent Code
+BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
LIB_DEPENDS= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libepoxy.so:graphics/libepoxy \
libpcre2-8.so:devel/pcre2
-USES= bison compiler:c11 cpe gmake gnome iconv:wchar_t perl5 \
+USES= bison compiler:c11 cpe gmake gnome iconv:wchar_t ninja perl5 \
pkgconfig python:build tar:xz xorg
USE_GITHUB= yes
USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
+USE_PYTHON= distutils noflavors
USE_XORG= pixman
-GH_TUPLE= qemu:qemu:9435a8b \
+GH_TUPLE= qemu:qemu:22d30b3 \
qemu:keycodemapdb:6b3d716:keycodemapdb/ui/keycodemapdb \
qemu:dtc:85e5d83:dtc/dtc \
- mesonbuild:meson:68ed748:meson/meson \
+ mesonbuild:meson:776acd2:meson/meson \
cota:berkeley-softfloat-3:b64af41:berkeleysoftfloat3/tests/fp/berkeley-softfloat-3 \
cota:berkeley-testfloat-3:5a59dce:berkeleytestfloat3/tests/fp/berkeley-testfloat-3
#BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
@@ -67,8 +69,6 @@ CAPSTONE_CONFIGURE_OFF= --disable-capstone
CAPSTONE_LIB_DEPENDS= libcapstone.so:devel/capstone4
CURL_CONFIGURE_OFF= --disable-curl
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html \
- sphinx-build:textproc/py-sphinx
DOCS_CONFIGURE_ENABLE= docs
DOCS_USES= makeinfo
GNUTLS_CONFIGURE_OFF= --disable-gnutls
@@ -111,7 +111,7 @@ WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
--extra-ldflags=-L\"${LOCALBASE}/lib\" --enable-debug \
- --prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
+ --prefix=${PREFIX} --cc=${CC} --enable-netmap --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
@@ -141,11 +141,6 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
PLIST_SUB+= LINUXBOOT_DMA=""
-post-patch:
- @${REINPLACE_CMD} -e 's|/etc/qemu-ifup|${PREFIX}/etc/qemu-ifup|' \
- -e 's|/etc/qemu-ifdown|${PREFIX}/etc/qemu-ifdown|' \
- ${WRKSRC}/include/net/net.h
-
post-patch-CDROM_DMA-off:
@${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
;id=6a21efe0e8037caacf3a41799048b32bb2d0cf7a'>- Fix innd/nnrpd semget failuresfluffy2012-09-022-1/+74 * news/inn: fix plaintext command injection, CVE-2012-3523rea2012-08-272-1/+62 * Move the rc.d scripts of the form *.sh.in to *.indougb2012-08-062-1/+1 * - Fix typofluffy2012-07-081-1/+1 * - Add options for OpenSSL (for those who don't need) and GnuPG (pgpverify)fluffy2012-07-072-50/+68 * - Remove SITE_PERL from *_DEPENDSaz2012-06-301-1/+1 * - Update INN to 2.5.2 releasefluffy2012-06-277-102/+108 * Fix rc script.thierry2012-02-263-4/+4 * - replace `YES' with `yes' in USE_PYTHON/USE_PYDISTUTILS (mostly)rm2012-02-191-1/+1 * - Fix plist.avilla2012-01-242-2/+28 * In the rc.d scripts, change assignments to rcvar to use thedougb2012-01-141-9/+4 * - Get Rid MD5 supportmiwi2011-03-201-1/+0 * - Switch MASTER_SITES to local to make it fetchable againfluffy2010-09-301-2/+5 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1