aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2016-05-29 08:24:29 +0800
committerbofh <bofh@FreeBSD.org>2016-05-29 08:24:29 +0800
commitbebf77f9c5748363f4761b164926a7202227e2c4 (patch)
tree3945d1f39b1b16578e8b1397780a90dd3b2d6559 /emulators/qemu-devel/Makefile
parentf971205797cbcb42845bc86c14055239980dac29 (diff)
downloadfreebsd-ports-gnome-bebf77f9c5748363f4761b164926a7202227e2c4.tar.gz
freebsd-ports-gnome-bebf77f9c5748363f4761b164926a7202227e2c4.tar.zst
freebsd-ports-gnome-bebf77f9c5748363f4761b164926a7202227e2c4.zip
emulators/qemu-devel: Update version 2.5.0=>2.6.1
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index a6617e1e6741..559a057ecb27 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-DISTVERSION= 2.5.0
-PORTREVISION= 5
+DISTVERSION= 2.6.0
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/
PKGNAMESUFFIX= -devel
@@ -16,8 +15,8 @@ LICENSE= GPLv2
HAS_CONFIGURE= yes
USES= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
USE_PERL5= build
-USE_XORG= pixman
-USE_GNOME+= glib20
+USE_XORG= pixman x11 xext
+USE_GNOME+= cairo gdkpixbuf2 glib20
MAKE_ENV+= BSD_MAKE="${MAKE}"
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
@@ -59,7 +58,7 @@ USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_CONFIGURE_OFF= --disable-usb-redir
PCAP_CONFIGURE_ON= --enable-pcap
-PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch
+PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch ${FILESDIR}/pcap-patch-net_net.c
STATIC_LINK_CONFIGURE_ON= --static
STATIC_LINK_PREVENTS= GTK2 X11
STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
@@ -79,6 +78,10 @@ CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
--smbd=${LOCALBASE}/sbin/smbd --enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
+LIB_DEPENDS+= libnettle.so:security/nettle \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
.include <bsd.port.options.mk>
.if !defined(STRIP) || ${STRIP} == ""