aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2014-01-20 06:27:14 +0800
committernox <nox@FreeBSD.org>2014-01-20 06:27:14 +0800
commit6667cce4e244692f57513a04805653adb856a943 (patch)
treebbc7ae9c75621815b98f4a3e651c35a4c285552c /emulators/qemu-devel
parent426d6d16dd50780a5089afaca66b72506636a281 (diff)
downloadfreebsd-ports-gnome-6667cce4e244692f57513a04805653adb856a943.tar.gz
freebsd-ports-gnome-6667cce4e244692f57513a04805653adb856a943.tar.zst
freebsd-ports-gnome-6667cce4e244692f57513a04805653adb856a943.zip
- Remove last mentions of SEABIOS_GIT. (which were nops already tho)
- Update LIB_DEPENDS. - Rewrite NOPORTDOCS. - Stagify. - Fix plist. (empty dirs) - Bump PORTREISION. Submitted by: rene (via private emai)
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile37
-rw-r--r--emulators/qemu-devel/files/patch-Makefile11
-rw-r--r--emulators/qemu-devel/pkg-plist7
3 files changed, 26 insertions, 29 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 66b1208fab01..38306296dc55 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qemu
PORTVERSION= 1.7.0
+PORTREISION= 1
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -22,8 +23,6 @@ USE_XORG= pixman
USE_GNOME+= glib20
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}"
-MAN1= qemu.1 qemu-img.1
-MAN8= qemu-nbd.8
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
CONFLICTS_INSTALL= qemu-[0-9]*
@@ -37,7 +36,6 @@ JPEG_DESC= jpeg dependency (vnc lossy compression)
PNG_DESC= png dependency (vnc compression)
CDROM_DMA_DESC= IDE CDROM DMA
PCAP_DESC= pcap dependency (networking with bpf)
-SEABIOS_GIT_DESC= add seabios snapshot (-bios bios.bin-1.6.3.1)
USBREDIR_DESC= usb device network redirection (experimental!)
GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Don't build non-x86 system targets
@@ -45,8 +43,6 @@ BSD_USER_DESC= Also build bsd-user targets (for testing)
STATIC_LINK_DESC= Statically link the executables
OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP
-NO_STAGE= yes
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBSD_USER}
@@ -150,31 +146,31 @@ PLIST_SUB+= GTK2=""
.if empty(PORT_OPTIONS:MGNUTLS)
CONFIGURE_ARGS+= --disable-vnc-tls
.else
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.endif
.if empty(PORT_OPTIONS:MSASL)
CONFIGURE_ARGS+= --disable-vnc-sasl
.else
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.endif
.if empty(PORT_OPTIONS:MJPEG)
CONFIGURE_ARGS+= --disable-vnc-jpeg
.else
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
.endif
.if empty(PORT_OPTIONS:MPNG)
CONFIGURE_ARGS+= --disable-vnc-png
.else
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
.endif
.if empty(PORT_OPTIONS:MCURL)
CONFIGURE_ARGS+= --disable-curl
.else
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.endif
.if empty(PORT_OPTIONS:MOPENGL)
@@ -205,14 +201,10 @@ CONFIGURE_ARGS+= --static
RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba36
.endif
-.if ${PORT_OPTIONS:MSEABIOS_GIT}
-RUN_DEPENDS+= seabios-devel>=1.6.3.1:${PORTSDIR}/emulators/seabios-devel
-.endif
-
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= NOPORTDOCS=1
-.else
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
+.else
+MAKE_ARGS+= NOPORTDOCS=1
.endif
.if !defined(STRIP) || ${STRIP} == ""
@@ -287,16 +279,15 @@ post-configure:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${DOCSDIR}/)
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR}/)
.endif
- @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
- @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc
@if [ ! -f ${PREFIX}/etc/qemu-ifup ]; then \
- ${CP} -p ${PREFIX}/etc/qemu-ifup.sample ${PREFIX}/etc/qemu-ifup ; \
+ ${CP} -p ${STAGEDIR}${PREFIX}/etc/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc/qemu-ifup ; \
fi
@if [ ! -f ${PREFIX}/etc/qemu-ifdown ]; then \
- ${CP} -p ${PREFIX}/etc/qemu-ifdown.sample ${PREFIX}/etc/qemu-ifdown ; \
+ ${CP} -p ${STAGEDIR}${PREFIX}/etc/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc/qemu-ifdown ; \
fi
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/emulators/qemu-devel/files/patch-Makefile b/emulators/qemu-devel/files/patch-Makefile
index 3eba14264cf3..f9fc530ea762 100644
--- a/emulators/qemu-devel/files/patch-Makefile
+++ b/emulators/qemu-devel/files/patch-Makefile
@@ -1,5 +1,6 @@
-Index: qemu/Makefile
-@@ -65,7 +65,11 @@ LIBS+=-lz $(LIBS_TOOLS)
+--- Makefile.orig 2013-11-27 23:15:55.000000000 +0100
++++ Makefile 2014-01-19 15:35:48.000000000 +0100
+@@ -72,7 +72,11 @@
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
@@ -11,7 +12,7 @@ Index: qemu/Makefile
ifdef CONFIG_VIRTFS
DOCS+=fsdev/virtfs-proxy-helper.1
endif
-@@ -304,8 +308,10 @@ endif
+@@ -311,8 +315,10 @@
install-doc: $(DOCS)
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
@@ -22,14 +23,14 @@ Index: qemu/Makefile
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
$(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
-@@ -334,7 +340,10 @@ install-confdir:
+@@ -341,7 +347,10 @@
$(INSTALL_DIR) "$(DESTDIR)$(qemu_confdir)"
install-sysconfig: install-datadir install-confdir
- $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(qemu_confdir)"
+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(qemu_confdir)/target-x86_64.conf.sample"
+ if [ ! -f "$(qemu_confdir)/target-x86_64.conf" ]; then \
-+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(qemu_confdir)"; \
++ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(qemu_confdir)"; \
+ fi
install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig \
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 98097b7f1197..98e8589b6a84 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -37,6 +37,9 @@ bin/qemu-system-i386
bin/qemu-system-x86_64
%%NONX86%%bin/qemu-system-xtensa
%%NONX86%%bin/qemu-system-xtensaeb
+man/man1/qemu.1.gz
+man/man1/qemu-img.1.gz
+man/man8/qemu-nbd.8.gz
@unexec if cmp -s %D/etc/qemu-ifup.sample %D/etc/qemu-ifup; then rm -f %D/etc/qemu-ifup; fi
etc/qemu-ifup.sample
@exec if [ ! -f %D/etc/qemu-ifup ] ; then cp -p %D/%F %B/qemu-ifup; fi
@@ -132,4 +135,6 @@ etc/qemu/target-x86_64.conf.sample
%%GTK2%%@dirrmtry share/locale/de_DE/LC_MESSAGES
%%GTK2%%@dirrmtry share/locale/de_DE
@dirrmtry %%DATADIR%%
-@dirrmtry %%DOCSDIR%%
+@exec mkdir -p %D/var/run
+@dirrmtry var/run
+@dirrmtry var