aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-11-14 13:17:09 +0800
committerlawrance <lawrance@FreeBSD.org>2005-11-14 13:17:09 +0800
commitbc2fcbcf1d563f8afcbb68c2d964a1765d2d64c8 (patch)
treef8f13631366de7a38a0cd83dc5dc9200c8778ba8 /emulators/qemu-devel
parentf6656b64cae10b8334883e5bb9ce9bb16f52ac24 (diff)
downloadfreebsd-ports-gnome-bc2fcbcf1d563f8afcbb68c2d964a1765d2d64c8.tar.gz
freebsd-ports-gnome-bc2fcbcf1d563f8afcbb68c2d964a1765d2d64c8.tar.zst
freebsd-ports-gnome-bc2fcbcf1d563f8afcbb68c2d964a1765d2d64c8.zip
Update to 2005-11-12 snapshot.
PR: ports/88952 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer)
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile5
-rw-r--r--emulators/qemu-devel/distinfo4
-rw-r--r--emulators/qemu-devel/files/patch-vl.c21
3 files changed, 24 insertions, 6 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 0b398be15b96..b9450090fff5 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= qemu
-PORTVERSION= 0.7.2s.20051030
+PORTVERSION= 0.7.2s.20051112
PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://people.fruitsalad.org/nox/qemu/:snapshot \
+ http://www.volny.cz/xnavara/qemu/:snapshot \
http://qemu.dad-answers.com/download/qemu/:snapshot
-DISTNAME= ${PORTNAME}-snapshot-2005-10-30_23
+DISTNAME= ${PORTNAME}-snapshot-2005-11-12_23
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
MAINTAINER= nox@jelal.kn-bremen.de
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index f08c3a161c2f..67275c763f8b 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (qemu-snapshot-2005-10-30_23.tar.bz2) = d41b56254cc8704aef80fd188e30e95a
-SIZE (qemu-snapshot-2005-10-30_23.tar.bz2) = 1162650
+MD5 (qemu-snapshot-2005-11-12_23.tar.bz2) = 27673ed3a6bc78b4be2933ddc63f8276
+SIZE (qemu-snapshot-2005-11-12_23.tar.bz2) = 1219984
diff --git a/emulators/qemu-devel/files/patch-vl.c b/emulators/qemu-devel/files/patch-vl.c
index 85a521ba3bd0..5eff6568373b 100644
--- a/emulators/qemu-devel/files/patch-vl.c
+++ b/emulators/qemu-devel/files/patch-vl.c
@@ -1,4 +1,5 @@
-Index: qemu/vl.c
+--- vl.c.orig Mon Nov 14 15:55:56 2005
++++ vl.c Mon Nov 14 15:57:25 2005
@@ -40,6 +40,10 @@
#include <sys/socket.h>
#include <netinet/in.h>
@@ -10,7 +11,7 @@ Index: qemu/vl.c
#ifdef _BSD
#include <sys/stat.h>
#ifndef __APPLE__
-@@ -1280,7 +1284,7 @@
+@@ -1363,7 +1367,7 @@
return chr;
}
@@ -19,3 +20,19 @@ Index: qemu/vl.c
CharDriverState *qemu_chr_open_pty(void)
{
char slave_name[1024];
+@@ -1509,6 +1513,7 @@
+ return chr;
+ }
+
++#if defined(__linux__)
+ static int pp_ioctl(CharDriverState *chr, int cmd, void *arg)
+ {
+ int fd = (int)chr->opaque;
+@@ -1571,6 +1576,7 @@
+ chr->chr_ioctl = pp_ioctl;
+ return chr;
+ }
++#endif
+
+ #else
+ CharDriverState *qemu_chr_open_pty(void)