aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2015-01-20 02:46:51 +0800
committernox <nox@FreeBSD.org>2015-01-20 02:46:51 +0800
commit2b218e6d0cf2900c9b9d653850c785e903afa4a6 (patch)
tree6148fe8195a7e39945abacba806d3e38df983309 /emulators/qemu
parentb14e4f4c81e0c1e148deba699e2f7d1a9d1d079e (diff)
downloadfreebsd-ports-gnome-2b218e6d0cf2900c9b9d653850c785e903afa4a6.tar.gz
freebsd-ports-gnome-2b218e6d0cf2900c9b9d653850c785e903afa4a6.tar.zst
freebsd-ports-gnome-2b218e6d0cf2900c9b9d653850c785e903afa4a6.zip
Fix build on 10+/i386 for when gcc49 becomes default (and fix ALL_TARGETS
on 10+/i386 while we're at it.) PR: 196855 Submitted by: gerald
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index dfd0883df06f..25a53ef61e8c 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -14,8 +14,7 @@ MAINTAINER= nox@FreeBSD.org
COMMENT= QEMU CPU Emulator
HAS_CONFIGURE= yes
-USE_GCC= any
-USES= gmake perl5
+USES= gmake perl5 compiler:features
USE_PERL5= build
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}"
@@ -39,6 +38,14 @@ OPTIONS_DEFAULT= SDL GNUTLS CURL PCAP GNS3 CDROM_DMA
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386" && ${COMPILER_TYPE} == "clang"
+# gcc49 breaks target-i386 on i386, and gcc48 breaks ALL_TARGETS on i386:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196855
+USE_GCC= 4.7
+.else
+USE_GCC= any
+.endif
+
.if empty(PORT_OPTIONS:MALL_TARGETS)
CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
PLIST_SUB+= ALLTARGETS="@comment "