aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2016-06-10 19:01:52 +0800
committerbofh <bofh@FreeBSD.org>2016-06-10 19:01:52 +0800
commitbe46f5dffa8f38df2b8f5db3959add577e0e4803 (patch)
tree5a4c731927c851209dda258dab1b34c535834334 /emulators/qemu
parentc30aca729c93e0f540309139744c7996fd84d6cf (diff)
downloadfreebsd-ports-gnome-be46f5dffa8f38df2b8f5db3959add577e0e4803.tar.gz
freebsd-ports-gnome-be46f5dffa8f38df2b8f5db3959add577e0e4803.tar.zst
freebsd-ports-gnome-be46f5dffa8f38df2b8f5db3959add577e0e4803.zip
emulators/qemu: Update version 2.4.0=>2.5.1.1
- Change X86_TARGETS Description - Update pkg-plist to fix X86_TARGETS issue
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile11
-rw-r--r--emulators/qemu/distinfo5
-rw-r--r--emulators/qemu/files/patch-Makefile9
-rw-r--r--emulators/qemu/files/patch-configure128
-rw-r--r--emulators/qemu/files/patch-include_qemu-common.h4
-rw-r--r--emulators/qemu/files/pcap-patch101
-rw-r--r--emulators/qemu/pkg-plist55
7 files changed, 154 insertions, 159 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 50fc3858d481..1808d99c128e 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 2.4.1
-PORTREVISION= 1
+PORTVERSION= 2.5.1.1
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= qemu/${PORTVERSION}
MAINTAINER= bofh@FreeBSD.org
@@ -34,7 +32,7 @@ CDROM_DMA_DESC= IDE CDROM DMA
PCAP_DESC= pcap dependency (networking with bpf)
USBREDIR_DESC= usb device network redirection (experimental!)
GNS3_DESC= gns3 patches (promiscuous multicast)
-X86_TARGETS_DESC= Don't build non-x86 system targets
+X86_TARGETS_DESC= Build only x86 system targets
BSD_USER_DESC= Also build bsd-user targets (for testing)
STATIC_LINK_DESC= Statically link the executables
OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3
@@ -76,7 +74,7 @@ PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
- --disable-smartcard-nss --disable-libssh2 --enable-debug \
+ --disable-libssh2 --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--smbd=${LOCALBASE}/sbin/smbd --enable-debug-info --python=${PYTHON_CMD} \
@@ -155,9 +153,6 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
post-patch:
- @${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
@${REINPLACE_CMD} -E \
-e "/^by Tibor .TS. S/s|Sch.*z.$$|Schuetz.|" \
${WRKSRC}/qemu-doc.texi
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index bb14b1b8df22..100f1af8781c 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qemu/2.4.1/qemu-2.4.1.tar.bz2) = e3d5cf4c8b1f9129c9c797329a515bfb6b3b1ded0ab8b394c8a316490fe3a177
-SIZE (qemu/2.4.1/qemu-2.4.1.tar.bz2) = 25087522
+TIMESTAMP = 1464476316
+SHA256 (qemu/2.5.1.1/qemu-2.5.1.1.tar.bz2) = 28d9946e43765a44ccccca3cba5f4f9034f2759ec1f2ce16594ddb6776c8efe6
+SIZE (qemu/2.5.1.1/qemu-2.5.1.1.tar.bz2) = 25474902
diff --git a/emulators/qemu/files/patch-Makefile b/emulators/qemu/files/patch-Makefile
index 74d2971e0d2a..1600e4c6e6c6 100644
--- a/emulators/qemu/files/patch-Makefile
+++ b/emulators/qemu/files/patch-Makefile
@@ -1,18 +1,19 @@
---- Makefile.orig 2015-11-03 20:01:30 UTC
+--- Makefile.orig 2016-03-29 21:01:14 UTC
+++ Makefile
-@@ -88,7 +88,11 @@ LIBS+=-lz $(LIBS_TOOLS)
+@@ -90,8 +90,12 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8
+else
- DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 qmp-commands.txt
+ DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+ DOCS+=qmp-commands.txt
+endif
ifdef CONFIG_LINUX
DOCS+=kvm_stat.1
endif
-@@ -390,8 +394,10 @@ endif
+@@ -407,8 +411,10 @@ endif
install-doc: $(DOCS)
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
diff --git a/emulators/qemu/files/patch-configure b/emulators/qemu/files/patch-configure
index f08019d7b3ce..1352414aed42 100644
--- a/emulators/qemu/files/patch-configure
+++ b/emulators/qemu/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2015-11-03 20:01:31 UTC
+--- configure.orig 2016-03-30 17:53:28 UTC
+++ configure
-@@ -273,7 +273,7 @@ DSOSUF=".so"
+@@ -276,7 +276,7 @@ DSOSUF=".so"
LDFLAGS_SHARED="-shared"
modules="no"
prefix="/usr/local"
@@ -9,7 +9,28 @@
datadir="\${prefix}/share"
qemu_docdir="\${prefix}/share/doc/qemu"
bindir="\${prefix}/bin"
-@@ -2102,7 +2102,7 @@ if test "$gtk" != "no"; then
+@@ -344,6 +344,9 @@ libssh2=""
+ vhdx=""
+ numa=""
+ tcmalloc="no"
++pcap="no"
++pcap_create="no"
++bpf="no"
+ jemalloc="no"
+
+ # parse CC options first
+@@ -905,6 +908,10 @@ for opt do
+ ;;
+ --enable-vnc-png) vnc_png="yes"
+ ;;
++ --enable-pcap) pcap="yes"
++ ;;
++ --disable-pcap) pcap="no"
++ ;;
+ --disable-slirp) slirp="no"
+ ;;
+ --disable-uuid) uuid="no"
+@@ -2241,7 +2248,7 @@ if test "$gtk" != "no"; then
gtk_cflags="$gtk_cflags $x11_cflags"
gtk_libs="$gtk_libs $x11_libs"
fi
@@ -18,20 +39,69 @@
gtk="yes"
elif test "$gtk" = "yes"; then
feature_not_found "gtk" "Install gtk2 or gtk3 devel"
-@@ -3643,15 +3643,18 @@ if compile_prog "" "" ; then
+@@ -2413,6 +2420,50 @@ then
fi
+ ##########################################
++# pcap probe
++if test "$pcap" = "yes" -a "$pcap" != "no"; then
++ cat > $TMPC << EOF
++#include <pcap.h>
++int main(void) { return (pcap_lib_version() == (char *)0 ? 1 : 0); }
++EOF
++ if test "$mingw32" = "no" ; then
++ libpcap=-lpcap
++ else
++ libpcap=-lwpcap
++ fi
++ if compile_prog "" "$libpcap" ; then
++ :
++ else
++ echo
++ echo "Error: Could not find pcap"
++ echo "Make sure to have the pcap libs and headers installed."
++ echo
++ exit 1
++ fi
++ cat > $TMPC << EOF
++#include <pcap.h>
++int main(void)
++{
++ char errbuf[PCAP_ERRBUF_SIZE];
++ return (pcap_create("foo", errbuf) == (pcap_t *)0 ? 1 : 0);
++}
++EOF
++ if compile_prog "" "$libpcap" ; then
++ pcap_create="yes"
++ fi
++ cat > $TMPC << EOF
++#define PCAP_DONT_INCLUDE_PCAP_BPF_H
++#include <pcap.h>
++#include <net/bpf.h>
++int main(void) { return (BPF_MAJOR_VERSION); }
++EOF
++ if compile_prog ; then
++ bpf="yes"
++ fi
++ libs_softmmu="$libpcap $libs_softmmu"
++fi # test "$pcap"
++
++##########################################
+ # libtasn1 - only for the TLS creds/session test suite
+
+ tasn1=yes
+@@ -2983,7 +3034,7 @@ for i in $glib_modules; do
+ glib_libs=`$pkg_config --libs $i`
+ CFLAGS="$glib_cflags $CFLAGS"
+ LIBS="$glib_libs $LIBS"
+- libs_qga="$glib_libs $libs_qga"
++ libs_qga="$glib_libs -lintl $libs_qga"
+ else
+ error_exit "glib-$glib_req_ver $i is required to compile QEMU"
+ fi
+@@ -3864,14 +3915,7 @@ fi
+
# Check if tools are available to build documentation.
-+#if test "$docs" != "no" ; then
-+# if has makeinfo && has pod2man; then
-+# docs=yes
-+# else
-+# if test "$docs" = "yes" ; then
-+# feature_not_found "docs" "Install texinfo and Perl/perl-podlators"
-+# fi
-+# docs=no
-+# fi
-+#fi
if test "$docs" != "no" ; then
- if has makeinfo && has pod2man; then
- docs=yes
@@ -41,11 +111,11 @@
- fi
- docs=no
- fi
-+ docs=yes
++docs=yes
fi
# Search for bswap_32 function
-@@ -3793,6 +3796,17 @@ fi
+@@ -3999,6 +4043,17 @@ fi
# check for libusb
if test "$libusb" != "no" ; then
@@ -63,7 +133,7 @@
if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
libusb="yes"
libusb_cflags=$($pkg_config --cflags libusb-1.0)
-@@ -3805,6 +3819,7 @@ if test "$libusb" != "no" ; then
+@@ -4011,6 +4066,7 @@ if test "$libusb" != "no" ; then
fi
libusb="no"
fi
@@ -71,3 +141,27 @@
fi
# check for usbredirparser for usb network redirection support
+@@ -4773,6 +4829,7 @@ echo "Audio drivers $audio_drv_list"
+ echo "Block whitelist (rw) $block_drv_rw_whitelist"
+ echo "Block whitelist (ro) $block_drv_ro_whitelist"
+ echo "VirtFS support $virtfs"
++echo "pcap support $pcap"
+ echo "VNC support $vnc"
+ if test "$vnc" = "yes" ; then
+ echo "VNC SASL support $vnc_sasl"
+@@ -4951,6 +5008,15 @@ fi
+ if test "$profiler" = "yes" ; then
+ echo "CONFIG_PROFILER=y" >> $config_host_mak
+ fi
++if test "$pcap" = "yes" ; then
++ echo "CONFIG_PCAP=y" >> $config_host_mak
++ if test "$pcap_create" = "yes" ; then
++ echo "CONFIG_PCAP_CREATE=y" >> $config_host_mak
++ fi
++ if test "$bpf" = "yes" ; then
++ echo "CONFIG_BPF=y" >> $config_host_mak
++ fi
++fi
+ if test "$slirp" = "yes" ; then
+ echo "CONFIG_SLIRP=y" >> $config_host_mak
+ echo "CONFIG_SMBD_COMMAND=\"$smbd\"" >> $config_host_mak
diff --git a/emulators/qemu/files/patch-include_qemu-common.h b/emulators/qemu/files/patch-include_qemu-common.h
index 198e5e22c3c7..9a02c4025261 100644
--- a/emulators/qemu/files/patch-include_qemu-common.h
+++ b/emulators/qemu/files/patch-include_qemu-common.h
@@ -1,6 +1,6 @@
---- include/qemu-common.h.orig 2015-11-03 20:01:34 UTC
+--- include/qemu-common.h.orig 2016-03-30 18:14:31 UTC
+++ include/qemu-common.h
-@@ -568,7 +568,9 @@ void qemu_hexdump(const char *buf, FILE
+@@ -469,7 +469,9 @@ void qemu_hexdump(const char *buf, FILE
#define VEC_OR(v1, v2) ((v1) | (v2))
/* altivec.h may redefine the bool macro as vector type.
* Reset it to POSIX semantics. */
diff --git a/emulators/qemu/files/pcap-patch b/emulators/qemu/files/pcap-patch
index d31c1c9eda17..f5b00941b360 100644
--- a/emulators/qemu/files/pcap-patch
+++ b/emulators/qemu/files/pcap-patch
@@ -1,102 +1,3 @@
---- configure.orig 2015-08-11 19:11:05 UTC
-+++ configure
-@@ -338,6 +338,9 @@ libssh2=""
- vhdx=""
- numa=""
- tcmalloc="no"
-+pcap="no"
-+pcap_create="no"
-+bpf="no"
-
- # parse CC options first
- for opt do
-@@ -896,6 +899,10 @@ for opt do
- ;;
- --enable-vnc-png) vnc_png="yes"
- ;;
-+ --enable-pcap) pcap="yes"
-+ ;;
-+ --disable-pcap) pcap="no"
-+ ;;
- --disable-slirp) slirp="no"
- ;;
- --disable-uuid) uuid="no"
-@@ -2354,6 +2361,51 @@ EOF
- fi
-
- ##########################################
-+# pcap probe
-+
-+if test "$pcap" = "yes" -a "$pcap" != "no"; then
-+ cat > $TMPC << EOF
-+#include <pcap.h>
-+int main(void) { return (pcap_lib_version() == (char *)0 ? 1 : 0); }
-+EOF
-+ if test "$mingw32" = "no" ; then
-+ libpcap=-lpcap
-+ else
-+ libpcap=-lwpcap
-+ fi
-+ if compile_prog "" "$libpcap" ; then
-+ :
-+ else
-+ echo
-+ echo "Error: Could not find pcap"
-+ echo "Make sure to have the pcap libs and headers installed."
-+ echo
-+ exit 1
-+ fi
-+ cat > $TMPC << EOF
-+#include <pcap.h>
-+int main(void)
-+{
-+ char errbuf[PCAP_ERRBUF_SIZE];
-+ return (pcap_create("foo", errbuf) == (pcap_t *)0 ? 1 : 0);
-+}
-+EOF
-+ if compile_prog "" "$libpcap" ; then
-+ pcap_create="yes"
-+ fi
-+ cat > $TMPC << EOF
-+#define PCAP_DONT_INCLUDE_PCAP_BPF_H
-+#include <pcap.h>
-+#include <net/bpf.h>
-+int main(void) { return (BPF_MAJOR_VERSION); }
-+EOF
-+ if compile_prog ; then
-+ bpf="yes"
-+ fi
-+ libs_softmmu="$libpcap $libs_softmmu"
-+fi # test "$pcap"
-+
-+##########################################
- # VNC TLS/WS detection
- if test "$vnc" = "yes" -a "$vnc_tls" != "no" ; then
- cat > $TMPC <<EOF
-@@ -4515,6 +4567,7 @@ echo "Audio drivers $audio_drv_list"
- echo "Block whitelist (rw) $block_drv_rw_whitelist"
- echo "Block whitelist (ro) $block_drv_ro_whitelist"
- echo "VirtFS support $virtfs"
-+echo "pcap support $pcap"
- echo "VNC support $vnc"
- if test "$vnc" = "yes" ; then
- echo "VNC TLS support $vnc_tls"
-@@ -4692,6 +4745,15 @@ fi
- if test "$profiler" = "yes" ; then
- echo "CONFIG_PROFILER=y" >> $config_host_mak
- fi
-+if test "$pcap" = "yes" ; then
-+ echo "CONFIG_PCAP=y" >> $config_host_mak
-+ if test "$pcap_create" = "yes" ; then
-+ echo "CONFIG_PCAP_CREATE=y" >> $config_host_mak
-+ fi
-+ if test "$bpf" = "yes" ; then
-+ echo "CONFIG_BPF=y" >> $config_host_mak
-+ fi
-+fi
- if test "$slirp" = "yes" ; then
- echo "CONFIG_SLIRP=y" >> $config_host_mak
- echo "CONFIG_SMBD_COMMAND=\"$smbd\"" >> $config_host_mak
--- net/clients.h.orig 2015-08-11 19:11:09 UTC
+++ net/clients.h
@@ -49,6 +49,12 @@ int net_init_bridge(const NetClientOptio
@@ -213,7 +114,7 @@
+
+int net_init_pcap(const NetClientOptions *opts, const char *name, NetClientState *peer)
+{
-+ const NetdevPcapOptions *pcap_opts = opts->pcap;
++ const NetdevPcapOptions *pcap_opts = opts->u.pcap;
+ NetClientState *nc;
+ struct PCAPState *s;
+ const char *ifname;
diff --git a/emulators/qemu/pkg-plist b/emulators/qemu/pkg-plist
index 0bdffed0e6e7..1e3e1d47425e 100644
--- a/emulators/qemu/pkg-plist
+++ b/emulators/qemu/pkg-plist
@@ -1,32 +1,34 @@
+%%SOFTMMU%%bin/ivshmem-client
+%%SOFTMMU%%bin/ivshmem-server
%%SOFTMMU%%bin/qemu-ga
%%SOFTMMU%%bin/qemu-img
%%SOFTMMU%%bin/qemu-io
%%SOFTMMU%%bin/qemu-nbd
-%%X86_TARGETS%%bin/qemu-system-aarch64
-%%X86_TARGETS%%bin/qemu-system-alpha
-%%X86_TARGETS%%bin/qemu-system-arm
-%%X86_TARGETS%%bin/qemu-system-cris
+%%NO_X86_TARGETS%%bin/qemu-system-aarch64
+%%NO_X86_TARGETS%%bin/qemu-system-alpha
+%%NO_X86_TARGETS%%bin/qemu-system-arm
+%%NO_X86_TARGETS%%bin/qemu-system-cris
%%SOFTMMU%%bin/qemu-system-i386
-%%X86_TARGETS%%bin/qemu-system-lm32
-%%X86_TARGETS%%bin/qemu-system-m68k
-%%X86_TARGETS%%bin/qemu-system-microblaze
-%%X86_TARGETS%%bin/qemu-system-microblazeel
-%%X86_TARGETS%%bin/qemu-system-mips
-%%X86_TARGETS%%bin/qemu-system-mips64
-%%X86_TARGETS%%bin/qemu-system-mips64el
-%%X86_TARGETS%%bin/qemu-system-mipsel
-%%X86_TARGETS%%bin/qemu-system-moxie
-%%X86_TARGETS%%bin/qemu-system-or32
-%%X86_TARGETS%%bin/qemu-system-ppc
-%%X86_TARGETS%%bin/qemu-system-ppc64
-%%X86_TARGETS%%bin/qemu-system-ppcemb
-%%X86_TARGETS%%bin/qemu-system-s390x
-%%X86_TARGETS%%bin/qemu-system-sh4
-%%X86_TARGETS%%bin/qemu-system-sh4eb
-%%X86_TARGETS%%bin/qemu-system-sparc
-%%X86_TARGETS%%bin/qemu-system-sparc64
-%%X86_TARGETS%%bin/qemu-system-tricore
-%%X86_TARGETS%%bin/qemu-system-unicore32
+%%NO_X86_TARGETS%%bin/qemu-system-lm32
+%%NO_X86_TARGETS%%bin/qemu-system-m68k
+%%NO_X86_TARGETS%%bin/qemu-system-microblaze
+%%NO_X86_TARGETS%%bin/qemu-system-microblazeel
+%%NO_X86_TARGETS%%bin/qemu-system-mips
+%%NO_X86_TARGETS%%bin/qemu-system-mips64
+%%NO_X86_TARGETS%%bin/qemu-system-mips64el
+%%NO_X86_TARGETS%%bin/qemu-system-mipsel
+%%NO_X86_TARGETS%%bin/qemu-system-moxie
+%%NO_X86_TARGETS%%bin/qemu-system-or32
+%%NO_X86_TARGETS%%bin/qemu-system-ppc
+%%NO_X86_TARGETS%%bin/qemu-system-ppc64
+%%NO_X86_TARGETS%%bin/qemu-system-ppcemb
+%%NO_X86_TARGETS%%bin/qemu-system-s390x
+%%NO_X86_TARGETS%%bin/qemu-system-sh4
+%%NO_X86_TARGETS%%bin/qemu-system-sh4eb
+%%NO_X86_TARGETS%%bin/qemu-system-sparc
+%%NO_X86_TARGETS%%bin/qemu-system-sparc64
+%%NO_X86_TARGETS%%bin/qemu-system-tricore
+%%NO_X86_TARGETS%%bin/qemu-system-unicore32
%%BSD_USER%%bin/qemu-arm%%STATIC%%
%%BSD_USER%%bin/qemu-i386%%STATIC%%
%%BSD_USER%%bin/qemu-mips%%STATIC%%
@@ -37,9 +39,10 @@
%%BSD_USER64%%bin/qemu-sparc64%%STATIC%%
%%BSD_USER64%%bin/qemu-x86_64%%STATIC%%
%%SOFTMMU%%bin/qemu-system-x86_64
-%%X86_TARGETS%%bin/qemu-system-xtensa
-%%X86_TARGETS%%bin/qemu-system-xtensaeb
+%%NO_X86_TARGETS%%bin/qemu-system-xtensa
+%%NO_X86_TARGETS%%bin/qemu-system-xtensaeb
%%SOFTMMU%%man/man1/qemu.1.gz
+%%SOFTMMU%%man/man8/qemu-ga.8.gz
%%SOFTMMU%%man/man1/qemu-img.1.gz
%%SOFTMMU%%man/man8/qemu-nbd.8.gz
%%SOFTMMU%%@sample etc/qemu-ifup.sample