aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/snes9x
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-09-29 11:41:37 +0800
committerkris <kris@FreeBSD.org>2002-09-29 11:41:37 +0800
commit71c60a6f08bf57785a2f1279f4b54111baf16a23 (patch)
tree561da2cd410d2c5dbbd36b3a17742429d4b5f74c /emulators/snes9x
parent58caa5a6e1b8302ed16eca36b580f7b7ebc590c7 (diff)
downloadfreebsd-ports-gnome-71c60a6f08bf57785a2f1279f4b54111baf16a23.tar.gz
freebsd-ports-gnome-71c60a6f08bf57785a2f1279f4b54111baf16a23.tar.zst
freebsd-ports-gnome-71c60a6f08bf57785a2f1279f4b54111baf16a23.zip
Fix build (chase libusb to libusbhid)
Diffstat (limited to 'emulators/snes9x')
-rw-r--r--emulators/snes9x/Makefile2
-rw-r--r--emulators/snes9x/files/patch-aa6
-rw-r--r--emulators/snes9x/files/patch-af6
3 files changed, 7 insertions, 7 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 7d99994f83a0..ec3c158bbafa 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -27,7 +27,7 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" \
USE_ZIP= YES
WRKSRC= ${WRKDIR}/release
-.if exists(/usr/lib/libusb.a)
+.if exists(/usr/lib/libusbhid.a)
MAKE_ENV+= USB_JOYSTICK_SUPPORT=yes
.endif
diff --git a/emulators/snes9x/files/patch-aa b/emulators/snes9x/files/patch-aa
index 0fb8a334afe4..b86fedec824e 100644
--- a/emulators/snes9x/files/patch-aa
+++ b/emulators/snes9x/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Feb 28 15:29:58 2001
-+++ Makefile Sat Mar 24 23:16:22 2001
+--- Makefile.orig Wed Feb 28 12:29:58 2001
++++ Makefile Sat Sep 28 20:50:19 2002
@@ -4,7 +4,6 @@
#SPC700ASM=1
NETPLAY=1
@@ -51,7 +51,7 @@
+ifdef USB_JOYSTICK_SUPPORT
+CCFLAGS += -DJOYSTICK_SUPPORT
-+EXTRALIBS += -lusb
++EXTRALIBS += -lusbhid
+endif
+
#-DSOUND
diff --git a/emulators/snes9x/files/patch-af b/emulators/snes9x/files/patch-af
index 3b4bb724326c..c80a45a0ad5f 100644
--- a/emulators/snes9x/files/patch-af
+++ b/emulators/snes9x/files/patch-af
@@ -1,5 +1,5 @@
---- unix/unix.cpp.orig Wed Feb 28 16:12:23 2001
-+++ unix/unix.cpp Fri Sep 20 14:58:01 2002
+--- unix/unix.cpp.orig Wed Feb 28 13:12:23 2001
++++ unix/unix.cpp Sat Sep 28 20:16:36 2002
@@ -51,9 +51,11 @@
#include <ctype.h>
@@ -63,7 +63,7 @@
+#include <dev/usb/usbhid.h>
+#undef class
+
-+#include <libusb.h>
++#include <libusbhid.h>
+}
+
+#define JOYSTICK_MAX_BUTTONS 16