aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/vice
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-02 13:41:50 +0800
committerbsam <bsam@FreeBSD.org>2013-09-02 13:41:50 +0800
commit76068bedb30bd66dfe3e9cc6d7d202042d4f871c (patch)
tree329b9860cec2b8bc443912ad4a52d7732ffc9db3 /emulators/vice
parentc2ec996ddec2412e5140b829f58ba8dd3bb0a038 (diff)
downloadfreebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.tar.gz
freebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.tar.zst
freebsd-ports-gnome-76068bedb30bd66dfe3e9cc6d7d202042d4f871c.zip
1. Introduce using iconv with arguments:
. lib (default, implicit); . build, . patch. The default is the same, all existing ports stay valid. 2. Introduce variable ICONV_CMD with default to ${LOCALBASE}/bin/iconv. It is intended to get the value of /usr/bin/iconv at recent 10.x. 3. Adopt all ports to using USES+= icomv:build and iconv:patch and change iconv (executable) at Makefile commands to ${ICONV_CMD} at those ports. Submitted by: bsam (me, via e-mail) Approved by: portmgr (bapt)
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 3c90ef7433fe..b7b0b2f60623 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -105,8 +105,7 @@ LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PATCH_DEPENDS+= ${LOCALBASE}/bin/iconv:${PORTSDIR}/converters/libiconv
+USES+= gettext iconv:patch
CONFIGURE_ARGS+= --enable-nls --localedir=${LOCALBASE}/share/locale
# causes vice to crash:
#LDFLAGS+= -lgettextlib
@@ -139,7 +138,7 @@ post-patch:
${WRKSRC}/configure
.for i in da.po de.po fr.po hu.po it.po nl.po pl.po sv.po tr.po
${MV} "${WRKSRC}/po/${i}" "${WRKSRC}/po/${i}.latin"
- ${LOCALBASE}/bin/iconv -f latin1 -t utf-8 < "${WRKSRC}/po/${i}.latin" > "${WRKSRC}/po/${i}"
+ ${ICONV_CMD} -f latin1 -t utf-8 < "${WRKSRC}/po/${i}.latin" > "${WRKSRC}/po/${i}"
.endfor
.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in